Getting error messages don't have permission

This is my second My Passport external drive. My first one worked wonderfully until recently. When I tried to download my last batch of pictures from my Mac only 2,000 out of 6,000 would transfer to the MP external drive. I kept getting messages saying that “you don’t have permission to copy these files” or that “the format of the file is unreadable.” I am using the same computer, the same cameras and the same editing program that I have always used.
I thought that it was giving me these messages because my first My Passport was full, so I bought a second one. The same thing happened when I plugged in my new Passport. I only got a couple hundred pictures out of over 6,000 that I was trying to transfer. I noticed that the files that actually were recognized and transferred were the old files that I had taken off my old Passport when I had needed to use them. So, all my new pictures are not being accepted for some reason. Can you help me fix this issue? Thank you.

Hi vonda_lavway,

In which file format your My Passport has been reformatted?