"Getting content info" won't stop

Hi there,

I am new to this forum – so hello everybody!

I own the the “WDTV Live”, connected by wire to my home network and internet. I have set the “Get content info” to automatic. It has been working very fine, downloading most infos automatically – and when it had all info, it stopped, and the message “getting content info” disappeared, as it should.

But now it does not disappear again, after all info is downloaded… it showing me “getting content info” now for hours. I did a restart through the device – but no change. It’s quite annoying.

Does anybody encountered the same issue – and has solved the problem somehow?

Thanks for any help on this.


Im getting the same problem as you did start another thread a few days ago,ive set mine to manual for the time being incase its a bug.

Have you tried resetting the player to factory defaults.

Are you sure that its got all the content.

Have you tried changing from auto to manual and then back again to see what happens.

I haven’t reset it to factory defaults yet. Sounds it’s worth a trial.

Even if it would solve the issue for now, what would prevent it’ll happen again? I really wouldn’t want to do it now and then if the error should appear again.

Did anybody did it, and solved the issue that way? Did it solve it, and this error didn’t appear again?

But I did change it from auto to manual and back again though with no change: As I put it back to auto, the message on top of the screen appears right away. Even if not a single file was changed.

“Are you sure that its got all the content.”
My WDTV Live found the contents even while copying the files to it, and even when it was switched off. If he didn’t find any contents (i.e. because of strange file name) he wouldn’t try again – and I added these manually by altering the search phrase. I want him to look once, if he finds it automatically fine, if not, fine too, I can add these really rare cases manually.

So, in fact, he may not have all the content – but before the issue appeared, I didn’t get caught in that loop trying to find it.

I’ll keep you updated as soon I have reset it to factory setting, which I will do tomorrow. 
Meantime I’ll put it back to manual mode.

Thanks you both for your help so far. 
Hope we’ll get it solved soon. Any hints are still very welcome.


Can I just say that resetting to factory defaults is no big deal. If you have any problems you should do this first. It may or may not sort out your problem but its always worth a try. 

Uploaded 5 new movies today - seem stuck on ‘Getting content info’.  Some movies very new and no data on TMDB.

Last updated movies/content on my LiveTV Hub 14 days ago with no problems at all.

What has happened over the last two weeks. 

Have turned off/on Media Libary and Content Updates - still showing “Getting…” some three hours now. It never

took this long ever!

Have done a manual “get content” on each movie, but when I turn back on Get Content to Auto - just stuck there on the main screen “Getting content info”

Update…  Looking at the API used at themoviedb - things have changed in the last few weeks

I always named my files with the release year, ie “Brave 2012.avi”. I have a web app that uses the API at thmoviedb and searches for older movies (like Brave 2012) still work, but newer releases (ie Snitch 2013) having the year in the query fails.

Over at themovies api talk site, a developer for them named Travis Bell describes changing the v3 API (May 10, 2013) to use the whole query as a “phase” and that the numeric year must be part of the movies’ title or fails to return anything.

I did notice when I did a manual content fetch I had to edit out the Year from the Search (filename) name.

I think the WD LiveTV firmware is having a problem with the new api changes.

So, I have reset my WD TV Live to factory settings – no change. As soon as I put “get content info” to auto, the message “getting content info” appears right away. (I haven’t added any videos since my last post).

 So, if what The_Cat wrote is, true it seems we have to wait for a firmware update?

Actually I wouldn’t understand, why leaving away the year would be a good thing – so many movies having the same title…

What you have to remember is that the info comes from databases that WD have no control over. These databases are constantly being updated by users together with the actual operating program / api. It may be that it is being caused by something at the tmdb end which appears to be in a constant update.

Quite so.

They didn’t have control over it before – but it worked then. So I am still hoping to get it fixed through the next firmware update.



Follow Up: 

  1. I removed the Movies from last week – still “Getting content info”

  2. I reset my WD LiveTV Hub back to Factory Setting – still “Geting content info” for 3 hours…

Seems to me that it was not new content that caused this, but something else.

I have notices that three files in the “.wd_tv” directory keep having there date/time stamps updated every minute.




Sure wish there was a way to find which stuff/file is causing this. But I think we will have to get an update to the firmware to resolve this…

How does one contact WD to get them to know that we are having problems?

I have contacted customer care at Western Digital about it and asked them the follow this thread.

So any more information on this issue is well placed here – please post your experiences.

They have replied and assured to pass it on to the technicans there:

"Dear Ronen Schmitz

Thank you for contacting Western Digital Customer Service and Support. My name is [Deleted].

I will pass the information a long to back offices to have them look into the issue and hopefully in a future firmware update they will resolve this but right now I have no further information about that as we don’t have direct contact with engineers. 

If you have any further questions, please reply to this email and we will be happy to assist you further. 

Western Digital Service and Support


I did the same,I even deleted all my metadata and xml files, even though it didnt work.

so as everybody else I left it on manual.

I deleted all of the content on my WD TV Live Hub’s HD via network share after turning off the Media Lib and Auto Content.

Deleted the .wd_tv and .micocrawler_cache directries. Reset unit using hole and paper clip on bottom to restore to factory setting.

Truned back on Media Lib and Auto Content, since there were no files on the HD I got the Media Rebuild banner - quick flash - and the Getting Content info banner - a quick flash - It was gone  - Yea…

Now here comes the fun part. I put back one movie and got the Media Lib update and Get Contect info - both a quick flash. I next put a TV program (Bones) on the HD and again both banners flashed quickly and went away as normal.

I next copied back onto the HD the “Sample Media” folder (originally on HD) and its Music, Photo and Video folders and their content. ( I assume that they were all public domain stuff)

I got the Media Lib banner flash, but the Getting Content info did not go away. I next deleted the Video folder and it contents but it did not change the results. I next deleted the Music folder and it contents and did a Setup/Media Lib clear and the Getting Content info flashed and went away.

I next added a mp3 and m4a files from my iTunes Music and the Getting Content info did not go away. When I deleted the music files and went to setup medial lib clear it went back to normal - Getting Content info flashed and went away.

Thinking that maybe its a DRM issue I downloaded a public domain mp3 file on to the HD and the problem returned.

I have been on the phone with WD Support - Level 2 to report my finding, They had no known issues relating to Music.

Hope this helps others.

This issue has been bugging me since the latest FW update.  I have noticed that having the year in the title doesn’t work anymore with the content search. 

I find when I try to do a manual content search,  and I have a movie file with the name  Movietitle (2013).mp4

the content search no matter how long the file name drops the final ) after the year.

I think their tool is dropping characters

Just found this thread - having a similiar problem as everyone else, ‘Getting Content info’ won’t go away.  Also, I have noticed that some of the most recent movies I have added do not have meta data.  The .metathumb and .xml files are not loading.  When I try to manually get content the ‘get content info’ is not showing when I go into options on the controller. So I can’t even force WD to find the data.

Samples - various naming formats and file types…

Movie 43 (2013).avi, Quartet (2012).mp4, 21 and Over 2013.mkv

I was having the exact same problem – specifically, that the WD TV Live Streaming player (v3, current firmware) wouldn’t Get Content Info (either manually or automatically) for any movie on any source ***IF*** that movie filename includes a year. 

Western Digital Level 2 tech support tells me that YES, that’s the the way it’s supposed to work.  The guy I spoke with was emphatic that the movie FILENAME couldn’t contain a year or anything other than the simple movie title.  Containing folder can be whatever.

That seems wrong to me.  I thought the preferred naming convention was TITLE (YEAR).  But WD Level 2 Tech Support told me otherwise. 

It’s a recent change with themoviedb.org  scraper (months). WD just has to release a firmware update to compensate for the changes made. XBMC scrapers using the same DB have been updated and work just fine with the movie year in the name in parentheses. Not having the movie year in the title of the file is sort of silly as hollywood recycles constantly.

This issue is now fixed with Firmware 1.16.13 (released on 7/23/13).