Get My Cloud to show in Windows 10 File Explorer Network

Thanks again Bennor. Its strange because I had saved the downloaded file from prior, and was able to find it and install the My Cloud folder and all appears to be working as it was… My end goal was to have a folder on all my PC’s that acted like a google drive folder, so I can easily drop files from 1 pc, and pick it up on another PC using the same “My Cloud” folder. I’m still playing around with that, and not sure I have it working exactly the way it should… but time will tell.

Anyways, although I’m not able to see the My Cloud drives in the “Computer” section of Network, I was able to accomplish the same end goal (able to browse the file structure) and get the devices to show up properly in the bottom under the “Storage” section. I have 2 my cloud devices (a single bay unit, and a PR2100), and on 1 pc, the single bay unit actually showed the My Cloud icon correctly and allowed me to right click, choose open, and it would display the file structure - same as when it showed up in the “computer” section.

After setting up other computers - I was never able to see the proper icons again in the “storage” section, and although it said My Cloud - there were no usable options when right clicking except to open the IP website of the device - there was NO way to browse the file system.

I was able to fix this and have BOTH of my My Clouds show their proper icons, and now when I right click, it gives me an “OPEN” option in the context menu, and allows me to browse the file structure perfectly. All I did was go to DEVICE MANAGER, and under SOFTWARE DEVICES, I found both My Cloud devices. I right clicked on each one, and UPDATED the driver (Search Windows Automatically) and it found a driver and auto-updated it. This caused the device to be moved from that “software device” and put into its own “Western Digital NAS” section. This also updated the icons to show my actual device in the storage section, and now when I right click, it works perfectly.

Hopefully this helps someone else out.

One more way:

  1. Upgrade device firmware to My Cloud OS5 My Cloud
  2. Enable in windows SMB2 How to detect, enable and disable SMBv1, SMBv2, and SMBv3 in Windows | Microsoft Docs
  3. From WD Settings/Network select SMB Protocol: (SNB2, SMB3)
  4. From WD Settings/Network select NT LAN Manager: NTLMv1 and NTLMv2
  5. From WD users, configure admin user (or add a new one) with Read / Write access to needed folder

Now you should able to see your device in Network, it will ask for password that you set above,
if not, try changing the WD device name in Settings/general

@Ghenadie
For the older My Cloud, 1st generation, at this time it does not update to OS5 and probable won’t.

My Cloud OS 5 Firmware Release Note v5.10.122 - My Cloud OS 5 Personal & Network Attached Storage / Announcements - WD Community

I tried editing the local group policy as krausjxotv recomended, but I still was unable connect. still recieved error if I tried the run command and typed in \\192.168.1.200 (example ip),I had to modify the registry
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
set to 1

ref:
Unauthenticated Guest Access - Sysjolt

Two comments. First the OS5 update does not support all My Cloud models. At this time only the following models are supported:
My Cloud PR2100, My Cloud PR4100, My Cloud EX2 Ultra, My Cloud EX4100, My Cloud Mirror Gen 2, My Cloud EX2100, My Cloud DL2100, My Cloud DL4100, My Cloud (P/N: WDBCTLxxxxxx-10)

Second, before one attempts to upgrade their My Cloud device to OS5 firmware they should spend some time reading through the My Cloud OS5 support subforum and see the many issues people are reporting. Between the loss of certain features that are in OS3 firmware and the Indexing issue that locks up the My Cloud for days, one may want to reconsider OS5 until WD fixes the various issues with it (if ever).

Generally with the OS3 firmware single bay My Cloud (first gen and second gen) the inability to see it in Windows File Explorer is typically caused by the Windows SMB1.0/CIFS option being disabled. First step is to check that the option is enabled in Windows. Second step is to check if the Windows 10 Network Type is set to Private. If not and is set to Public one will typically have trouble accessing the My cloud or other local network devices. Third is to check any third party Firewall or Security software. Certain third party firewall programs may block access to local network devices like the My Cloud. Fourth, ensure both the Windows 10 computer and the My Cloud both are using the same Workgroup name and have IP addresses within the same IP Address range (example: both are using IP addresses in the 192.168.1.x range). Lastly, certain WiFi mesh network devices and power line network extender devices may; block access to local network devices, use different IP address ranges than the main LAN network, use client isolation to block local network communication.

1 Like

Wow! Is anybody susseed in any of these ways?
I have ThinkPad E590 (some of these laptops) for those, who ready to help