Get My Cloud to show in Windows 10 File Explorer Network

Here is what I just found with a Google search and it worked for me.

Open the Control Panel select Programs and Features then open Turn Windows features on or off
then make sure the following box is checked, SMB 1.0/CIFS File Sharing Support, your computer will have to reboot for it to take affect. See images below, click on, tap or activate images to enlarge them.

WDMyCloudShowMConNetwork

End results, my My Cloud is back. See images below.

3 Likes
2 MyClouds not showing up on "Network" in windows file manager
Can no longer see MyCloud contents via File Explorer/Network
Mycloud not visible
Cannot See MyCloud NAS drives in "My Network" after changing routers
Compilation of Windows 10 Methods, Steps and Solutions
Cannot access my cloud data via file explorer
My Cloud only available on one of two computers
My cloud not showing up in File Explorer ?
My Cloud not showing in Windows Explorer
Win 10 not recognizing MyCloud
WD MyCloud suddenly stopped showing up under "MY Pc" on Windows 10. Still see it, but can't change anything
Unable to map MyCloud
My cloud no longer in devices & printer
Can't access My Cloud on Windows v1803
Please help, cannot access MYCOUD on my pC
Cannot access/open drive in windows 10 file manager
My Passport is not recognised by my PC win 10
1 of 3 Dell Laptops Not Seeing MyCloud Home Drive
I did a Quick Restore, but still can't access files on the My Cloud from my computer
Cannot connect to MyCloud on Home Network
Network do not see mycloud
Windows 10
Passport 0740 won't show up on Windows 10
After upgrade firmware my WD cloud dont work
Cannot drag and drop files!
0X80070035 The network path was not found
Can't view drive on WIN10 Pro
Pas d'icone My Cloud dans l'onglet réseau rubrique ordinateur sous Windows 10
I can't access the MyCloud dashboard from PC, only from phone
Do I need SMB V2 for my cloud?
My cloud drive activation
Windows 10 PC doesn 't show "My Cloud" map anymore, on other devices Laptop or smartphone no problem
Can't connect to WD My Cloud on home router
My Cloud not visible on network/online after accidental power cut
Impossible Experience trying to connect MyCloud to a different computer on the same network
MyCloud Home and OneDrive - does it work?
Blue Light Not on
Wd Cloud not working please help
HELP! Updated firmware and lost ability to save files from SMB
Mycloud 5TB Drive refusing connections
CAN'T SEE WDMyCloud on my NETWORK
Please Help My Cloud - 6TB
Did the Oct 4 firmware update do this?
What Happened To My Password Protection
Flashing blue lights on My Cloud
Compilation of Windows 10 Methods, Steps and Solutions
How-to restore WDMyCloud Backup on UX2 Ultra?
Hard Reset - Cant see my Cloud - Network
Windows 10 Fix
My cloud homme hd removal?
Read WD Mycloud with USB caddy
Device Offline
Has anyone every gotten MyCloud to work with Windows 10?
Windows-10 cant see MyCloud drives?
Lost access to My Cloud & My Book Live in Windows Explorer (Windows 10)
Lost MyCloud access from Win10 (Android access ok)
My cloud is not working with windows 10
WD Passport Ultra not showing up on Windows 10
Has MyCloud died?
W10 WD Dashboard don't detect SSD and HDD
Cannot access my cloud data via file explorer
Front LED not light up
Access intermittent
How Do I open the MYCloud drive using Windows 7
Open sesame

Interesting wonder why that option was off/disabled? That option has been enabled, I assume by default, on my Windows PC’s since setting them up. Wonder if it’s tied to Windows File Sharing or similar option and if one has Windows File Sharing disabled (say for security policy) that option is likewise disabled.

Edit to add: Added the OP information as General Method 3 in the Compilation of Windows 10 Methods, Steps and Solutions post.

@Bennor
Unknown to me, my desktop is only a month old. I did do the Windows updates when they became available a couple of weeks back. I am just glad the mystery is solved, hope it helps out all those who have the problem.

This solved my problem so see my original post in this topic I created.

That should have a giant red flag and lots of warnings next to it Bennor. SMB1.0 is not safe for networks that are internet facing.

It appears there is also a WD Knowledgebase article covering activating SMB1 in Windows when a My Cloud or My Passport Wireless isn’t being discovered via Windows File Explorer.

This seems to have helped a great deal. I am now able to see what comprises my network but the problem isn’t completely solved yet. I am now able to see these
2019-01-06_1251 ![2019-01-06_1251_001|690x260](upload://uWoWqkK8tav1ynJr86pxYqw4Znx.png

1 Like

thanks, worked for me on new install of windows, I now see my shares on explorer directly. New updates have this option disabled perhaps, but still can’t install proper sw from wd, it cannot find my nas.

maybe the name is not resolved correctly, try the ip address instead. I always use a static IP for my devices, maybe is you can try that.

To fix this problem I had to turn on Enable insecure guest logons using Local Group Policy Editor. Open gpedit.msc, select Computer Configuration, Administrative Templates, Network, Lanman Workstation. Change the setting of Enable insecure guest logons to Enabled.

1 Like

Also, a simple setting in Windows. Opened Network Settings and went to Network Connections>Wireless Network Connection> Internet Protocol Version 4 > Properties > Advanced > Enable NetBIOS over TCP/IP. The default setting of Use DHCP is why none of my NAS drives were showing. Thank you Western Digital for calling me and walking me thru the steps.

1 Like

Awesome. This worked for me. Thank you

after almost one full day of trials, googling, updates, resets, searching… I used your method and IT WORKED !!! Thank you so much!!!

Brilliant! I’ve been struggling with this one for months, Always used to be able to see/copy things to My Cloud Mirror from File manager, then one day WD MCM disappeared.

thank you man you saved me :slight_smile:

So my drive is showing all the issues identified in this thread. Can’t map due to supposed mis-spelling, network view in explorer shows My Cloud as Media Device and Storage device, but not on computer or network, etc.

I’ve tried all the solutions here (enable SMB, enable NetBIOS, etc.). I’ve spent hours on this searching recommended articles and solutions. No joy.

Has anyone found anything else that worked for them? I just want to mount the drive on the network so my PC’s can use it as a backup device!

Many thanks but not worked turning on the SMB 1.0 feature.

Turned it on, than restarted and tried to do the hard reset, with the 5 seconds holding the reset button and not worked, after that the hard reset with 60 seconds and not worked too.

Front light is just orange and not blinking during the hard reset (for both - Long and short reset). I’m still on the same point… any other suggestion ?

Thank you, Luis.

Old Topic - SAME PROBLEM. I have 4 computers at home, 2 desktops, and 2 laptops. The 2 desktops are essentially new machines (1 is a completely brand new build running Windows 10 and the other got reformatted and has a fresh new install of Windows 10). Both laptops are also running Win10.

As soon as both desktops were set up and joined my network, I can see them in the COMPUTER section of the Network folder from both laptops and from eachother. Everything seems to be working among all pc’s. I cannot however get the My Clouds to show up under the computer section. I have a My Cloud 1 bay (not home) and a PR2100. I can access both my clouds IF I type in the IP address into file explorer. As a work around - I have pinned both to Quick Access from here, but this is not my ideal setup. I want to mount folders from the network page (I have usb drives connected also). This WAS working perfectly on my 1 desktop before the re-format, and was working on 1 of my laptops. Now the laptop doesn’t show the my clouds anymore under network, however my mapped drives are still working perfectly fine on that machine. The desktop was also working like the laptop until I reformatted.

I also have WD Access (?) installed on my laptop, which puts a WD icon in my system tray, and if I right click on that, it gives me options to go to either MyCloud on my network. I cannot seem to find this software ANYWHERE anymore. This is not listed on the WD site when I filter by my device. I’ve installed stupid other software listed, and none of it does what I have before. Why has so much changed from just a short time ago??

I should mention that I’ve tried ALL of the above, I have SMB enabled, tried netbios, turned on insecure guest logons through gpedit… selected multiple things from the windows features section of control panel…

Are you running the very latest version of Windows, in particular Windows 10 version 2004?

If so you are not alone. Seems there may be something with that version of Windows 10 that is causing a problem for some users.

Indeed I am on the latest version and build of Win10. Seems as though this is an ongoing issue… Thanks Bennor.

BTW, whats the word on the WD Access software, which was useful. Is that the “desktop app” that was referenced to in the post, that is no longer available and EoL? I found a zip file I had downloaded which installed a WD sync folder (called My Cloud) on my desktop, is this software ok to use?

Correct. The WD Desktop app does not work with single drive My Cloud units running the very latest firmware.

My Cloud Desktop App End of Support
https://support-en.wd.com/app/answers/detail/a_id/28748/

My Cloud Desktop App No Longer Works with a My Cloud or Login Not Authorized
https://support-en.wd.com/app/answers/detail/a_id/25159