General questions to get more back ground of how this WD My Cloud works

Hey Guys,

I open this thread as I have some open question of how this NAS works, which came to my mind while I’m using 2GB version in the last couple of weeks.

So let me begin with data flow.

how are the date flowing during copy, moving, etc.

  • When I connect a USB drive to the NAS. is it like, from USB-HDD → NAS → MacBook → NAS all the way through the network because my Mac triggered the copy comand or is MyCloud smart enough to understand that USB-HDD → NAS?
  • I’m asking because when moved roughly 350GB from a USB-3-HDD connected to NAS, the whole copy process took 6 to 9 hours with at the end max. transfer rate of 25MB/s of the process, starting 2MB/s. 25MB/s is even not half of USB-2 speed.
  • Copy process with Finder was even worser, I got above result using CyberDuck with FTP file upload.
  • How is data flowing when I download from the internet and choose NAS as destination, will the data bypass the PC/Mac, so it goes from Internet → Router → NAS, or not?
  • How is data flowing when I move or copy files/folders/dir within the realm of NAS?
  • My understanding from what I saw, is as long as any comand comes from a Mac/PC outside NAS, all data will flow through this particular device. Conclusion: I should run commands from NAS itself?
  • This enable my next question, I can enable SSH for deeper control of MyCloud, ok at least I could access as root via Cyberduck but doing this, don’t let me run commands, so I think I have to use Terminal but how, I have no clue, or is there a dedicated app/software to install to get acces to MyCloud’s OS to run commands?
  • I understand that over WIFI transfer rate is limited, even my router is able to broadcast in AC, however my Mac operates in N at 2,4 GHz only, with 300Mbit/s. Depending on the quality of the WIFI, distance to router, etc. a net-rate between 5Mbit/s (0,625MB/s) to 120Mbit/s (15MB/s) is archivealbe for my case, this should be ok to transfer some GB in a appropiate time frame. Yesterday I tried to copy 10GB via WIFI to the NAS, expecting max. speed the process would take roughly 12 to 15 mins, even when I dived transfer rate by 3, it should not take more 45 mins perhaps 60 mins max. Yesterday I reached in 45 mins 600MB roughly, than it stucks, 15mins later I quited the process at 600MB. My WIFI network is not that bad. 
  • Further, I’m still backing up 93,5GB job over a Gigabit-Ethernet (1000BaseTX) which I started 14 hours ago, currently at 86GB.

I think you get a flavor where I want to go, I will try to understand how this thing works before I start bashing this device and trash it. Something is strange with this thing.

Ah last question:

Can u tell me which ports I have to forward to get adirect cloud connection rather than bridged? I tried serveral also the officiial UPnP (1900, 5000 and 5001) but havent tried 5350-5351 so far.

thx guys for taking time to answer some or all question.

PS. one last question :slight_smile: : When I want to use Safepoint, I will use, as I dont really trust MyCloud so far, how is the process? Can I leave the Backup HDD in NFS? The backed up data, are they somehow crypted so I have to use MyCloud to access those data, or it’s possible to connect to my Mac and access the backup hdd from there?

hope I have not forgotten any more

cheers :slight_smile:

  1. Mac still handles the actual transfer, even to the USB of the NAS. Only wat around it is SSH.

  2. Depends on how the download is done. Most browsers cache a shadow copy before the actual file is stored in the final destination.

  3. The device starting the physical file management will be involved even if the file doesn’t come/go from/to it.

  4. Nope, no graphical app. Commands are commands. If you don’t know how to deal with them or don’t feel confident enough about it then don’t try it.

  5. 80 and 443 for the WD cloud service. Other services will use other ports.