General Feedback - WD My Cloud OS 3 Operating Software

I still can’t use http://www.mycloud.com/. After I put in my user-name and password I am met with the following and it happens on three browsers.

My Cloud login failure.png

That error’s coming from WD’s own servers.  :cry:

Has been reported.

odd, i never see wd2go in any url

No, and I don’t get it if I click on the MyCloud.com link.

Maybe a ctrl-refresh?

I’ve even tried another computer!

cpt_paranoia wrote:

No, and I don’t get it if I click on the MyCloud.com link.

 

Maybe a ctrl-refresh?

I hadn’t upgraded the firmware for about 4-5 months, mostly since everything was running fairly smooth. I saw that I had missed a couple releases and decided to upgrade to 4.04.00-308. WHAT A MISTAKE. GUI is pretty much non-responsive or non-existent. A reboot usually brings it back but it usually never refreshes completely. My media library appears mostly unavailable over DLNA. If I log in with SSH and the load average is usually in the 20-30’s. I would love to just downgrade the firmware but with no GUI to speak of anymore, I am at a loss. HELP!

GUI is pretty much non-responsive or non-existent. A reboot usually brings it back but it usually never refreshes completely.

It’s probably running the indexing and thumbnailing tasks, like it will after every firmware upgrade.

Rebooting will only restart these tasks.

Either leave it alone for a couple of days (if you have a lot of media) to let these tasks finish, or kill them off:

http://community.wd.com/t5/My-Cloud/Hidden-wdmc-directories-created-by-mcserver-and-photodbmerger/m-p/682091/highlight/true#M7765

My media library appears mostly unavailable over DLNA

Have you checked in the Twonky UI to see what shares it’s now looking at for media?  Firmware upgrades (and most other restarts) trash the Twonky settings. You can address this to some extent:

http://community.wd.com/t5/My-Cloud/FAQ-Twonky-DLNA-Media-Server-Setup-amp-Use/td-p/858810

ps. you shouldn’t have to know these things… the device should ‘just work’. The reality is a little different.

After reading all the posts here about the new and highly awaited OS, i came to the conclusion that if i value my NAS sleep and power on at desired schedule capabilities, i shouldn’t upgrade.

So far since finally relenting and upgrading the NAS, I now have no ability to access the dashboard via the software or IP.

I can ping it and still access the files via mapped drives, but cannot control or configure the NAS at all and so far my thread asking for a solution on this has gone ignored by WD support. Really poor.

and so far my thread asking for a solution on this has gone ignored by WD support.

If you want support from WD, contact WD Support. this is a user forum, not an official Support forum.

I’ve tried clearing the Twonky database and rebuilding.  It’s just terrible and usually ends up with error messages.

This is the latest load value before even the ssh session went non-responsive.  I plan to disable twonky, followed by the Media sharing on each Share and see if I can try to re-enable each one.

top - 11:06:15 up 14:00,  1 user,  load average: 129.21, 116.52, 100.64
Tasks: 128 total,   1 running, 126 sleeping,   0 stopped,   1 zombie
%Cpu(s):  0.6 us, 47.3 sy,  0.0 ni,  0.0 id, 49.1 wa,  0.0 hi,  2.9 si,  0.0 st
KiB Mem:    232320 total,   197312 used,    35008 free,     1472 buffers
KiB Swap:   500672 total,   229568 used,   271104 free,     1024 cached

I guess the point of this post was that this update essentially ruined the MyCloud and it’s essentially worthless at the moment.

At this point, I really just want to return to the previous release and leave it there. 

For some reason, now, MyCloud.com does not like working with Firefox, but is working with Chrome.  Don’t think I’ll be using the MyCloud.com web-site NAS portal.  It’s because the only protection one user-name and one password and if my accdient these details get harvested then all NAS’s connected to a MyClloud.com account get compromised.

I have suggested at least that two factor authentication is used, but I think the suggestion is being ignored.

So, use the MyCloud.com remote access portal with caution.  A lot of caution.

It’s mad. For example, DropBox introduced 2-factor authentication quite some time ago as well as Google and Microsoft.

So, within the MyCloud NAS’s there should ba a built in facility to allow the use of 2-factor authentication on the MyCloud,com web portal and also all the apps.

Until that is done it’ll take me some convinving that WD does really take security on ther NAS’s seriouslty.

Honest feedbaclk.

1 Like

I can’t even find the link to download the software anywhere on your website…could you post it here please?

USB My Book does not connect and mount. When it does connect but not mount, it shows 0K free.

My feedback:

Login page is still really really bad. 

 1/  On chrome is needs Login to be pressed twice

 2/ If you enter the passowrd incorrectly, and then type a new password, it needs to clear the old error.  You have no idea where you are, if the password is still wrong, if it’s an old message.

The Android app and new firmware are really badly broken.  Not sure which has been at fault, but it’s never worked since upgrading, coming up with network errors.   Had several app updates, not of them have fixed it yet.

Other than that, all working as expected.  I have not seen any new features however, it’s just a lick of paint, plenty of existing bugs still present (the login bugs), and some new ones (the broken apps)./

1 Like

For 3rd year running. Not a hickup. It just sits there churning files as it should be together with its backup (a Seagate 3 TB USB 3.0 expansion box). It is set to auto updates and it just works. Except for the last update when it reverted back to DHCP. I only noticed when I couldn’t connect, I just reconfigured it back to static IP and all is fine. I actually I had no idea it updated its OS, until I looked here.

Interface is sleeker, and faster. I haven’t used any app yet. Actually I don’t use any app. I just use secure FTP as posted here by jamalayka or Hamalaya in the FAQ or something like that LOL. 

Drive seems fine as ever, sleeps when it should be and it emails me its backup status.

I use the IOS app, it is faster I noticed.

This thread?

http://community.wd.com/t5/My-Cloud/HOWTO-Securing-ftp-server-with-encryption/td-p/868664

I had it bookmarked. Maybe time for me to implement it…

I definitely like the white.

Homepage is abysmally slow… I keep getting the chrome “page is dead” error, and I have to tell it to “wait” as eventually the page does respond, but it takes forever.

I just got my Amazon S3 backups working, my SUGGESTIONS for the next release:

a) Call it “Access Key” and “Secret Access Key” (not private key), because that is what they are called

b) a little more help on what “Remote Path” means (the bucketname), being new to S3, I was not putting that in correctly

c) PLEASE support default setting of downloading with storage class “Infrequent-Access”, otherwise have to go and manually change after the backup is completed.

Thank you!

cpt_paranoia wrote:

This thread?

 

http://community.wd.com/t5/My-Cloud/HOWTO-Securing-ftp-server-with-encryption/td-p/868664

 

I had it bookmarked. Maybe time for me to implement it…

Yep, that is the one. OOps spelled her name wrong sorry :angry: but very close :smileyvery-happy:

You know I hope whoever wrote OS 3.0 is not the same folks doing the new WD Community Web site

1 Like

updated to new firmware last night. http into dashboard , get a splash screen, briefly logon screen which dissappears before you can do anything with it. tried chrome, it 7,8,9 and edge.