General Feedback - WD My Cloud OS 3 Operating Software

I’m a general user who simply wants to be able to easily backup my various devices and serve our media (pictures/movies etc).  Since this update things have gotten significantly WORSE.  This device has always been slow to what I would expect out of a modern day NAS but it worked relatively OK.  

The looks and feel is fine but functionality has suffered. 

So far I’ve only attempted to access and interact with the Dashboard (black icon) and the My Cloud (white icon) on a Mac Air.  Some of our other devices are PCs so I’ll have to check those tomorrow.

If I click the My Cloud alias it opens up about 5 different windows prior to opening the My Cloud client which looks like it has not changed.  THe extra windows are finder windows opening each of the various top level folders we have like pictures, music, public etc.  

Everything about interacting with the My Cloud Mirror is now significantly slower.  If I try to use a Mac finder window to access pictures folder it has gone from painful to unusable.  Sometimes 5-10minutes to show a folder that has one #&^$ picture in it!   Copying is still about 4mb/s so no change there.  THis is using the default AFP.  SMB might be worse now, completely unusable.  Sometimes searches just time out now. 

It appears you’ve managed to mess up the Camera Backup from the Backup tab on Dashboard.  It now creates an entirely new directory structure within my PIctures folder instead of dumping dated folders.  The new folder is the name of the camera and it’s super long : Canon Inc. Canon EOS REBEL T3i_00.0    THe dated folder are in there but since I’m using a Mac there’s no easy way to merge the folders.  There’s no reason to break up pictures by the device that took them so please fix this ASAP.  Fortunately I was smart enough to not delete the original copy of photos so I can copy again AFTER you fix this.  

The WD My Cloud app for mac is also displaying v 0.0.0 so is that normal, I seem to recall it had a version number.

I do really like the new pie chart, that’s nice.  

I’ll try my PC tomorrow and see if it is any better and edit this post accordingly.  I don’t expect performance to be A+ given I’m using Wifi but I don’t expect it to get worse after the update.  

So far, time machine backup seems to be working - somehow it manages to find the disc a LOT faster than the finder window would!

An Update…

  The mystery of the Capacity value showing amount “in error” is resolved.   I have a 3Tb My Cloud with a 3Tb USB drive attached.  I use the USB drive for safepoints and other non critical stuff.   I have set the USB Sharable switch “ON”.   The MyCLoud is calculating the total amount of free space (internal AND USB) and displaying that value.   If I set USB Shareable = off, correct (for internal drive only) free space is shown.  

   In retrospect, I think showing total free space is a good thing so that issue withdrawn.  Still love to have the netwrok monitor window on teh dashboard though.  

tim/waldo

User Interface:

Personally I hate this white look. There is nothing “clean” about it. It just looks plain, boring and, frankly, unpleasant on the eyes. Much prefered the dark scheme.

It seems “clunky” in terms of performance. Things take too long to happen and sometimes just don’t happen properly, like not all the items appearing unless you select something else then come back again (like a bad web page). When Dropbox is installed in the Apps it takes AGES (20 seconds) for that to appear in the list of apps after I’ve clicked on Apps. I don’t mean to appear after installing it, I mean when it has been installed for several days. I login to the dashboard, click on Apps and it is like watching paint dry waiting for Dropbox to finally appear in the list of installed apps.

As someone else said, scroll bars should be BARS, not thin lines that are difficult to get the pointer over properly. Their lack of substance, coupled with the poor colour scheme, makes it hard to notice sometimes that they are actually even there! Take a look at the scroll bars on this forum when entering a post for comparison.

Why does the breakdown of capacity usage on the home page of the dashboard only differentiate into file types if Cloud access is enabled and working? If disabled it just shows a bland how much space is occupied with no graphic chart. If enabled but it can’t see the internet properly (it can’t configure the router) you get the graphic chart (circle) but the figures for the various file types are all 0 and everything is just lumped together under “other”?

Why no Daylight Saving option under Language and Clock?

Why no ability to configure the period of inactivity before the drives go to sleep?

Why has the report on fan functioning been moved from under Storage, Disk Status to Settings, Utilities and then having to click on System Test and wait. Even then all you get is OK. How about putting it back in Disk Status and it reporting the actual fan SPEED in RPM?

Why no proper control over the fan such as setting fan speed/temperature thresholds?

In Remote backups, why can’t the SSH login name be changed when trying to configure a remote backup to a NAS Server (as opposed to another My Cloud)?

General Performance/Functionality:

I’m still getting used to mine but why does it seem to take ages when first browsing my EX2 (either from Explorer under Network or even “net view” in a command promtp) before anything actually shows. The same when trying to map a drive.

I’ve a Seagate Central which is lighting fast in comparison - it is let down by being dire in almost every other way. Yes I’ve done all the bits of setting the four services to automatic (DHCP Client which is anyway, NET TCP Port Sharing/SSDP Discovery/UPnP Device Host which aren’t), but why should I need to? Almost no other device seems to demand these services be set to automatic. My Seagate Central doesn’t need it and it is blindingly fast in comparison both on first and subsequent browsing and drive mapping. Proper servers certainly don’t such as my ancient Centos 6.6 and SBS 2003 boxes

Once it finally decides to tell me what shares it has it seems quite a bit faster, but waiting 15+ seconds to see initially (or map a drive afterwards) is WAY too long. This has NOTHING to do with gigabit ethernet either. If it NEEDS to be on gigabit ethernet to give decent performance then something is seriously wrong. I get very much faster response in comparison browsing/mapping to the shares on a 450MHz PC running XP when it is connected via 10Mb!

Fix the non-sensical drive LED thing when it is in sleep mode. Most every other device in the world shuts almost all it’s lights OFF in sleep mode. So did the EX2 until FW 2.10.302. Silly change that one.

Nice to see the option of doing a remote backup to another NAS Server which is NOT a My Cloud has been added - but how the **bleep** are you supposed to make it work?

Other Comments:

Where is the updated manual? All the links on the WD website only give the OLD manual.

1 Like

I have two MyCloud Mirrors running side by side. One is 3+3 GB the other is 4+4 GB.

  • General

The upgrade came as a complete surprise with no warning or advance information. Maybe I dind’t look i the right place. But even after it came (via Auto Update) I could find no mention of it (2.10.302) and it wasn’t even amongst the firmware versions availble for download on the regular WD site. Some documentation (Release notes for example), showing what has changed would be nice to see.

Even now I am unclear. I received new “Firmware” 2.10.302 and the subject here is “OS 3 Operating Software”. Are they the same thing? If so where do we see that stated? If not, then what is the relationship between them?

My first comment on the update was that Auto Update ran with no regard to ongoing processes. I had about 8 backup jobs running and they were all trashed by the update and reboot. I’ve raised this elsewhere and from now on keep Auto Update switched off. This is obviously not caused by the new OS but rather by the old one which was running before the update. But I guess the same behaviour is present in the new one. But hopefully not in the next.

  • Look and feel of the new user interface

The white screen was a shock but easy to get used to. Most interfaces are white now - even this one we are typing on and noone complains about this one. Black reminds too much of old ascii terminal displays.

Also; as noted elsewhere by many there seems to be much confusion about the behaviour of the drive leds. As far as I can make out the documentation manual is ambiguous. Most of us thought that “drive leds off” when idle was good. But another interpretation was that “off” means" not present" and “on-but-not-flashing” means idle. Someone seems to have decided that the previous implementation was faulty and “corrected” it to implement the latter interpretation. This confused most of us who thought it was fine in the first place.

Despite the drive leds new behaviour I’m still happy that the box goes into idle state properly - the top led blinks slowly off then on when idle. 

  • Dashboard and drive functionality

I see one difference is that now the storage usage statistics and current actvity are presented directly on the first screen whereas before they were on a secondary screen after clicking a menu item. I guess this is why the startup screen is slower to appear now. I was happier with the earier approach - faster start and then choose what I wanted to see.

Hiding away the thumbnails was both good and bad. They were a source of irritation previously cluttering up every directory. But now we don’t know where they are and we have no way to see whether they are maintained correctly so as not to waste space. (eg if we delete or move files)

I’ve had both running for about 10 days since last reboot and noticed one issue. The automatic creation of thumnails stopped after some time during the 10 days. This happened on both units so it seems to be a common effect. I rebooted one box remotely and the thumnails started to appear on my remote App as expected. The other had remote access turned off so I had to wait until I was locally connected again. I just rebooted it and it’s been working frantically with the drives for about two hours trying to catch up…

  • Remote access functionality

I’ve had no technical remote connectivity issues.

As someone else noted the username/passowrd setup can be confusing. This is not really related to the new OS - but since it’s been broulght up already… As far as I can make out when a user is setup on the MyCloud Mirror itself the user name (ie email address), but NOT the password is uploaded to a WD database at wd2go.com or similar. Also the user is informed by email that an account exists and is advised to go to " https://web.wd2go.com/signup.do…" to create a password (again). The thing that threw me was that the requirements for the passwords are different. On the MyCould Mirror I used passwords with lower-case and numbers; on the wd2go site it demands that a capital letter is also present. So my initial password was rejected on the wd2go site. This confused me for a while until I figured out what was going on. Now I have two different passwords for the same account and have to keep remembering which one applies each time I login to something.   

WDSync I have tested recently and nice as it seems it is inadequate to be used as a Cloud Sync program. It lacks the simple common sense to replicate file and directory “moves” on the storage device. Instead, when you move a file or directory on your computer it deletes the copy in the oroginal location on the storage device and proceeds to upload the file or directory again to the new location. this is potentially a tremendous waste of time and data transfer. Imagine moving a directory containing 2 GB of files and having to wait while the whole lot is uploaded again. I really hope this is improved soon!

Also not really related to the new OS, but I see the WDMyCloud android app has improved and now includes browsing of the mobile device itself with “copy” working between different storage units and also between storage unit and local device.  Meanwhile the desktop program doesn’t do either of those (although I guess drag and drop makes up for tha a bit).

First off I have an WD EX4 with Qty:4 3TB WD RED Drives. I’m an IT consulant that recommends what clients should purchase. I feel I made my personal wrong decision and maybe should have went with Synology afterall. 

  • Look and feel of the new user interface

I enjoy the White setup looks nice and clean

  • Dashboard and drive functionality

 Dashboard - I don’t need the Storage size information every time I log in, that should be in the Storage Tab named Usage. Currently this takes 5 minutes for my GUI to come up to even be able to use it. 

 Drive/System functionality - I believe the CPU is tweaked more towards accessing the device and cloud not the GUI Dashboard as it’s painful, and I was expecting OS3 to resolve my issues of performance and hasn’t and only has gotten worse. 

Remote Access-WD MyCloud App Iphone Backup Photos-Doesn’t work well; when I view Activity it takes forever to send anything. My Iphone is 5S and 9.0.2 firmware with plenty of open space. 

I returned my unit RMA and got a new same version one EX4 and I’m disappointed that the firmware 1.05.30 is most responsive comparing to this recent OS3. I chose this EX4 based on my expierence with WD Hard drives throughout my life and the support received for hard drives is AMAZING!!! WD needs to honestly up their game and put more money to this “MyCloud” niche as it’s very important. Sad to say I can’t even provide extra $$$ to get the new version of EX4 that has a better processor and more than 512MB ram, reason why they came out with those because they most likely have MANY customers out there that B*tched about these models on performance(EX2, EX4). 

WD please contact me I need a resolution on my device; please take accountability and fix these issues.

Gramps wrote:

I do not see anything different on my DL4100 other than perhaps the power schedule and MYCloud connects now

 

Oh yea, the WD2Go app does not work on a Windows 10 phone.  Shows the device, shows the shares, then says No network available

 

 

         

In short, WD no longer support Mobile device remote access, instead you have to use a web broswer and login to their website to access files. This sadly doesn’t give the function that WD2Go did.

Quote an email this morning:

“Thank you for contacting Western Digital Customer Service and Support. My name is [[DELETED]].
Your case has been assigned to me regarding the problems of connecting your windows phone to our WD My cloud drive.
We would like to apologize for the inconvenience this has caused.

Currently there is no option with our apps to access the drive remotely on our OS3 platform.
The only way to access your unit remotely is with an internet browser by login on to [mycloud.com]
If this workaround is not a workable solution to the remote access we would like to offer you a refund of the purchase price of your unit once this is received at our collection center.”

I’ve emboldened the particular statement that I still find shocking.

There is an ideas thread on the forum here that tries to get WD to pay attention to users’ requirements (ie function that they have now removed): http://community.wd.com/t5/Personal-Cloud-Ideas/Windows-Mobile-app-for-MyCloud/idi-p/906853

Here’s hoping, as the MyCloud device could be such a good thing. I don’t want to have to send it back to WD for a refund.

Ps, Amazon have suspended its sale too, owing to the feedback they are receiving as a seller.

Regards

1 Like

Dat’s a sad respones from WD

Do you have a link for Amazon?  I still see units offered. Where did you get that info?

1 Like

Gramps wrote:

Dat’s a sad respones from WD

 

Do you have a link for Amazon?  I still see units offered. Where did you get that info?

If you search “wd mycloud” Amazon finds it. I was also refering to the 2GB version btw…

I looked just now and see that the big red box of message has been removed now. I’m guessing they’re (Amazon)  happy to continue selling it. No further information unfortunately.

Please peeps, pop into the ideas thread (linked above in previous message) and smash the Kudos button to get the Windows (and all mobile platform) apps reinstated! I still cannot believe that a company as reputable as WD will leave users hanging in this way.

Regards

Is WDs statement aimed only at the DL4100?

Remote access is working fine for the MyCloud Mirror

I checked for the DL4100 and found   http://www.wdc.com/en/products/products.aspx?id=1450#Tab90

where is proudly says…

Mobilize your critical business data

From anywhere in the world, you are always connected to your My Cloud Business Series NAS with the My Cloud mobile and desktop apps. The mobile app allows you to securely access your business data using smartphones and tablets, and easily share files with co-workers, partners and clients. With the desktop app for PC and Mac computers, you can easily drag and drop files, manage your content and share links to specific files or folders via email.

If that is what they sold then that is what they have to provide even if is takes a new software update ASAP

I notice the distinct lack of detail in which smartphones and tablets can be used to do remote access: no details of which operating systems are supported.

Similarly, no specifics of App availability here:

http://www.wdc.com/en/products/products.aspx?id=1450#Tab3

Weasel words…

I still can’t use http://www.mycloud.com/. After I put in my user-name and password I am met with the following and it happens on three browsers.

My Cloud login failure.png

That error’s coming from WD’s own servers.  :cry:

Has been reported.

odd, i never see wd2go in any url

No, and I don’t get it if I click on the MyCloud.com link.

Maybe a ctrl-refresh?

I’ve even tried another computer!

cpt_paranoia wrote:

No, and I don’t get it if I click on the MyCloud.com link.

 

Maybe a ctrl-refresh?

I hadn’t upgraded the firmware for about 4-5 months, mostly since everything was running fairly smooth. I saw that I had missed a couple releases and decided to upgrade to 4.04.00-308. WHAT A MISTAKE. GUI is pretty much non-responsive or non-existent. A reboot usually brings it back but it usually never refreshes completely. My media library appears mostly unavailable over DLNA. If I log in with SSH and the load average is usually in the 20-30’s. I would love to just downgrade the firmware but with no GUI to speak of anymore, I am at a loss. HELP!

GUI is pretty much non-responsive or non-existent. A reboot usually brings it back but it usually never refreshes completely.

It’s probably running the indexing and thumbnailing tasks, like it will after every firmware upgrade.

Rebooting will only restart these tasks.

Either leave it alone for a couple of days (if you have a lot of media) to let these tasks finish, or kill them off:

http://community.wd.com/t5/My-Cloud/Hidden-wdmc-directories-created-by-mcserver-and-photodbmerger/m-p/682091/highlight/true#M7765

My media library appears mostly unavailable over DLNA

Have you checked in the Twonky UI to see what shares it’s now looking at for media?  Firmware upgrades (and most other restarts) trash the Twonky settings. You can address this to some extent:

http://community.wd.com/t5/My-Cloud/FAQ-Twonky-DLNA-Media-Server-Setup-amp-Use/td-p/858810

ps. you shouldn’t have to know these things… the device should ‘just work’. The reality is a little different.

After reading all the posts here about the new and highly awaited OS, i came to the conclusion that if i value my NAS sleep and power on at desired schedule capabilities, i shouldn’t upgrade.

So far since finally relenting and upgrading the NAS, I now have no ability to access the dashboard via the software or IP.

I can ping it and still access the files via mapped drives, but cannot control or configure the NAS at all and so far my thread asking for a solution on this has gone ignored by WD support. Really poor.

and so far my thread asking for a solution on this has gone ignored by WD support.

If you want support from WD, contact WD Support. this is a user forum, not an official Support forum.

I’ve tried clearing the Twonky database and rebuilding.  It’s just terrible and usually ends up with error messages.

This is the latest load value before even the ssh session went non-responsive.  I plan to disable twonky, followed by the Media sharing on each Share and see if I can try to re-enable each one.

top - 11:06:15 up 14:00,  1 user,  load average: 129.21, 116.52, 100.64
Tasks: 128 total,   1 running, 126 sleeping,   0 stopped,   1 zombie
%Cpu(s):  0.6 us, 47.3 sy,  0.0 ni,  0.0 id, 49.1 wa,  0.0 hi,  2.9 si,  0.0 st
KiB Mem:    232320 total,   197312 used,    35008 free,     1472 buffers
KiB Swap:   500672 total,   229568 used,   271104 free,     1024 cached

I guess the point of this post was that this update essentially ruined the MyCloud and it’s essentially worthless at the moment.

At this point, I really just want to return to the previous release and leave it there.