GEN3 WD TV Live Streaming Media Player freezing @ loading times

Hello all,

I’ll try to be as detailed as possible.  My freezing problem just started.  I have been using the latest firmware(2.01.86) for quite some time now.  I never know when the freezing is going to happen as it randomly occurs, but what I did notice is that it always occurs while loading anything.  

For example, I could be loading up TuneIn Radio to play a radio station.  The radio station loads, music starts to play, but my orange load “Arrow” stays SOLID(it is no longer spinning\thinking) and my streamer is locked.  I can’t even turn it off with the remote.  The only way for it to come out of this state is by pulling the plug.  While it is frozen, the radio station will play the entire time pretty flawlessly.  

This has happened to me with setting up a movie as well. When loading the movie, the movie sound loaded, but the picture froze and the solid “arrow” appeared.  I couldn’t shut it off or do anything else with it. 

My Troubleshooting so far:

  1. I just reset my WD Streamer to factory settings, but this did not do the trick.  

  2. Made sure my switch was working correctly.  My laptop can get a connection on all ports. everything seems fine in that aspect. 

  3. made sure upnp is off on router(as I read somewhere this could be a culprit), but did not work for me. 

  4. Not over heating.  Freezing can occur within 30 secondws of turning the device on(or how ever fast I can make it to whatever I want to watch).  

All help is appreciated asI love my western digital. I don’t understand why this thing is acting up after 2 years of solid use. 

Thank you,


Do you have the same issue when you play files from the USB?


I haven’t tried USB yet.  Either way, it freezes when trying to use online services such as Tune In. 

My problem seems to have been fixed.  I don’t know how.  All I’ve done was uncheck UPNP and Zero Config(In router admin page), reenable them, reset my router, and take out a 10/100 netgear switch I recently implemented into the WD Stream area of my house.  

It’s been a solid week of no freeze.  On Monday, I am going to re-introduce the Neatgear switch and I’ll report back.  

Above is all I’ve done and I have not been getting any more freezes… I couldn’t tell you if this is a coincidence or not at this point, but I’ll give it two more days before I change it up again and re-introduce the new switch.


Hi there,

Have you been using YouTube by any chance?

YouTube has a memory leak in this latest firmware release which cause all of the above symptoms and more! Read this post and it will help explain in more detail how to resolve this issue.

Cheers :slight_smile:

No.  I have never opened Youtube, so I don’t think this problem is exactly the same. 

No worries, just thought I’d ask. Sorry I can’t be of any more help.

I am having this exact freezing problem. Except, I on the USB side. I don’t use any online services at all. Just external HDD. I just started having this problem after the lastest update as well. I can play a video and if during the video I pause, then resume, sometimes it keeps the little orange arrow stuck on the screen while playing. Then the player becomes unresponsive, until I unplug and restard the player.

1 Like

Have the same issue. One thing that i find out that WD TV Live can unfroze if i reboot my desktop

1 Like


Are you connected to the network at all when the orange arrow stays on the screen while the video plays and the player becomes unresponsive?

I too am having this issue with 2 different players with the latest firmware while streaming from my NAS though. I’m trying to make ends of this. 

I do believe there are a few support tickets into WD on this issue though.

I’ve also experienced the movie unlocking when i rebooted one of my Windows 7 machines. Funny thing is this machine has no servers running on it, updated drivers and isn’t the machine that the PC is streaming from. The movies are all stored on a NAS.

This WDTV Live SMP is turning out to be really really sensitive to network activity, which isn’t making it very friendly to the end user.

1 Like

Thank you! I was about to return my newly aquired WD TV Live.

I had a gen 2 unit and bought a gen 3, mainly because I wanted Netflix also. My setup always worked flawlessly with my gen 2 unit.

My setup is also with a NAS. I had constant freezes while listening to my mp3 files in the gen 3. If I chose a CD (a folder) at some point the WD TV Live would freeze while going from one song to another (never in the middle of the song). I had to pull down the power source to restart the unit, no other action would work. I had the orange arrow freeze only once with TuneIn.

After reading this posts, I reinitialized my laptop during a freeze, which had also absolutely nothing to do with the song being played, and it unfreezed.

Please WD, solve this!!



It is truly perplexing as to why computers that are unrelated to the WDTV are causing issues. It seems to be completely random in occurance and none of these PCs are infected with viruses or have anything dubious running on them.

I’m confused.

The PC that affects playback happens to be the Master Browser, but it is also set to be on the entire time. When the issues happen with playback it is never off, nor crashed. It’s simply on…functioning as it always does. I may try to format this PC, but I’m thinking that’s pretty drastic considering I have absolutley no issues with it other than it being the cause of these lockups.

I’m also unsure of what that’ll do since more than likely another Windows machine will become the master browser and will have the same issue.

Very confused.

Hi, @kmederios,

it is really perplexing. And I tried something else. Since I realized it was caused by this one computer in the network, when it happened, I just took the computer off the network (unabled WIFI). Nothing happened. So I took it back to the network, still nothing.

Restartet and… works again.

Really weird.

This week I will try to play with it. I do not really think a reformating is worth it. It has to be something to do with network configuration or home sharing. I will try disabling those things.

 It would be great to have someone from WD reading and replying here!


A different computer on the network is now the Master Browser, so I’ll see if that happens to fix anything. I do wonder however if we all have a certain application that’s causing this issue with the WDTV?

My PC is Window 7 Pro and I know that I do run Steam on it pretty consistently for my gaming needs. It’s hard wired on the network and completely clean of viruses. Windows 7 was installed about a year ago on this particular machine.

I will test and see if other machines are causing the issue, but here’s the thing. There are at least 2 other users reporting the same exact fix of restarting the computer and having their movies start to work again so that to me rules out it being any particular “one off” thing about this computer that’s causing this issue. This is more than likely a WDTV issue that’s happening with a certain semi-common configuration of a PC on the network.

My PC has the following installed that are pretty common:

  • Microsoft Security Essentials
  • Malwarebytes (free version)
  • Steam
  • Skype (not running in the background)
  • Teamviewer 9 (could be it?)
  • Dropbox

The players just froze up this time again. It allowed me to start the movie but then left the arrow and on screen display on the screen and continued playing with the remote being unresponsive.

With that player still frozen I booted up the other player and started a movie with the same result. Movie went on playing with arrow on the screen, remote unresponsive.

I then rebooted all the computers in the house, which usually fixes the issue, but this time it did not unlock the players. I then proceeded to reboot all the devices in the house and it turns out when I rebooted my iPad this time it unlocked the players.

Seriously now my iPads are the culprit? This issue is widespread enough to warrant some review. I’m thinking it’s probably under review already.

simple, this is a DNLA problem

I’ve discussed it before

WD is a DNLA renderer

any DNLA server on the network has the ability to take control of the WD

if a DNLA server is misbehaving, etc … it can absolute crash the DNLA renderer (WD)


I have one server setup for transcoding media to other devices. This server has been turned off however with the same affect. There are no other DLNA servers on the network, I made sure to turn them off. I have turned off the Universal Media Server completely and still have the same issue. I’m almos certain other user’s may not have any other DLNA servers up and running and have the same issue.

Regardless of whether this is the cause, the fault still lies in the WDTV, not the DLNA standard nor servers that work with every other device except the WDTV.

It’s still a problem that needs to be fixed on the WDTV.

I’m experiencing the same behaviour.  Launch a movie, the black box gets stuck in the middle of the TV.  Play a directory of TV shows.  Black box will get stuck in the middle of the TV when you tries to advance to the next episode.

I’ve given up and reverted back to 1.16.  Peace with the wife is much more valuable than v2 of this firmware.