Gen2 missing smb.conf

I was playing around with poweroff command. I found that the gen2 network can handle WOL. The released
firmware sets WOL to disabled. You can use ethtools to set WOL to g. But when I tried to poweroff the device and
see if WOL would work. The SSH disconnected but the blue led stayed on. Not sure why it did not power off.
So I pulled the power plug and allowed the device to reboot. After rebooting I could not map the device to my
windows 10 Pro system. After some testing I found that the /etc/samba directory only contained smbpasswd and the var directory. Since the smb.conf file was missing samba would not run. I looked every where that I could look, trying to find the smb.conf file. But it was no where to be found. I even looked in the GPL source tree. So I did a system only restore and this fixed the problem. Not sure where the smb.conf file was restored from.

The SSH disconnected but the blue led stayed on.

I have a single bay WD My Cloud with V4+ firmware. Not sure if that qualifies as a Gen2 (I don’t think so).

This is the same behavior I see when I use the WD Quick View utility to shutdown. The blue light stays on.

But if you want to restart the MyCloud, wouldn’t it require some power to be on? I guess that is a feature (after all!).

I would love to get WOL working on this model, but I’ve heard from several people here that the Gen1 doesn’t support it in hardware.

Good luck getting yours to work!

I have modified my shares, but here is my smb.conf on my gen2.

 [ global ]
 netbios name = WDMyCloud
 server string = WDMyCloud
 veto files = /:2eDS_Store/.bin/Network Trash Folder/.systemfile/lost+found/Nas_Prog/mirrored/uploaded/.wdmc/
 workgroup = WORKGROUP
 security = user
 passdb backend = smbpasswd
 ldap ssl = no
 local master = yes
 os level = 33
 preferred master = yes
 max protocol = SMB2
 min protocol = CORE
 max xmit = 131072
 smb2 max read = 262144
 smb2 max write = 262144
 smb2 max trans = 262144
 max log size = 10
 log level = 0
 socket options = IPTOS_LOWDELAY TCP_NODELAY SO_RCVBUF=2097152 SO_SNDBUF=2097152
 delete veto files = yes
 unix charset = UTF8
 encrypt passwords = yes
 map to guest = bad user
 null passwords = yes
 guest account = nobody
 dns proxy = no
 use mmap = yes
 use spnego = yes
 disable netbios = no
 strict allocate = yes
 csc policy = disable
 min receivefile size = 16k
 allocation roundup size = 0
 create mask = 0777
 directory mask  = 0777
 force create mode = 0777
 force directory mode = 0777
 use sendfile = yes
 smb passwd file = /etc/samba/smbpasswd
 disable spoolss = yes
 nt acl support = yes
 acl map full control = yes
 load printers = no
 unix extensions = no
 follow symlinks = yes
 wide links = yes
 printable = no

 [ P2P ]
 comment = P2P Folder Share
path = /mnt/HD/HD_a2/P2P
 browseable = yes
 public = yes
 available = yes
 oplocks = yes
 map archive = no
 guest ok = yes
 writable = yes
 # !!properties = "remote_access"

 [ Public ]
 comment = public
 path = /mnt/HD/HD_a2/Public
 browseable = yes
 public = yes
 available = yes
 oplocks = yes
 map archive = no
 guest ok = yes
 writable = yes
 # !!properties = "media_serving","remote_access"

You should be able to use the built-in vi editor to reconstruct the file from this sample over ssh. Samba should start after that. Make whatever adjustments you need.

After the system only restore the smb.conf file was restored. Just not sure where the restore gets the
file. As I said I looked every where I could to find the file.

Not a clue. It does not appear to reside inside the cramfs container that holds most of the protected/backup stuff for the gen2. Perhaps it gets generated on the fly by the restore process?