GDrive Mobile SSD R Series 500g only has 3.79 GB?

Bought it a while back, just needed to use it. Plugged it into USB slot, formatted, it shows in Windows 7 as G Utilities Drive F. I tried to copy to it, but Properties says it only has 3.79 GB. I have not put anything on it. I am not a pro, but I am not stupid either. What am I missing? My other G Drive worked out of the box. Please help, I need to back up. Thanks.

what does Windows 7 Disk Management say ?

that’s the place to look for any unformatted partitions or volumes.

https://support-en.wd.com/app/answers/detail/a_id/8200

Do I have to partition it to use it? Never had to before on previous G drives and other backup drives. I just plugged them in and they worked. But assuming I have to do that, the instructions on the link you kindly sent don’t match my computer, so I am just as lost- but I’ll google it. And I don’t even know where to find Win 7 disk management, hunting around, no go so far. Sorry, I not a newb, just somethings like disk drives escape me. I just want to plug it in and have it work. Thanks for your input though.