G-Raid with Thunderbolt 3 issue with macOS Monterey

Hi I recently installed macOS Monterey onto a 2019 MacBook Pro. All seemed well until I tried to import photos into Lightroom Classic. The G-Raid is in the menu but when you click to open the folder system nothing is visible. This is the same in Photo Mechanic, Fast Raw Viewer and Nikon Capture.
In the Lightroom Classic Library module the G-Raid is visible, the folder system is as it should be and the photos are displayed. Opening a photo in the Develop module gets the message, “The file could not be found”. It is not possible to open a photo from Lightroom into Photoshop however you can open a photo from the G-Raid into Photoshop.
G-Raid Thunderbolt configurator displays, “No device Found”.
Photos from the G-Raid open in Preview.
Disk Utility displays information about the G-Raid, space used etc.
Lightroom Classic and Monterey are the latest versions.
I’ve tried a few different cables.
Other drives are working normally.
Any help would be appreciated. Thanks

Hi @MervynM,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

I found the answer on Adobe. Solved: Lightroom does not recognize photos in external dr... - Adobe Support Community - 12832967
Giving the apps “Full Disk Access” in Security & Privacy solved the problem.
Strange it only affected one drive.