G-RAID Thunderbolt 3 shows "No Media"


#1

I have tried connecting a brand new G-RAID Thunderbolt 3, to 3 different computers now. All them show “No Media” or nothing at all.

Desktop - The Drive shows up as a grey’d out icon in ‘This PC’, when I try to open it, it says ‘please insert a disk into the drive’. A disk? Go to Device Manager and G-RAID Thunderbolt 3 USB Device shows up under Disk Drives. But when I click on properties it shows as being O mb, no media, completely empty. Says device is working properly, ha right… Go to Disk Management and the Disk shows up as “No Media” as well. I can not format or clean or anything. Go into powershell DiskPart to try and clean it but that also does not work. It’s as if there is no hard drives in the enclosure. There is…2 of them at 6GB each. So I removed each drive and hooked them up internally directly to my computer with SATA cables and they connect totally fine, show up at uninitialized drives at 6GB each. Put them back in the G-RAID, turn it on, and nothing. “No Media” The G-RAID light comes on fine, the drives have power, they spin for a bit and then settle, but they show zero space. I’m connecting via the USB-C cable.

PC Laptop - exact same thing happens. Grey’d out icon and “no media”. Tried Thunderbolt and also USB-C to A cable.

Mac OS MacBook Pro Laptop - the device isn’t recognized at all, doesn’t even show up. Funny since this thing is supposed to be plug and play with Mac OS. USB-C to A cable, laptop has TB 2 only.

Is it possible there is some sort of switch or connection not being made inside the actual enclosure? It acts exactly the same whether I have the drives in it or not. If I take them out the drive appears in Windows as the same thing, obviously when nothing is inside 0 mb is correct. But nothing chances when I put them back in.

Regretting big time not sticking with Lacie now, have never had an issue with 4 different RAID drives from them.

I can’t return this where I bought it either since it’s opened, so I’m stuck with RMA hell if I can’t figure out how to make it recognize the hard drives.

Thanks for any help!


#2

After a little more googling, not really any answers, but the most logical explanation seems to be that the enclosure is broken. It did make a rather weird loud noise when it started but everything seems to be working fine and quiet now other than I can’t use it.


#3

In the properties it shows up as MBR partition, which could be the cause of the drives not booting properly as they’re both over 2GB, but there’s no way to change that either. Majorly frustrating.


#4

A drive showing as a device with no media means the computer is recognizing the device as a removable drive like a card reader. The drive should never be recognized as such. If that is indeed the issue then it would need to be replaced.