G-RAID Studio- RAID 0 Lost Drive Partition after first use

I just purchased a G-RAID Studio 6TB Thunderbolt drive. After following the instructions I started transferring my photos to the drive from my SD Cards. I moved about 200GB of data. After the file transfers were complete, I ejected the drive (O/S = macOS Sierra Ver 10.12.2) and powered the unit down by holding the switch on the back of the G-RAID Studio. I powered things back up later and got the following message from my mac “The disk you inserted was not readable by this computer.” It seems like the partition for the drive was lost. I downloaded a trial version of data recovery tools and I still see the data.
I initially moved most of the data off my sd cards and was planning to backup to online storage once I organized the data on the G-RAID Studio. Luckily I stopped after 200GB.

I currently do not have access to 200GB of my data without buying recovery software. First I need my data back and second I need to know if this will happen again. I plan to return the drive if WD/G-tech. are unable to help and explain why this happened.

I tried calling support and they are closed. I also tried emailing support but they require a WD serial number which is not provided on the G-RAID Studio or the HGST 3TB Drives.

Drive was formatted as Mac OS Extended(Journaled)->GUID partition map.

Hopefully someone else in the community has successfully resolved this issue and knows why it happened.


There is no common reason as to why that happened but the partition got corrupted, it can happen to any drive at anytime there is no recourse other than repair software as you’ve found. Normally if there is corruption it is definitely not after a first time use but we recommend the software Disk Warrior to rebuild corrupted partitions. If you use Disk Warrior it will just bring the partition back and everything will continue to be usable as normal.

If in the event it happens again with any drive that same software can rebuild it.

Thanks Rydia. Can you recommend any free software tools that I can use to repair the drive. I don’t feel like spending $100+ on s/w I will only use once.

Hello Rydia,
I just purchased Disk Warrior for $119+shipping and it wasn’t able to fix the issue. I am waiting on their tech support to get back to me. Disk Warrior is unable to mount the drive and says that the drive has an unrecognizable format. I know the data is there since I downloaded a trial version of Disk Drill and it shows the lost partition but I cannot repair without buying the full/pro version of Disk Drill which is $89. This seems like an issue that you WD/G-tech should be repairing since it occurred after first time use. Please provide me with a contact number where I can discuss this further over the phone with WD/G-tech.

Update on my issue:
Disk Warrior helped resolve my issue and got me all my data back :slight_smile: Someone at Disk Warrior logged into my machine and manually rewrote the partition map. Really great service from Disk Warrior’s technical staff. Highly recommend the software since the company believes in providing remote connection support when necessary. Many companies don’t offer this and only rely on off the shelf software to resolve your hard disk issues. I am now very happy with my purchase of Disk Warrior and plan to use it to ensure issues like this don’t happen again.

Hello Oscar,
Unfortunately you are going to have to purchase software to resolve this issue. A Disk Warrior service tech had to remote into my machine to fix my hard drive partition. He was very helpful and fixed the issue in about 10 minutes. You can probably research more and try to do this yourself, however, you risk losing your data if you do something wrong. Sorry I couldn’t be much help and good luck. I do feel that G-raid/WDshould provide a little more support to fix these types of issues especially since we spend so much money on there product.