G-RAID 2T USB flashing light


#1

G-RAID 2T USB powers up but the light on front just blinks. Tried desktop and laptop with same result.

Any hope?

Plugged directly into wall outlet - blinking

Different USB cord (Panasonic with filter) - blinking

No USB cord and the drive light is solid. Plug in USB and the blinking begins


#2

That usually means an enclosure issue or power adapter issue. Verify your power adapter is 12v 4a if it is a G-RAID. If it is the correct adapter and still blinks then the enclosure cannot read the drives inside due to either failure of one of the drives inside or the RAID controller itself.


#3

Yes, the power adapter is the original that came with the drive - APD 12v/4a.

I have ordered an eSATA to USB3 cable that will arrive tomorrow. I did this since the light was not blinking when the drive was powered up without the USB cable attached. When the USB was plugged in, the light started blinking.

If that doesn’t work, can I replace the enclosure as a last resort? If so, what am I looking to purchase? I’m not a techie, simply clueless with a non-functioning drive.


#4

You would need to find a matching G-RAID enclosure. Your unit is probably a GEN4. It should mention something along the lines of G-RAID4 2TB on the bottom, that 4 in the name is the generation so you’d have to match that in order to be able to use the same drives. You could also just try finding a used version of your PN. The PN on the bottom will be something like 0G0XXXX.


#5

Thanks! GR4 2000 OG00271 S/N: MAFB1114200D9D-JM

Googled it but didn’t see any enclosures for sale. Where to look?


#6

Yea! The eSATA-to-USB3 cable worked!! Message popped up that the drive is damaged and cannot save any changes, but I’m able to transfer what’s on there to another drive.

One final question - is there any redemption for this drive or is it simply dead? Reformatting won’t make a difference?

Many thanks for your help!

UPDATE: I managed to transfer all of the data to another drive, erased the data from the G-Tech and restore it as an unpartitioned 2T drive - and all appears well. I’m not about to store any critical data on the drive but it appears to be OK.