G drive shuts my mac down when it mounts


#1

Hi, my G Drive 1 TB firewire does not mount when I switch it on, in fact it causes my Mac to shut down every time I turn the drive on, I have tried it with different cables, and on 23 different Macs. Anyone have an answer to this problem ??


#2

The drive likely has a hardware conflict with a computer at this point. You can try with USB instead of FireWire to see if you have better results. Other than that with a device that old you can switch the drive inside to a new enclosure or move on to a newer device.


#3

Hi , I have tried using USB & Firewire cables but no different, I was wrong in my earlier post when I said it is a 1TB drive, it is a 3TB usb 3 drive, if you had the serial number can you see how old it is, I don’t think i have had it more than 2 years, I would not expect it to fail so soon !! SN isYVJ1K4VD.


#4

The warranty ended a year ago in Sept. 2016 with that device. As I mentioned in the other post your best option in order to try and get access to the data would be to open the enclosure and swap the drive into another external enclosure.

Something along the lines of this: External hard drive enclosure