G-Drive not working on my Mac

Hi everyone, I have a 2-year-old G-Drive that I save all of my video and Premiere Pro projects on. I was working on it today, when suddenly the G-Drive disappeared from my Desktop. It lights up and seems to be working, but it won’t show up on either my iMac or my Mac Air. It’s never been used on a PC, so that’s not an issue.

Here’s everything else I’ve done so far:

  1. Restarted my iMac and plugged in drive again
  2. Tried on my Mac Air
  3. Tried a different USB cord
  4. Checked all of my USB ports to see if the ports were the problem
    All in all, I have done all the obvious to no avail.

I’ve also checked the Disk Utility. My G-Drive shows up, but it says it is not mounted and there seems to be no way to mount it. First Aid also has failed. I’m running out of ideas and losing hope! I talked to Geek Squad at Best Buy and they informed me that I would have to dish out anywhere between 200-1500 dollars in order to recover the files on my drive. As my last ditch effort, I will be going to a media lab to see if putting it in the G Dock ev with Thunderbolt will work. I just need to access my files in this drive one time to move everything! Please help!

Hi @williamchapman,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting: