G-DRIVE 6TB USB3 ejecting unexpectedly

i bought 2 brand new G-DRIVE 6TB thunderbolt 3 + USB 3.1 drives. when using the drive w USB 3.1 on multiple computers (mac pro, macbook pro) with multiple cables the drives eject themselves without warning. sometimes the drives will not spin back up and a restart is required. one machine is on High Sierra the other Sierra, seems to make no difference. energy savers setting for putting drives to sleep is turned off. it seems as if the drive is putting itself to sleep with some kind of internal firmware function. this is beyond frustrating as this happens in the middle of a video edit or export.

It should never happen in the middle of use of the device. If this is the case then the enclosure/cable could be the problem. If you have another USB cable you can try and verify it continues to happen then the hardware on the enclosure is the issue and the device will need to be replaced.

Did you ever get this solved? I am having a similar problem with a brand new MacBook Pro running on High Sierra. It happens with both G Drives using USB 3.0 and an adapter I purchased with this new computer, because it doesn’t have a USB portal. Help, this is so frustrating!

1 Like

yes, for me it was a set of bad cables i bought off of amazon. if you are using after market cables, try the cables the drives came with or the generic “amazon” brand cables.


hej there,

any news on this issue? Have the same Problem that the new Drive ejects unexpected. Currently using Sierra and the original USB-C Cable.

Thats quite annoying to work with this drive.

just tried the USB-C to normal USB. Same behaviour using all the cables from G-Drive :slight_smile:

turns out i had bad set of new USB3 cables. replaced w amazon brand and problem solved.

1 Like

thanks - just have to check if it works with another Usb-C Cable. Unfortunately the usb-c and the usb-c-to-normal-usb has the same behaviour

just tried to work with the usb-c cable of the macbook … looks like you’re right in my case too! :slight_smile:

hope this is the only error … a faulty cable!