FW 2.31.193 broke My Cloud - No USB

Auto updated to 2.31.193 last night and today there was no way I could get My Cloud device to recognize the attached USB storage I had always been using. Hard resets, etc. - nothing worked. I downloaded 2.131.183 and loaded it and now everything works as it should again. I have now turned auto update off and don’t plan to do any further updates as I know what I have now works for me.


@sparksd What My Cloud product are you using? My Cloud (Single Bay), Mirror Gen2, EX2 Ultra, DL or PR Series?

My Cloud, single bay.

Coincidentally I had a similar problem when updating to 183. After a bit of fiddling round, I found rebooting with a USB drive plugged into each of the 2 ports caused them to “re-activate”.
Might be worth a try.

Thanks - tried that, too. Tried every combination/approach I could think of for hours before the rollback worked.

Same here.

@sparksd Thank you for reporting the external USB Drive issue on My Cloud (Single Bay) with 2.31.193 firmware. We’ve been able to duplicate the problem and will be removing My Cloud (Single Bay) 2.31.139 from support.wdc.com replacing ith 2.31.183.

This issue does not affect My Cloud Mirror Gen2, EX2 Ultra, DL, EX or PR models.


Some problem here. After auto-update to 2.31.193 my USB external drive is gone and no chance to activate it. Hope this will be solved soon?

Using WD My Cloud Single Bay 4TB

Auto updated to 2.31.193 last night and today there was no way I could get My Cloud device to recognize the attached USB storage, How can i fixed?

@DaneEder @araujof Thanks for reporting the issue with USB drive and 2.31.193 firmware.
Please install the previous version 2.31.183 to resolve the issue

  1. Click the link below to download My Cloud firmware 2.31.183


  1. Follow the steps on how to manually install firmware 2.31.183

Answer ID 25485 How to Download and Manually Update Firmware on a My Cloud


Thanks for help. Now everything works fine again after downgrading to .183

Before downgrading I tried to save a backup of my iMac via TimeMachine with my WD My Cloud. This did not work either with .193, but now works fine again with .183. Maybe another issue of .193.

Hi SBrown,
I have the same problem on my My Cloud Ex 2 Ultra. Can I take the same file to downgrade the firmware to …183 ?

@PeterS55 This issue posted in this thread is only related to single bay My Cloud with 2.31.xxx firmware code base. I would recommend opened a case with technical support and providing the My Cloud EX2 Ultra system logs as your issue may not be the same. The firmware posted in this thread will not work for My Cloud EX2 Ultra.

No. You need to use the firmware specific to the My Cloud EX2 Ultra. This link should be the previous version firmware for the EX2 Ultra and others that used this firmware file.

NOTE: Proceed at your own risk!!! Unexpected things, including bricking (rendering unusable) the device, can happen when attempting to downgrade the firmware. Backup your device data before attempting to downgrade the firmware.


I had the same issue with the 2.31.193 firmware making the USB connected drive unreachable. I downloaded the 2.31.183 firmware and used the manual process to upload the firmware. After a few seconds, the web interface stopped responding. A few minutes later I noticed the change on the My Cloud’s LED and then some activity on the USB connected MY Book drive.

When I browsed to the My Cloud it still indicated the 2.31.193 being installed, but the "buttons’ to upload new firmware (and search for new firmware) were grayed out. The LED was flashing blue which in looking at the manual it said that this either meant it was in standby or updating firmware.

While waiting for something to change and doing some research on this site, I found something that suggested I reboot the drive, which I did. It came back up with the same flashing blue LED. I now can’t browse to the MY Cloud drive’s web page. I later found a reference indicating that a “pulsing blue” LED was standby and that a flashing blue LED was updating firmware.

When using the WD Access trey tool and looking at the Properties, it shows the static IP address that I had assigned at original installation and a Firmware version of “0.0.-1”. The LED has been flashing blue for about 2 hours now.

Any suggestions?

I ran into the same issue and it was because (for me) that I was was loading the new f/w from a location other than on the My Cloud itself. I did a hard reset -
“At the same time as you plug power into the WD My Cloud device, press the Reset button and hold for about 40 seconds. The device undergoes a system restore and powers on.”
which got me back up and running and then I copied the f/w file to the My Cloud and went through the load process again, which worked. (Note - no files are lost on this reset.)

1 Like

Thanks! After waiting several days to make sure the drive wasn’t indexing (I’m cautious), I did the 40 second reset and it came alive, still with the 193 firmware. I set my static ip address back in and then successfully “update” the firmware back to the 183 firmware. My shares were still there and my USB My Book is recognized properly.

1 Like

Good to hear!

Will this be fixed? Honestly, I’m scared to downgrade out of fear of bricking. I don’t have the time (or the space) to backup this drive. The USB drive was my means to backup the drive lol

Me too. I have the 3 GB My Cloud. thumb drives work but NO USB external. Trying to use a Sabrent EC-GD2B dock. Other devices like my old Seagate Central see the dock just fine. Tried other docks, 2.31.183 and currently at 2.31.195 no love from any.