I have been trying for the past couple of months to get FTP working with the Buzz player App on my ipad.

I have done the following

FTP enabled on MBL

Enabled port forwarding on my router (20-22)

MBL dashboard confirms port forwarding is enabled

The problem I have is that i have no idea what logon details i need to use - i have tried everything that i can think of :slight_smile:

The format that the Buzz player wants is

FTP://servername or IP address/sharename

Any help would be greatly appreciated

I tkink it’s…



Went to try this last night and realised that I had forgotton to advice that the Buzz player also has log on requirements e.g.

It wants the FTP:// details along with logon details ( you can either logon as a “Guest” or “Registered User”). therefore I’m assuming i don’t need to put my username and password in the FTP:// address ??

I don’t have any experience with the Buzz player. I am guessing that the Guest option tries to sign-onto the FTP server as Anonymous byt the VSFTPD daemon has anonymouse sign-ons disabled.  You need to create a user-name and password for the Buzz player and tell the Buzz player to use those credentials.

I have a Network camera. I’ve3 created a user and password on the MyBook Live and programmed the same credentials into the Network IP camera, so when the camera senses motion it saved an image to the MyBook Live.

Works very well indeed.

I could guess all you need to do is, if you want to point the Buzz player to the MyBook Live’s Public folder to use…


But…  The Buzz player might not be able to resolve the Bonjour domain name resolving system and NetBIOS broadcasts so let’s just assume your My BookLive to be at  The FTP path would be . . .

Does that lot above help?

I could hug you !!!

It worked with and then registered user logon of the admin user !!

I had tried this way before yet had used “mybooklivepublicip” rather than just “Public”.

Thank you so much for your help as I’ve been playing with this for at least the last 2-3 months :slight_smile:

OK, so maybe I’m hugging you too soon :slight_smile:

I just called my girlfriend and had her try and logon and it didn’t work, could this be because I’m trying it via my own home wireless??, if so I’m back to the drawing board :frowning:

If you’re trying to grant access to your girlfriend who is outside of your home network then you will need to configure your router to forward all FTP requests to your MyBook Live and I would really recommend A LOT to create another user name with it’s own password to access your files and not use the admin login.

Granting your girlfriend access from outside your home network is down to correctly configuring your router. Also, if you do this I advise you to make sure your passwords a very difficult to guess or get by brute-force attack password guessing.

As you’ve got your Buzz player to access files and play them means that it is all working and any other connectivity issues will be with the router and whatever else will be trying to connect with your MyBook Live.

The FTP protocol is pretty set-in-stone and the VSFTP daemon that is used in the MyBook Live quite a lot of high flying corporations and companies use.  It’s quite a simple and reliable FTP service.


I have enabled port fowarding on my router for the MBL, so I’m assuming that first i need to direct the connection to my actual IP address ??

Would something like this work ?

FTP:// my pc’s ip address/ my MBL ip address/ Public 

Yes. On the router you would create a port forwarding rule that will forward port 20 TCP to  From the Internet your girlfriend would use your router’s PUBLIC IP address and not the internal IP address.

The Router will see that a connection is being attempted on port 20 from somewhere on the Internet and it will forward that connection to port 20 of whatever is located on the LAN IP address

The Public IP address may change frequently so you will need to use the Dynamic DNS service.   You can use http://Dyn.com/ .  Order the premium service but then as soon as it’s ordered cancel the service before the trial period ends. Also, to make sure Dyn.com does not charge you by accident, remove your credit/debit card details from the Dyn.com account.  This company allow you to keep one Dynamic DNS name for free.

You will need to install the DynDNS updater client downloadable from the Dyn.com web site which will update the domain name’s public IP address when it changes. You may be able to get the router to do this, which is better.

This way you don’t need to know the public IP address.  Just the dynamic domain name you registered at Dyn.com which won’t change.  You router and/or the DynDNS client will tell Dyn.com the public IP address every time it changes.

I would recommend taking a look at the BarracudaDrive WebDAV server for MBL and use WebDAV instead of FTP.

See the following for more info:


Have you tried setting up remote access using Wd2Go?

Yes, I have already got WD2go hooked up and this works fine on my ipad and computer, yet the problem i have is that WD2go will only play .mp4 files and all of mine are in .avi format - hence the Buzz player app as this plays everything :slight_smile:

I have at least 1000 movies/TV shows so didn’t want to have to convert each one to .mp4 format and as the Buzz player is able to to accessed from within any wireless environment it made sense to try and get this working so that when I’m away from home i can access my movies and so can my family/friends on their ipads.

Thanks will give DynDNS a go tonight when i get home from work and get back to you

Thing is that the FTP protocol is not a streaming protocol. You’ll have to download the entire media file to your device so the Buzz player app can play the media file unless it can play in real time as it’s downloading.  I don’t have any experience of the Buzz player app.


Right , so i created a .dyndns.org account

Checked that port forwarding was working using an internet tool (start port 20 end port 22 on Ip address 192.168.x.x)

Went on my Ipad at home and entered the following


Choose “Registered User” and entered in my username and password

Result - worked like a charm

Called my girlfriend to get her to try and nope didn’t work


Followed the instructions in your link for SSH.

Went to open my MBL and it goes directly to the barracuda webpage and it wants a username and password, as i had disabled the admin username and password on my MBL to enable SSH i tried the “bd” and my wd2go username and passwords.

No joy, infact now I’ve been locked out as it thinks i’m a hacker !!

If i do get this option up and running what format do i use to login on my Ipad as it requires the following format

ssh://ipaddress or server/share

To say I’m a little frustrated with this would be an understatement, yet I’m not going to give up !!

Hmmm…  If the FTP connection worked for you from outside your network and not from your Girlfriend’s home then the only conclusion I can make is that the remaining issue is on your girlfriend’s computer. If there any firewall on your girlfriend’s computer that is preventing her computer from connecting?

You’ve proven to yourself that the FTP method works.  You only need for forward in port 20.  (Maybe 21).

I assume when you wrote “Went on my Ipad at home and entered the following” that you connected to the Internet through a mobile phone network and not wirelessly through your router?  I live a Linksys router and it has a facility that if from inside my network if I access something using the public IP address of my router then it processes it as if I was on the WAN side of the router even though I’m on the LAN side.  The title of that option on my router is “Filter Internet NAT Redirection” which I has disabled. When I enable this option then my router begins to act dumber and not allow me to make, what I call “Virtual WAN connections” from with my LAN.

PS:  If you don’t want to be charged by DynDNS then cancel the Pro account. They let you keep the domain name for free but you need to have a computer in your house to “phone home” within 30 days of the last “phone home”. This isDynDNS’s way of getting to know if you still want the domain.

It worked from within my home not outisde it, so, I’m thinking that what you are saying is probably right in the fact that it is connecting via the WAN side  from home.

My girlfriend is trying to access it via her ipad with the same Buzz player app that i have using her wireless environment.

Have just checked the apps specs and this is what it says " Supports various protocols RTP, RTSP, HTTP, FTP, MMS, Netstream(mpst://), SMB, ffmpeg://, that allows users to not only play media files from local but also play media files from remote servers and devices. Users can use Buzz player to connect to their IP cameras and servers to play media from them"

So I’m assuming that what i am trying to do is connect remotely to my server via this app ??

I checked my router out yet couldn’t see any reference to the  “Filter Internet NAT Redirection” . I have a Netgear WNR 1000v3.

Any suggestions on what i could try next :slight_smile:

i have success !!!

My girlfriend must have been entering the wrong information as have just been at her place and thought i’d try it while i was there and it worked and i also tried it on her ipad and it also worked !!!

So, if anyone else out there needs to do this then follow these instructions

Create a dns account (refer to Myron’s post earlier) and link it to your external IP address - it will automatically pick this up anyway

Go onto your router and create a port forward to your MBL IP address using ports 20 - 22

Enable FTP on your MBL

Secure your MBL by clicking on the “Secure Drive” (top right hand corner of MBL screen)

Now logon as follows


Note : make sure you use the upper/lower case letters as above

Tap “Registered User”

Enter your username and password (the one you used to secure your MBL)

And thats it you can now access your MBL :slight_smile:

Do NOT forward port 22 from outside your network to your MyBook Live !!!

Hi Myron

Have changed the end port to 21 and it still works. Just out of interest why can’t you use port 22??