Ftp worked but no photos are shown

Weird stuff.

I got a new Live Duo,  installed it, no prob.

I tested it by uploading two folders with pics, just by means of windows explorer.  Installed the WD apps, shows on iPad, no problem, so far.

Then I continued with the settings, amongst others I renamed my drive, checked the box “ftp”, found out how to upload (much faster) by means of an ftp transfer program. Uploaded the rest of my pics (loads of them of course).

To my surprise, I still only could see the pics I uploaded first.  No matter what I tried, it is not showing the rest of the files.  And believe, they are on the drive, no problem there.   I tried removing the drive within the app, and reinstalling it (with a new code), but still only the two folders I uploaded through windows explorer can be seen. Please, don’t tell me this is not to be fixed, 'cause the upload speed in explorer is only 20 kb per sec…

Can anyone shed a light here?




If you did a huge upload it can take hours (even days, depending on qty of photos) for them to show up on the mobile app.