FTP with I.E. and File Explorer don't work

Good morning,
i ve bought a EX2 ultra and i created some shares. Then i allowed FTP access, but i only can access with software like FileZilla. If i try to visit FTP with I.E. and File Explorer (as i usually did in the past with other NAS) it gives an error and dont go.
it works with mozilla (ftp://myipaddress)
i have win7 x64 Ultimate, upgraded Nas firmware.
I tried with FTP active, passive, FXP on and off, TLS implicit and explicit (i tried because i don’t know exactly what it is, so i just tried). Still doesnt work. it only works if i set:
Shares --> (name of folder to share) --> FTP ANONYMOUS read/write.
But it’s not good for me because i dont want anonymous FTP. i want to log in with File explorer like in the past with other NAS that i had.
Where am i wrong? What to set up?
Thanks
Note: i’m trying in internal network so i use internal ip, not WAN ip of course. i just need in my network and i use 192.168.0.199 that is NAS ip address,…as i had always done in the past.

UPDATE: if i use File Explorer with the following syntax:
ftp://user:password@address [exactly: ftp://admin:admin12345@192.168.0.199] it works.
So, the problem is something like I.E. and File Explorer cannot show me the box where to type username and password. This problem is not from my PC, because the same happens with other pc in my network. So, everything starts from NAS.
I still ask you what to set in my NAS to ask me FTP password and work.
Thanks again.

I’m pretty sure this is an “IE only” issue. This will work in any other browser (and apparently also your file explorer)…
For older IE versions, you have to go to the “File” menu and select “Login As”…
I think this is a development choice from MS side… Edge is completely dead for anything FTP, and even in the current explorer version you have to enable the FTP under advanced settings. There is a reason MS has lost about 90% of the browser market :slight_smile:
You are MUCH better off using your file explorer or a “real” FTP client.

no, of course no because i tried from different PC with different IE installed on it, using from winXP to Win10, always the same. i need to visit this ftp using File Explorer, not internet explorer, by the way i tried to add the IP path to SECURE AREA in Internet Explorer, nothing changes. i m using it as:
ftp://username:password@ip

In the older IE, have you tried the “login as” setting in the file menu ? It should work. It may not be as elegant as providing the username/password in the URL, but at least you would have access.

no, i m not using internet explorer, i m trying to use FILE EXPLORER!!!

File explorer works fine. Just use the URL ftp://username@address