FTP timeouts when using both FTP and SMB

I use SMB on 3 computers to access the public shar on a MyBookLive. I also occasionally use FTP to access a private share on that same MyBookLive. Today I was pulling lots of data off the MLB via FTP - several hundred files around 2GB each - using the WinSCP FTP client running on Windows. Twice during this process the data transfer stopped and the FTP connection timed out. (I don’t know whether it was the control connection or data connection.)

When a failure like that occurs, WinSCP tries to reconnect a few times with a 30 second delay in between. The attempts failed - no response from the MBL FTP server. I aborted the effort after 2 attempts. I tried logging onto the MBL dashboard but it hung - no response from the MBL HTTP server.

During the data transfer I had been accessing the public share from Windows with no problem, but that was mostly reading. I know I had just done a write the second time the FTP transfer hung up, and I suspect that was the case with the first hangup, but I can’t be sure. The write to the public share was small so there wasn’t a long enqueue or anything like that.

I know I rebooted Windows after one of the failures but I’m not sure if I did that twice. The reboot would have reset the SMB connection, but it also just took time so I don’t know if the reboot was needed. I did not have to reboot MBL; it woke back up without any intervention. I manually restarted the FTP and its been pulling more files for 2 hours now. with no problems.

Is this a known problem with MBL? Can SMB and FTP access to MBL interfere with each other?

Hi, the only reason that I can think for the MBL to close the connection is because it couldn’t handle the transfer from both FTP and SMB, especially if you have the drive connected on a gigabit network that will surely force the drive to use all the resources.

The drive was connected via gigabit Ethernet, but I was FTPing to a USB3.0-connected external drive. The FTP client was showing transfer rates in the 30-50KB/s range.

But I think a bizarre error in my backup software may have doomed me. Earlier in the day I had tried setting up a backup via FTP using Acronis True image. I did something seriously wrong. After rebooting (and after posting my question on this forum) I did a netstat and found over 100 open FTP connections with the server. I can’t prove it, but I think Acronis was repeatedly trying to restart the connection using incorrect credentials, and failed to terminate each failed connection. After deleting that backup definition and again rebooting I’ve had no problem. (I’ve also not tried pulling 200 2GB files from the server, but I bet I could do it with no trouble now.)

Hi everybody!

I stuck with the same problem. But then left alone FTP for it’s insecurity (Acronis does not support FTPS).

Better solutions/workarounds are:

  • iSCSI;
  • SFTP (FTP over SSH).

The problem with ftp (vanila or FTPS) is the that timestamps are lost when uploading to the MyCloud FTP server. I think that’s the case with SFTP, too. I know nothing about iSCSI.