FTP issue

I have My Book Live Duo 6TB and on MBLD is also connected My Book 3TB USB drive. I can access all shared folder via network. Problem is when connecting through FTP. I can open only shared folders on MBLD but shared folders of USB drive can not be opened. In my ftp program (total commander) only shortcut of USB drive shared folder is visible but it can not be opened. Where is the problem?

not sure…

What happens when you try the USB share?

If you get an error message please post it

Seems there is a bug.

Interestingly enough SAMBA and VSFTPD indicate that I do not have permission to access the USB flash disc even though it’s set as a private share with admin and Myron allowed read/write with my computer correctly authenticated to the MBLD as admin.

The bug in the MBLD’s firmware is that the following line is appended to the bottom of the /etc/trustees.conf file when the USB flash memory stick inserted.


This is wrong.  #usb should not be at the beginning. The line written should be.

[/dev/sdc1]/shares/128MB_USB:*:CU #usb

Actually, #usb I think is not important unless some script needs it to remove the line later.

The right people will see my small wibble about this issue. Think there will be another firmware update in the not so far future.

When I tried to open USB shared folder over FTP I get this error

CWD My_Book_3TB
550 Failed to change directory.

My_Book_3TB is shared folder for USB disk connected to MBLD. As I said via samba I can acces this folder normaly.


I think I’m experiencing the same issue. I have a My Book Live Duo 4TB updated to the latest firmware and a 2TB My Book Live Studio Edition attached to the USB expansion port. When trying trying to access the MBLD via FTP, I can see all its shares, plus the share for the attached drive. When double clicking this folder to access the attached drive, and the file browser refreshes and I’m still in the same listing, as if it hasn’t done anything.

I’m currently using Directory Opus, I’m too probably getting the “Can’t change directory” error.

Any way to report this and expect a fix? Thanks for your support

EDIT: I just tested this with FileZilla, and got the following error when trying to access the attached USB share:

Status: Retrieving directory listing…
Command: CWD /MBSE <---------- THIS MBSE IS THE SHARE FOR THE ATTACHED USB (“My Book Studio Edition”)
Response: 550 Failed to change directory.
Error: Failed to retrieve directory listing

Western Digital are aware about this. Don’t know when the next firmware update will be released. I know why it’s happening but at the moment I don’t know all of the script edits needed to fix the issue prior to a new firmware release.

Thanks for supporting this Myron and for your findings! :slight_smile:

I hope they will look into this soon. I’ve bought the unit to FTP to it while away from home, and having it now working with the attached device really hinders my usability very much.

Thanks again and looking forward to have some progress soon. Regards,

Oh, I forgot to ask. Should I still report this anyway, in order for WD to have yet one more user who is experiencing the same issue?

Is it even needed? Anything I could do to help.


FTP works for the internal storage. For now use that. I’m going to carefully poke around under the hood to see if I can figure out a temporary workaround.  It is a surprise to me too because the USB storage worked before the current firmware release so evento me it is a bit of a mystery how it’s become broken. I do know that this issue has been communicated to the people who are responsible for tinkering with the firmware.

Tell ya what…  Plug in a USB device that you’re having problems accessing via FTP and use the dashboard facility to request support.  In the report mention the URL of this thread within this community.  Also send me a private message with the case ID you get and I’ll pass that on to the people within WD who are interested.  The first level support are good but sometimes a thing like this can get them stuck.

When you private message the case ID and I send it on the the techs behind the level 1 techs can get at your case and MBLD logs which get automatically uploaded and that, I guess, will be of use to them in forulating a fix.

Best idea I can think of a this moment in time.  But remember, before generating a support request from the MBLD’s web dashboard remember to have the USB device that is experiencing issues plugged into the MBLD!

Timmy1024 wrote:

Oh, I forgot to ask. Should I still report this anyway, in order for WD to have yet one more user who is experiencing the same issue?


Is it even needed? Anything I could do to help.



Hi Myron,

I’ve tried the “Request Support” as soon as I got home, and it opens a new blank tab in the browser and stays there. I’ve tried several times and it’s still the same. I think I also have a problem to report with the problem reporting module :scream_cat:

In any case, any other way to try and generate the report? If it’s not possible, then maybe it’s already enough with your reports to WD; if not, I’ll keep trying to generate it!

Hopefully this will get fixed someday.

Thanks again for your continued support on the matter! If you find anything, please let me know


Something seems to be up with your web browser. Temporarily set as default and use another web browser.

Before doing this this, try generate another support request but this time when you’re met with a blank tab, wait.  It seems that the form might not appear until the logs are uploaded.  I think I waited for about 4(ish) minutes before the support request form appeared.

Hi Miron, I still couldn’t do it because I’ve been on a trip and I’m quite busy at the moment!

While I was travelling, I got to read a couple of things in this forum and found out about the hidden SSH menu to enable the SSH interface. What I wonder is if, via SSH, is it possible to access the attached USB device? Just so I could use it meanwhile WD fixes the FTP glitch!

Hopefully yes, if you know would you please confirm this? Thanks again!

Yes. I believe you can. You’ll need to use the Linux system on the NAS to copy the files off the USB device onto the NAS’s disc to work round the issue. It’s not elegant but you do end up with a back-up of the USB device on your NAS.

Thanks Myron!

Just one more question. Do you know if via SFTP the same problem exists with the mounted USB not working? Or it works OK with SFTP?

Thanks! :smiley:

I’ve not reied, but considering that SFTP login is the root user then all permissions are generally ignored and you can upload and download from anywhere.

Actually, slightly changing the subject from the MBL forum I’ve learned how to enable VSFTPD’s FTPS feature so a encrypted connection can be established using FileZilla.  Just requires a SSL certificate to be created, a configuration changed is /etc/vsftpd.conf and a bit of additional port forwarding.

Absolutly excellent.  Why is it not enabled by default?

See: http://community.wdc.com/t5/My-Book-Live/How-to-setup-Secure-FTP-some-times-called-FTPS/m-p/534870#M18212

Great Myron, I’ll look into it and hopefully set it up someday soon!

What are the benefits of having FTPS over SFTP in a FTP/SFTP/FTPS enabled client (in my case, Directory Opus for Windows) for simple file sharing? I ask because the SFTP should be enabled from the start by activating SSH, while FTPS required more mods like in the thread you posted.

Oh, and by the way, are there any security concerns to have to publish the SFTP port (i.e. 22) on the WAN, so I could access it from work? Of course, I’ll change the default welc0me pass to a strong one! :slight_smile:

Thanks for your continued support Myron, it’s really appreciated.

SFTP on the MBL and MBLD gives unrestricted access top the ENTIRE file system on the NAS. If for any reason the root user password is compromised then the uninvided guest will have full access not only to files but also have telnet access.

FTPS involved the VSFTPD. Works exactly like normal FTP except that the FTP link is encypted by use of a certificate on the NAS. Yoyu have to trust recognise and trust the certificate that the FTP client will encounter and from that poinbt on all data, including the FTP user-name and password are sent over a secure connection.

For the external network, what would be great is to useradd a new user for SFTP and block root from logging in remotely, but I think that wouldn’t be possible, right?

I think I’ve read a post from you yesterday about editing some file to hinder attacks by adding a 1 minutes delay between each login, or something like that. Do you know where I could find it?

A million thanks!