FTP error: IP AutoBlocked by PR2100

I’m trying to FTP files from my security software (Blue Iris) which is “watching” multiple cameras but MyCloud “AutoBlocks” the Win10 PC computer ( from FTPing the files (check this out in my last image).

I know the Blue Iris settings are correct because the BI screen has a “Test” button and the test always works the first time. Then the computer IP is blocked. Both computer and MyCloud are on the same network. If I don’t run the test, the first time BI attempts to send a file, the computer gets blocked.

I’ve turned on FTP in both Settings/Network and the Shares folder. I have no idea why it’s getting blocked and how to tell MyCloud to accept the computer files.

Here are my settings:

My FTP settings:

I’m hoping it’s something simple that I’m missing. Is there a way of telling MyCloud to “trust” my computer and accept the files? Thanks for any help you can send my way.

Try using a standalone FTP client (not sure if Win 10 has it built in like Win 7 does) and see if that gets autoblocked as well.

As per your suggestion, I tried FTP Commander. I made sure it wasn’t blocked and sent a text file. It went through just fine and is not blocking access…hmmm

So what does that tell us?

Here are my Blue Iris settings:

Well, it would appear that Blue Iris is doing something that the WD doesn’t like during the FTP session. Does Blue Iris have the ability to create debug logs? That might help.

WD’s documentation is absolutely silent on this…

I cleared the Blue Iris Error log then deleted the block so I would get a fresh image of what happens when the computer connects to the server via FTP. Image of error log below. But something else I noticed…When I setup a mapped drive to MyCloud and tried to save the files from Blue Iris to MyCloud in the public folders or a shared folder, Blue Iris doesn’t even see the mapped drives when browsing for them (even though the drives show up in the Windows explorer)???


This problem is still unresolved. I wonder why someone from WD isn’t chiming in?