FTP Does Not Work


#1

Hello, I Have a WDMyCloudEX4100 with four 4TB disks, I configure one raid5 volume and FTP server, its works fine for a month , but since the volume reached
90% of utilization FTP stops to work, anyone knowks if the WDMyCloudEX4100 have any limit to prevent te volume reach 100%?

Sorry about my english I’m Brazilian


#2

@Suporte_Mandae,

Have you tried to enable SSH on the EX4100 and check if FTP service is running on the unit ?

root@WDMyCloudEX4100 root # ps -aef | grep ftp
root      7248     1  0  2017 ?        00:00:00 pure-ftpd (SERVER)
root      9212  9180  0 20:19 pts/0    00:00:00 grep ftp

If this process is not running that will be an issue. Also have you tried restarting the EX4100 to see if FTP becomes available after a reboot ?

The EX4100 uses ext4 as the backing filesystem for the RAID volume by the looks and this filesystem, can be configured to have space reserved that only the “root” user can write to when it is getting close to full. If you are able to, maybe see if you can delete some stuff that is not required to free up some space, and then test again if the FTP service works. Try and reboot again once the space is cleared as well and test.

Beyond that, they may be indications in the logs on the EX4100 to indicate why the FTP service is not running, but these would need to be access via SSH as well and are cleared each time the unit is rebooted.

Cheers,

JediNite


#3

Hello JediNite

Thanks for answering me.

The FTP server is running, but i cant save files. The log shows a lot of mesages Logon / Logout:

image

The volume has more than 2TB of free space.

I reboot the WDMyCloudEX4100 but still not working


#4

@Suporte_Mandae

What is the IP Address 192.168.1.253 ? Is that the PC you are testing from ?

I just did a quick test on my EX4100 (I don’t use FTP usually), and it looks like you have to enable FTP globally and then also enable it on each share. Is it enabled in both locations in the GUI ?

Cheers,

JediNite


#5

Yes, the IP 192.168.1.253 is the PC im using to test.

The FTP is enabled in network settings and the sharing settings too.

I realy dont know what can i do for recovery this service, its worked fine for more than a month.

Is possible to be any hardware problem with my EX4100?

Cheers.


#6

@Suporte_Mandae

Doesn’t sound like hardware. What FTP client are you using to connect with ?

What happens if you try and FTP from another device on the network ?

Cheers,

JediNite