Frustration: "There is no media in the current folder" and attempts to fix it


#1

Hi,
I just bought and installed the wdtv live and I’m having a problem that makes the unit not usable at all.

The unit can access to shared folders of my servers but it does not find any media file and returns the message: "“There is no media in the current folder”.

My setup:

  1. I have an XP Home Pro-SP3 server
  2. With folder shared with read permissions to “everyone” and full control to specific users. Specific users have a password set.
  3. Very simple user names and passwords with no special chars.
  4. guest login disabled (tried also to enable without any effect)
  5. No firewall/antivirus set (MS firewall disabled)
  6. All other PC (XP, vista & W7) can see the shares from the server and play files without any problem.
  7. Wired network connection (1Gb/s) trough a D-link DGS-2208 switch.
  8. The WD TV Live can connect to youtube, pandora and live365 without any problem.
  9. I have the latest 1.0.1.17 firmware
  10. My Windows XP workgroup is called “FAMILY”, not “WORKGROUP”
  11. There are multiple users set on the XP server, all of them with passwords
  12. I tried creating new shares from scratch, but I have the same problem “no media in current folder”
  13. I tried setting up a DLNA/UPNP media server and that works (but it is not my preferred method, i want to use network shares)
  14. I rebooted a few times the server, I rebooted the Ethernet switch, I rebooted the modem/router, rebooted the WDTV, to no avail.

Initially the WDTV did not even saw my server, then reading on the forum I enabled the network DDE/DDSEM services and now it can see the server but I get the “no media in current folder”.

My media files are in subfolders, not at the top level of the folder, but i cannot see any subfolder either.

Any suggestions on what to check next before I return the unit , will be appreciated! :cry:

Thanks!

–sav


#2

Ok, after browsing other forums I found my problem, maybe it can help somebody else too:
Go to your shared folders and right-click “Properties”, then “Security” tab. make sure that “everyone” is added to the “Group or user name”.
if it’s already there then make sure that “everyone” has read access.
No reboot (neither PC nor WDTV Live) necessary.
Now onto to other issues… :wink:

–sav


#3

I had the same problem. I solved it by going to the folder’s properties and click on the SHARE button (even if the folder already shows as shared) and then click on modify network sharing (top of the 2 posibilities shown).

This by the way does not work for entire drives (root of the drive). You must put all your videos in a separate folder and set the sharing properties for that folder!


#4

issues i have trying these suggestions;

  1. everyone group already there.  cannot edit permissions as i get an error canceling this attempt.

  2. when right clicking on the share, there is no option for sharing.

working from vista.