Fried Control Board---will Replacing help?

Good day, everyone!
So, the short version is I used a laptop charger mistakenly for my External Hard drive and fried a chip. I am trying to recover the data much later now that I have the time to dedicate to doing so. The computer will recognize that a drive is plugged into the USB but will not be able to access it.

Long version;
My Book Essential, 1 Terabyte I plugged into a Toshiba 65W AC Adapter (19V 3.42A) for Satellite Series power cable. It fried a chip, I saw and smelled it immediately. Hadn’t worked since.
Later, I found the correct cable and while now it will power up (LED lights up and will still be recognized as a drive by the computer) but will not initialize or migrate data.
I am able to get it to be recognized as a “My Book” on my older laptop, (windows 7) but my windows 10 just sees it as a blank drive. I am pretty sure I busted the case open irreparably, but here are the pictures I got.

1 2

So I can see the damage. I took it to a computer repair shop of…middling quality and they said they were unable to fix it.

I read other people had similar problems and were able to fix this issue with replacing the chip or by plugging the drive directly into a USB SATA bridge board.
I am, however, not technically versed at all so I am trying to get whatever pieces I need to give to a professional to fix for me.

If I get a new control board, (I found some on Ebay) that is not damaged, would this be a fix for the drive? I had see “fzabkar” had been very helpful with other people’s issues, but I do not know how to tag anyone in these just yet.

Note: I tried all soft fixes prior to this. Troubleshooted, updated drives, etcetera. And yes, my computer was able to recognize it enough to update the drive it needed. (The Windows 7)

I apologize for the long winded explanation! Thank you for any help you can offer.