Had the unit for a couple of weeks now and I’ve had enough. Upgraded from the wdtv hd unit which worked almost perfectly for 2 years. I wanted to take advantage of netflicks etc so took the plunge. It has been a nightmare from the start…

wired network , serviio media streaming. Firmware 1:12:14

random freezes at the start of playback.( on files that worked the day before) Orange progress circle stuck on top, and the remote is unresponsive. The only way to stop it is to pull out the power lead in the back( surely not a good idea.)

this now is a permanent problem, I am unable to play ANY files. You tube etc working fine

i tried a factory reset several times, which sometimes worked but now not at all.

tried rebooting the computer , serviio and the router all to no avail.

havent rolled back the firmware as it has been fine for about a week. Should I try this. (I had the same problem with every firmware since I got it)

in addition the unit doesn’t keep the  a video setting each time I turn it on, every time I have to set the hdmi settings to auto etc as the screen is pink on startup. but I wonder if its a problem with the tv( lg pk250 60" plasma)

the previous wdtv worked on exactly the same set up , so I assume that it’s a problem with the unit not my network etc.

i can’t see any other option but to return it and go back to the excellent  but limited wdtvhd.

handy suggestions gratefully received, but I find it astonishing that a product needs this level of research just to make it work. If its not ready, don’t release it…not everyone has the time and patience to sit reading pages and pages of forum discussions. And not everyone has the confidence or aptitude to implement  advice given in them. This is not a consumer product , it is a project for like minded techno philes

Robust wrote:
but I find it astonishing that a product needs this level of research just to make it work.

I doesn’t, however there seem to be a myriad of configurations out there and thus some incompatibilities. This is only the second time I’ve read about a pink screen, the first time even for the LIVE SMP. If people can’t reproduce it, it’s hard to tackle. In case you only need Netflix, buy a used WDTV Live + which supports it.

Ok, a moment of contrition, after my rant against this box, I  may have found out the problem, and it may be of use to others.

after frustrating attempts to make it work I factory reset the device and tried the vuze media player. Every time it has worked! (Fingers crossed) It seems to be a problem with serviio. Frustrating as it worked perfectly with  the wdtv hd box. Can anyone recommend another  media player  as vuze is limited in its function.

i will see if this is really the problem and try again with tversity etc

by the way I do understand that there are a myriad of configurations,  but the fact that I had come here was very annoying!

and no doubt I will be finding other problems down  the line.

apologies if this was posted in the wrong forum  but the problem solving forum seems a little cold and unhelpful 

Don’t believe the too many configuration arguments that the apologists like to hide behind. Every other streaming player must have to deal with that too, plus, there really aren’t that many settings to configure.
I have has now 3 of the same player (one bricked after a day, one had everything possible go wrong with it, Wd gave me a new one, and this now has the same issues). It’s just a poorly designed device. It reminds me of programs which are developed and rushed through QA/testing. They work to a developer, but when being used by others, bugs are constantly found.

I completely agree with Christian1 … This device is loaded with bugs and WD fails to fix the most serious issues. Instead, they add new features. And, everyone on here hides behind the “have you upgraded your firmware” “its your network setup”, etc, etc … The fact is… the SMP as some serious issues and they are NOT being address by WD! The performance of this little box **bleep**… The fact that I can wireless stream all my movies, including MKV files to all my other devices in my house prove that the SMP has issues streaming/player MKV files. 

**bleep** it, now it’s doing the same with vuze media player…

freezes on title screen with orange progress circle on the middle, remote unresponsive.

used it yesterday fine, today nothing works…

can any one recommend a streaming software, twonky, tverstity etc.

havent used it much in recent months so its really frustrating that now I’m on a break from work it doesn’t function.

so looking to get a refund, unless a solution is forthcoming. 

Very disappointed that only “the community” seems to respond, and no one from WD.

This is a user to user forum. If you are really lucky somebody from WD occasionally responds.