So I’m playing a video off the internal hard drive when I decide to pause it.  About two minutes later I try to unpause it and nothing happens.  I even try to hit the power button on the remote.  Still nothing.  So I was forced to use the power button on the machine.

My questions are as follows.  What could have caused the system to freeze aka lockup (bare in mind I turned off the screensaver feature, dont know if that hurts).  Also by turning off the system via the system power button will I increase the life of the machine?

What is the version of Firmware you are running?

Current version.  Made sure to update as soon as I bought the unit.  Should I downgrade to something that might be more stable.

I do not work for WD but I can safely say that I had strange freezing issues with the current firmware, It is better that you downgrade to the prior release

See the discussions that I had before in this community.

Lookup on how to downgrade, You may need to modify the .ver file to some higher number and use the USB method to downgrade.

Report back to us if hanging stops when you use the prior release Best of luck!

Any particular version I should downgrade to in terms of maximum protection from freezing?  Also where can I find downloads for older versions?  I tried looking for older version download links and couldnt find anything.

Again, Do this at your own risk, I Do not work for WD

Read this Documenation:

Suggest that you download version 2.03.24   << Click here to download >>

Hope this helps!

Best of luck!

I understand the risk.  But did the version you are recommending cure the freezing problems you had?  Or atleast cause them to become less prevelant?

YES! -  to best of my knowledge! My WD TV LIVE HUB has been working fine after the downgrade.

Report back to the community if you feel that it helped resolve your freezing problems so that others can feel confident too like me.

Just out of curiosity do you think not having the screensaver on could cause any issues in the future in terms of freezing?  I’d have no problem setting it to ten minutes if thats the case.

I am afraid, I cannot help you much here, I am too like you just a regular user of the product, You must read the posts that I wrote months ago for full details of what all I tested tried, attempted… and came to conclusions…

If you do not trust community members advice, please call WD customer support!


Best wishes



I am seeing you post in several threads offering your help, thanks for your participation.  Since the latest update I have been freezing like crazy, I didn’t find anything in these boards about it so I turned to WD support and was told that the tv/other electronics might be interferring with my remote’s IR signal…

Here is my response to them via email…

'As I thought it was the remote that was not sending a signal I trouble shot the snot out of this thing. Removing all electrical devices from anywhere near the area, including shutting down my Wifi (oh the horror), moving the box far far away from the tv, New batteries, pressing and holding buttons, resetting the box, power cycling the box, pushing the ‘reset’ button which cleared all of my settings, and doing all of the above while standing on my head…to no avail.

I am now convinced that it is the box not the remote that is not functioning properly. Despite it not responding to any controls given by the remote the box itself will not respond to me trying to manually push the power button when it is apparently frozen. If we let it sit in it’s frozen state for anywhere from 15 to 30 minutes we can then do some commands (anywhere from 2 to 15 pushes on the remote that it will respond to and then be frozen up again for another 15 to 30 minutes.’

It was only sent to them minutes ago and thier first response was fairly timely, so I will let it sit with them for now for a possible answer, but alas, I think I need to downgrade my firmware and give that a go.  We L O V E this little box, just need it to be funcioning properly again before my four year old declares a civil war on us parents becuase she can’t see her Blue’s Clues in the morning.

I will try and get back here to update either what WD support says, or what the downgrading does for me.

Thank you kindly.

I am also suffering from the “freezing” problem. Sometimes I’m at the “main” screen and pick “videos” and it freezes… sometimes it happens when I attempt to change the content source and access my NAS box…

I have to admit some of you are much more patient than I - I have waited 10mins. with no luck, but never 30mins.

Is a “downgrade” the only solution?

I went into File Explorer and I have no “console” folder on my Live Hub media player’s HD…