Freezes with new firmware 2.01.86

I am having the same problem with network disconnects. Raised a support ticket - hope it is fixed very soon.

In interim what is a stable / working version of the firmware so I can try a down grade?  

I tried 1.16.13 but had same problems and I saw 1.07.15 indicated as stable which quite old?


1 Like

I am too experiencing this issue just recently. I’ve had the firmware since release and now my SMP will crash when resuming from pause with the overlay intact and the video still playing. It will also crash when attempting to play a video with the arrow still on the screen and the playback continuing. The remote becomes unresponsive during these crashes and I have to pull the plug in order to get it working again.

Is this a UPNP issue? Where is the link to the open support request? I have 2 players that don’t because of this issue.

For Support go to and submit a support request

I think the staff do not read the posts on the community site - they asked me to reset the device which I had done - I hset up a static IP etc.

The community sites are full of reports of disconnects - I have tried 2 earlier versions the oldest 1.07.18 - it is faster than the newer versions and shows files on the NAS / Media server that the newer version misses.

I think the sofware was not properly tested - end users are doing the testin.

I think I am going to request a refund from the retail outlet.


I reported this issue months ago (with full supporting information). It seems that my post has been deleted.

I checked your entire post history since 2013 (11 posts), and all of yours posts are available. It is possible the post you are looking for was moved into another thread. Please check your post history in order to locate it.


I now have 2 WDTV Live SMPs that exhibit this type of erractic crashing and hard locking. I do notice that when I reboot or shutdown other equipment on my network it seems to unfreeze the player. 

No other player on the network has this issue, only the 2 WDTVs at different locations, hooked up with different Cat 6 cables. My WDTVs are connected to a WD My Cloud via Windows Shares, but this also happened when connected to my Windows 7 PC as well.

All running 2.01.86 firmware.

Possible fix for network disconnects


I was trying an old version of the firmware 1.07.18 and still had problems with disconnects and loss of connection when pausing playback of videos. Going through the varios settings in the 1.0.18 firmware I saw an RSS Feed option  (I have forgotten where it is )- set it ON and noticed it at top of the Home screen - thought it was useless - it was reporting some connection failure so I went back and se it OFF.

Guess what !!!

The system has been very stable since - NO DISCONNECTS to date even left it on overnight in pause state (there is no power off after 3 hrs in older firmware).

Now have been testing with 2.01.86 for a few hours and system also seems stable.

I wonder if there is some “dud / unused” code that is causing the problem.

Please try this if desperate - need to roll back firmware,393/session/L3RpbWUvMTQwNDU0MDU3NC9zaWQvdWpFRW52WWw%3D


All three of my units crash in different ways:

  1.  Playing a movie.  Movie will start playing, but the black box with the arrow will stay on in the middle of the screen.  Unit is unresponsive to commands has to be power cycled.

  2.  Playing a directory of shows.  The unit will freeze when trying to play the next episode.  The show will play, but when it goes to play the next video, unit is frozen and has to be power cycled.


I too am having both your issues. When I reboot the computer that is currently the Master Browser on my Windows network the issues go away for a bit until they return at a later date. I’m unsure if an MS Update is the root cause of this issue.

All my machines are Windows 7 currently, all of them stay on all the time.

As I mentioned in the other thread, I’ve given up.  1.16 is a pretty good firmware to be stuck with till the end of time :slight_smile:


does 1.16 include DTS-HD passthrough? I really enjoy that feature of the 2.0 firmware.


That’s what I thought. no go for me then. I’ll wait until something gets patched here or try it via NFS shares to see if that helps.

Thanks TechFlaws

I’ve been having similar issues with the freezing as described in this thread, as well as the one here:

About to revert back to 1.16 firmware (!!!) as I care more about having stable software than features lol. I’ll try to post back with results, but just wondering how some of those in this thread went with a firmware downgrade??. It seems upgrading to the latest firmware would be a poor move since this forum is flooded with posts about how buggy it is (in particular the memory leak from merely idling in the menus is a scary one). Plus there is no mention that the latest 2.02.32 addresses this freezing issue at all :frowning:

Dear mickay

I have installed 2.02.32 and pleased to inform you it fixes the prior problem regarding disconnects. Had one or two instances where a fatal error was reported when starting to play a video but after it rebooted all was OK.

What firmware version is the most stable ?

At the moment I want one that plays mp4s properly and doesn’t disconnect from a network drive every 15 minutes and tells me the source is no longer available.

I’m not that worried about the services. A lot of them don’t work in my region anyway.

Try 1.16.  

habskilla wrote:

Try 1.16.  

Thanks. I downloaded it a bit earlier.

To all

I recommend the latest version 2.02.32 - it works for me no problem with Windows shares etc. I had problems with all prior versions.

It may be best to do a hard reset - press button under unit (use toothpick) after firmware update - will have to reenter settings etc.


Trucker wrote:

To all


I recommend the latest version 2.02.32 - it works for me no problem with Windows shares etc. I had problems with all prior versions.


It may be best to do a hard reset - press button under unit (use toothpick) after firmware update - will have to reenter settings etc.




Thanks. I will try that first before rolling back,