Frames dropped during TV recording into Caviar Green 1.5TB


#1

I have a Western Digital Caviar Green 1.5TB Internal Hard Disk and a PCI TV Tuner Card. When I was recording a TV show into the Caviar Green hard disk, I noticed that some frames were dropped during the video capture process. The strange thing is that frames did not start dropping immediately after video capturing starts. The frames start to drop approximately 15~45 minutes after the beginning of the TV show. The 15~45 minute range makes this phenomenon appear to be very random. The second strange thing is that frames were only dropped for less than a second and normal video capture resumes in a split second.

I have done recording on other hard disks in my desktop and no frames were dropped at all. I suspect that this may be due to the fact that the Caviar Green hard disk adopts “IntelliPower” and/or “IntelliSeek” features. The other hard disks in my desktop all had fixed rotational speeds. With all other factors kept the same, ceteris paribus, I suspect that the variable rotational speed of the Caviar Green may be responsible for the dropped frames. I think the Caviar Green hard disk may be trying to spin down after some time, but detects that video capturing is still in process and spins up again. This may explain the strange phenomenon where frames did not drop immediately after the start of the video capture process and when they do, they stopped dropping in a split second.

I have read some of the other posts in this forum, and I assure you that the power management features in my operating system are set to “never”, meaning that hard disks do not spin down during inactivity. The hibernate function is also disabled. If my suspicions are right, is there a hard disk management software to manually force the Caviar Green to spin at maximum rotational speed during critical operations like real-time TV show video capture, and “IntelliPower”/“IntelliSeek” features re-enabled manually when needed (after the end of the TV show)?

I see “disable tagged queuing” and “disable synchronous transfers” options in the operating system’s device manger. I enabled “disable synchronous transfers” but the same issue persists. Maybe these options make no difference at all with regard to this issue? Maybe I should try to enable “disable tagged queuing” too?

The second suspicion that I have is the large 32MB buffer in the hard disk. The other hard disks in my desktop have 4MB, 8MB and 16MB buffers respectively, and they do not experience dropped frames during video capture. Maybe the Caviar Green hard disk have issues with writing from buffer onto disk during real-time video capture, causing frames to be dropped?

I read from the other posts in this forum that the Western Digital AV-GP model is recommended for video capture and the Caviar Black with fixed 7200RPM rotational speed for high performance, but I already made the mistake of purchasing the Caviar Green. I did not realize that the “Green” features would come at cost of dropped frames. Besides, I intend to use the Caviar Green for multiple purposes, e.g. office applications, games, video capture and editing, etc, not solely for video capturing.

Currently, I am circumventing this problem by recording into the other hard disks in my desktop that have fixed rotational speeds, and copying the captured video file after recording into the Caviar Green for storage and editing. In other words, its a two-step process. But I am still a tiny little bit infuriated by the fact that it cannot be a one-step process.

Any opinions on this post would be deeply appreciated. Please forgive me for this lengthy post.


#2

WD’s Knowledge Base has something of an explanation you might want to check out.  I hope it helps.

http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std_adp.php?p_faqid=3892