Format to FAT32?


I have the My Cloud 4TB, and I use it with two computers - a Windows PC (Win7), and a Macbook Pro (2013). Transferring files works flawless with my Win PC, but not with my MBP. I’m a photographer, so I often transfer folders with large portions of images. Usually 10-30 GB. When transferring from my MBP it stops about halfway, and giving me a error code 36. 

I have been talking to Apple, and they say that I should reformat my My Cloud to FAT32. How do I do that?

You can’t use Fat 32 on the My Cloud it uses a proprietry file format.

Not really proprietary… it is a standard Linux file system (EXT3)… but you are correct… it can’t be formatted as FAT32

I took exact words from WD FAQ and it depends on what you call proprierty I suppose for windows it is NFTS linux EXT 4 

Great… :-(. 

Is there anything else I can do, or did I just buy a product that doesn’t work properly with Mac?

I wouldnt say the product doesnt work with a Mac just the combination of file systems used can’t handle the number/size of data you are trying to transfer. I am not convinced using Fat 32 would solve your problem anyway really.

Looking on the web your error code is a standard problem for a Mac trying to transfer lots of data to any type of external HDD.  solutions suggest formatting the external storage device to HFS file system.  You won,t be able to do that on the My Cloud.

Are you able to just use the PC or have less images in your folder and less data in them and use the Mac.

Just found this on the web that might be a soloution for you, hope it helps

I get Mac Error Code 36 when trying to transfer files to a flash drive or memory card. How do I fix this?

Have a look at this link with instructions

Thanks for the link, but it’s still not working. I get the exact same error code. I’m going out of my mind - and out of space on my MBP…

I have the same My Cloud and two MacBook Pros on my network (3 when my son visits), they are '08, '10 and '13 vintage all running Mavericks. The My Cloud works fine on these (with the speed caveats many users here are expereiencing). There is no performance difference with my Wn 7 systems.

I don’t understand what may have gone wrong with yours. Speak with WD customer service, they tend to be helpful in my experience. Did you install WD MyCloud and WD QuickView? I believe you need to rund the MyCloud application once to install the proper drivers.

The Apple customer service is very misinformed. He clearly doesn’t understand your configuration or how a NAS works. He’s probably thinking of a USB drive, where that advice is appropriate (though I would have recommended running an NTFS OS extension on your Mac. A better file system than Fat32, though not as universal). A NAS like the WD MyCloud is a small computer. The computers on the network using it don’t intereact with the disk directly, but throught the NAS Linux intermediary. Hence formatting the drive makes no sense, and will break it if you could.

I think the problem is related to the sheer number of small files and the overall size of the data.

What version FW? The FW that came out last week seems better so far.

I suspect it is the the photo thumbnail indexing services

If you are comfortable with SSH try the commands below then re-try the copy

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

If you want to keep these off also run these
update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable