Format to fat32 for ps3 access

I got the 2tb world edition drive for my xmas and have managed to get it working fine with my laptop however ive just found out that it needs to be fat32 to work with the ps3.

Can someone help me please as Im about to loose my temper with it.  I’m running vista on my laptop and had found instructions to format using DOS.  This isnt working as it says cannot format network drive??

Please help, thanks in advance.

I suggest you unhook the NAS from the network, maybe it is possible to connect to pc via ethernet cable directly, i suppose you have to map a network drive first in Windows before youcan use it. But maybe you get the same problem as it still will appear like a network drive.

The mybook world edition drive is a NAS drive , that cannot be connected via usb to the PS3. you need a usb 2.0 drive. and the drives inside the mybook world are formatted ext3 linux format anyways.

so cannot be used with the PS3 this way, you need to connect it to the router and follow these steps in the user guide:

Playstation 3

  1. Ensure that your Playstation 3 and My Book World Edition are powered on and

connected to your local area network. You will see the main user interface with a

series of options displayed horizontally across your TV screen.

  1. Using the directional buttons (left and right) on the PS3 controller, navigate to

Music, Photo or Video depending on which type of media you want to play, and

press the

  1. Using the directional buttons (up and down), scroll and select MyBookWorld (or

the new device name that you created previously) by pressing the

will now see a list of folders (Music, Photo and Video) to the right of the

MyBookWorld icon.

  1. Make sure that you select the folder that corresponds to option you selected back

in Step 2. For example, if you select Photo from the main user interface screen,

open the corresponding Photo folder to the right of the MyBookWorld icon,

otherwise your content will not display properly.

1 Like

It does not work on my PS3.

The PS3 can “see” the TM Media Server, but it always shows a message that there are no files on the WD MyBook World Edition (wich is dlna enabled, as far as I know and as it was indicated in the box…).

Anybody can help me solve this?

I had the same problem with my PS3.

I sort of stumbled my way into fixing it.

  1. Make sure you use the public folder to store your media files. This is where the PS3 wants them for some reason. You can use the music and video sub folders.

  2. If you change the files on your drive or rename them, your PS3 has to rescan the media server. It should do this when you turn it on, however once I had to turn it off, unplug the network cable, turn it back on and let it boot without any network connection, then turn it off and reconnect the cable. Turn it back on and it will re scan and set all the files correctly.

  3. Make sure that if you are in Video in the crossbar menu that you are also looking in the video directory on the drive. Same goes for the music files, make sure you access them from the MUSIC heading in your crossbar menu. If you try to open a video directory from the Music crossbar heading it will say there are no files.

Whatever you do don’t format the freeking drive. It is a network media server, not a USB hard drive. It does not need to be fat32 formatted any more than a windows7 computer would have to be. If you format it you will brick it for media functions.

Once I got it working with the PS3 it works pretty good. If you have your music/video/pictures stored in the correct folders on the drive, and you try to access them from the correct ps3 crossbar heading (music for music, video for video, pictures for…), it should just work.

I have found one glitch with this drive and the PS3. It seems, if you watch a 2 hour movie on DVD, when you exit the movie the PS3 has somehow lost it’s connection to the drive. I think the drive went to sleep and the PS3 didn’t know it and couldn’t wake it up. I have turned the power save function off so it doesn’t go to sleep anymore. I turn it off when I turn my computer off, and turn it back on when I come home from work.