Forced subtitles

Ok… so I asked for forced/default subtitles in MKV files and we got them with 1.06.15.

Now, inexplicably, forced subtitles don’t work.  They are either on or off, but the forced flag makes zero difference.  I wanted to re-flash the firmware, but it won’t let me as I have the most current version.

Has anyone else experiencing this?

The forced flag in MKVs has been ignored from day one. I’ve reported this on the beta forums but there’s no way of knowing if/when this will be fixed.

Uh… version 1.06.15_V release note

“Resolved issue where default subtitle stream flags are ignored.”

Maybe I’ve been smoking crack, but I’m pretty sure default or “foced” subs worked properly after I installed this update.

Mmh, I might be wrong about the LIVE but the current SMP definitively ignores the flag in MKVs. Change the old firmware’s VER to 1.08.15 or something and you can flash it over the current one.

Default and forced flags are two different concepts:

If the user does not explicitly selects a track himself then the player should prefer the track that has this ‘default’ flag set. Only one track of each kind (audio, video, subtitles, buttons) can have this ‘default’ flag set.

A player must play all tracks for which the forced flag is set to 1 (true).

well if the track is forced, i always go in with mkvmerge and change both default and forced flags to yes.  otherwise, i make sure they’re both no.

That’s how it’s done but the problem is that when you set your LIVE to OFF, it will ignore the forced flag and not display ANY sub which does not make sense.

Yeah… and if you set it to “no” it doesn’t display anything.   I’m really starting to question my sanity… I requested a fix for this over a year ago, was really excited with the latest firmware, and remember it working.


I’ve seen people recommend an “auto” option for subtitles in the settings menu, and that would be the most logical fix.  Come on WD… a simple solution to a simple problem.  I’m not programmer, but recognizing a flag in a file header shouldn’t be a hard fix.

The AUTO option already exists on both players. The problem is that the forced flag is ignored when it’s set to OFF.

I have no idea what you’re talking about.  I have the latest firmware and I see no auto option.  Settings > video settings > subtitle default > on / off… that’s it.

Well, I thought thats what those people meant by AUTO. Settings > video settings > subtitle default > ON sets subtitles to ON, regardless of the flag used in the MKV. So this works. What does NOT work is Settings > video settings > subtitle default > OFF. Granted, it turns off subs regardless of their flags (on, default) but it should NOT do so with forced.

yes… but that’s exactly what it’s doing.  like i originally said, forced subs worked after i updates a few months back and all now i have to manyally turn on forced subs for every movie.  it’s not a bad file or a bad mux.  the movie i originally tested the new firmware on was apocalypto and my player recognized the forced flag.  i’m not sure what happened, but now it acts like the old firmware again… subs are either on or off regardless of the flag.