Force Update firmware on MyCloud Home


The release notes says:

My Cloud Home Firmware Release Notes

The release notes provides information regarding the firmware on your My Cloud Home device.

Firmware 7.0.0-129 (1/15/2020)

  • Bug fixes and performance enhancements

Firmware 6.9.0-107 (12/13/2019)

  • Import photos directly from camera roll or gallery to Albums
  • Bug fixes and performance enhancements

By My Cloud Home is (5 days after the release) still on 6.9.0-107

How do I force the box to update the firmware?

I have tried to make a restart from the site…
I have tried to power the unit of and the on again, but still no upgrade.

I there a way I can force it to update.

I am still not able to backup my Mac with osx Catalina, so I really want to test the new firmware version.

1 Like


What backup cannot you do? Is it Time Machine?

1 Like

Hi Austin.
Yes, it’s Time Machine

What happens exactly.

It is working fine here (although I wish it was over SMB).

Does the disk show up within Time Machine panel? The usual suspect of people trying to enter credentials. You should log in as guest.

Let me know.


The issue is Apple changed the way it makes backups in Time Machine on the Catalina MacOS version. WD knows about the issue and I expect it to be solved in the new firmware.

Older versions of MacOS X works fine, and the “MyCloud” (not the Home edition) was fixed with the December firmware. The MyCloud (not home) has a web management interface where you can upload a new firmware, but the “Home” edition does not - so you are relying on the box to auto update the firmware, which it is not doing…

Catalina Macs finds the drive in Time Machine and lets you connect as guest. It shows the disk and size information, and it starts the backup and calculates what’s needs to be copied, but then it stops and hangs and nothing is written on the disk. You can make shares and use it as a NAS disk from Catalina, it’s only Time Machine that is not working.

So, I want the MyCloud Home box to be updated to the new firmware version that was released on January 15, and I tried the usual ways (reboot, power off/on) but it stays on the old version.

Anyone have a clue of ways to enforce a firmware update of the MyCloud Home box?

It’s been working quite correctly as far as Time Machine is concerned. Wifi backup are not really reliable but it seems it has somewhat improved over the year with the different updates. I use encrypted backups.

Do you backup via wifi or Ethernet?

The good news
The MyCloud Home box is now updated, the solution seems to be to wait 7 days, my guess is that the box checks for updates once every week. I still did not find a way to force an update though…

The bad news
Time Machine backup does not work, now it gets a little longer than before, it connects, calculates the backup, create a sparse bundle on the MyCloud Home box, and fails when the size of the backup reaches between 1.5 to 2Gb. (tried both Wifi and cable)

I guess that we now have to wait another month for WD to try to fix it… now we have waited 3 months without a backup to the WD drive. We are quickly reaching the point where we will give up on WD and go with another NAS vendor.