Folders with name "uploaded" are invisible (MyCloud EX2 Ultra)

Hello,

I have noticed a strange behavior with my MyCloud EX2 Ultra.

In the Windows network drive, I try to create a folder with the name “uploaded”. Windows says it is not possible. Any other name works.

Then, I have established a SSH connection and creates the directory with “mkdir”.

$ mkdir "uploaded"
$ mkdir "xyz123"

It turns out that only the folder “xyz123” is displayed in the network directory. The “uploaded” folder is NOT shown.

When I rename the folder, it is shown

$ mv "uploaded" "hello"

and when I rename it to “uploaded”, the folder is invisible again

$ mv "hello" "uploaded"

It seems like the Samba-Daemon explicitly hides any directory that has the name “uploaded”. Also, it seems that the folder “.AppleDouble” is “banned” too.

What is going on and how can I create a directory that is called “uploaded”?

Thank you for your help

I have found the solution myself.
Unfortunately, this is an intended behavior…

/etc/samba/smb.conf:

[ global ]
...
veto files = /:2eDS_Store/.bin/Network Trash Folder/.systemfile/lost+found/Nas_Prog/mirrored/uploaded/.wdmc/.AppleDouble/
...
delete veto files = yes
...

More information about this setting:

So, the blacklist is:

  1. :2eDS_Store (Is “:2e” a mistake?! “2e” is the ASCII Code for “.”, but it does not work. I can create folders with the name “.DS_Store”, and I think this is not intended)
  2. .bin
  3. Network Trash Folder
  4. .systemfile
  5. lost+found (This is not necessary, because this directory only exists at /mnt/HD/HD_a2/, and is never inside a shared folder!)
  6. Nas_Prog (This is not necessary, because this directory only exists at /mnt/HD/HD_a2/, and is never inside a shared folder!)
  7. mirrored
  8. uploaded
  9. .wdmc
  10. .AppleDouble