Folders Thumbnail & Movies Thumbnail


#1

Hello everybody!

I have a question that needed to be resolved. I bought a WDTV Live Media Player and download the latest firmware. Everything works perfectly but the images. To make the story short, I have created each thumbnail for the genre folder for (Drama, Actions, Horror, etc…) with the 120x180 size. I also created each movie graphic as well 120x180. All the graphics size are around 45KB - 55KB, less than 70KB in general. When I click on the dispaying screen on the TV for dispalying folder —> local —> USB —> then it did displays all the movies graphic but not the genre folder graphic. Why? Please advised me! Thank you in advanced!!

Conclusion:

  • All the movies graphics are displaying on the screen.

  • All the graphic for the genre folder are not displaying on the screen ( I have placed all the graphics for the genre in the root and in the folder itself but it does not work.)

Please help!! What do I need to do in order for the graphic to display for the genre folder? I am stuck here!

VRage :frowning:


#2

The image for the folder needs to be named folder.jpg – so for each sub folder you have categories for just put a folder.jpg with the image you want IN that folder.


#3

Thank you Mike, it works! Problem solved… Once again, thank you so much for your help.

VRage :slight_smile:


#4

You’re very welcome.


#5

So to bring up this subject again from another angle…

I have my library ripped in 2 formats, up until today I was using VOB files renamed as MPG to work on my pyTivo setup, now that I’m running strictly on the WD setup, I’ve made that directory available to my WDTV Live Plus and also started to rip to ISO since that plays perfectly and saves a converstion step.

I have 1 folder with all my daughters movies in it as .MPG files and as a test I took the .jpg for 3 of these movies from Netflix and saved it into the directory named exactly the same as the title so what I have would be something like this:

Bee Movie.jpg

Bee Moive.mpg

Cars.jpg

Cars.mpg

etc…

In this case the thumbnail is not showing up, the file size is about 10k and is 110x150, I would have almost expected this to work but it did not.

I have not tried this on the ISO images but based on what I’m seeing, this will not work?  Is the only way to get this to work to rip to TS Folders???

Curious.

Miguel


#6

How are you accessing your files?  Net shares, media server, or local drive?  It *looks* like an NAS, but I don’t know how you are accessing these particular movies.

If net shares then, yes, that should work.  You might have to go out of the share and then come back in, but that thumb should show up.  Note that it’s always better to copy the file name directly, since it IS case sensitive.  I would not recommend using media servers (and they may not show the thumbs properly).  If net shares, do you at least see the images in that folder? (Because they WILL be duplicated, along with the movies).  If not, there’s something wrong with the files themselves.


#7

Hi Mike thanks for the reply, the setup is the WDTV Live Plus on my network pointed to a WD Sharespace NAS and the movies are in the public\shared videos folder (the default video share) on that drive.

When I browse the drive from my pc I can see the jpg files show up just fine and the names are exact. I’ll check it again this afternoon when I get home to see if by having the WDTV Live off all day and having to log back in when I get home if it “wakes up” a little and sees the files.

I’ll post my results either way.

Miguel


#8

What I have found is that I have to name the .jpg file on my pc “folder.jpg” for it to show up on the WDTV Live. On an external hard drive I have to give it the exact name of the movie for the .jpg file to show up.


#9

Well I just got home and checked again, so in the Thumbnail view when I go to the 3 movies that I tested, the thumbnail now shows up with the .mpg file, EXCELLENT!

But there is a minor glitch, I also see the 3 movie .jpg files as .jpg files so basically if I were to unleash my little on on this system she would not understand why she clicks on Bolt and see’s the picture but no movie.

Also confirmed that this setup works only when I’m looking at the directory as a share, if I just dial into the media server and hit that same directory, the behavior does not match, but Mike you said that would likely be the case.

So curious, what’s the right way to do this? I have 1 large directory with all the movies on it, if I put the .jpg files for each movie, there are going to be 2 thumbs, one for the movie and one for the .jpg file. Anyway to get the box to ignore the 1st?

Miguel


#10

Unfortunately, that’s the way it is.  The thumbnail issue with net shares is my ONLY problem with the Live.  WD is aware of it but any solution is probably at least 6-8 months away.

You might be surprised by how smart your daughter is, though – IMX kids seem to understand these things far better than we give them credit for.  If you tell her there are the “pictures” and then the “movies” down below she might well just figure it out.  In any case, it’s worth a shot (if nothing more, you can teach her a valuable lesson about how adults can program crappy software that we have to work around the bugs :>)


#11

I discovered the same problem last night.  Even though the .jpg have the exact same name as the Video file, it shows as a .jpg and does not link to the film.

Guess for now I will turn off Thumbnails and use the list version.  Probably faster anyhow :-).  Also don’t have pics for all movies so better I guess.  Would be good if you could define the view type per directory i.e. List or Tumbnails.

I am using this over the netwrok to a shared folder on a NAS.

One other thing I found which is a pain is that even though it stores the login and password, displays this screen.  Would be nice to be able to go straight in and/or have a default directory and media type.  I only plan to use this for Video content.


#12

The issue with thumbnails on Shared Folders is a long-standing bug that we’ve all be railing on WD to fix.  

Swiss, you CAN have it log you on without prompting.

After you have logged on the first time (so it does save your credentials) go into NETWORK SETTINGS and set “AUTO LOGIN TO NETWORK SHARE” to ON.   It won’t ask you again.


#13

Thanks Tony, will give that a try when I get back on Sunday (off the the mountains tonight).

I popped home over lunch and changed the settings from Thumbnails to Listing.  But it lists the .jpg files first.  Will move these into a separate directory.  Must admit, if the thumbnails is not instant, then will leave this turned off.


#14

mkelley wrote:

Unfortunately, that’s the way it is.  The thumbnail issue with net shares is my ONLY problem with the Live.  WD is aware of it but any solution is probably at least 6-8 months away.

 

You might be surprised by how smart your daughter is, though – IMX kids seem to understand these things far better than we give them credit for.  If you tell her there are the “pictures” and then the “movies” down below she might well just figure it out.  In any case, it’s worth a shot (if nothing more, you can teach her a valuable lesson about how adults can program crappy software that we have to work around the bugs :>)

Heck, maybe she’ll even fix it.


#15

Bill_S wrote:> Heck, maybe she’ll even fix it.

I hope you’re not suggesting we have to wait for her to grow up before we get a fix for the issue, Bill .

Oh, wait, I guess you mean she’ll be smart enough to fix it now (as opposed to the present programmers).  Now, even *I* wouldn’t be that harsh (LOL).


#16

Smart***!!!


#17

OK gents, :slight_smile:

I’ve had my WD TV HD for a few months now and have been happy with it for how easily it plays all my different video files. I’ve seen what the thumbnail view looks like and want to do that cause it looks gorgeous. However, I’ve spent several hours now attempting to make this work to fail, fail, FAIL. I am not networked, I have a 1 TB WD external hard drive that I upload my files to then link to the WDTV (when not hooked to PC) via USB. I can get the .jpg files to appear on my tv, they just only show up when I go to photos. For whatever reason, they are not apparent in the video tab.

I’ve read thread after thread and have tried MANY different configurations to try and get it to work. I named .jpg’s in the following ways: Exactly as movie, folder.jpg, Folder.jpg, folder.JPG, etc. (tried this multiple ways). I placed folder.jpg files in both my root directory and movie sub folder, and had each of 5 unique configs for 5 unique movies. I’m stuck. lol.

I have not ever upgraded any firmware, that’s my next plan, but I need to go buy a USB cable for that, and will do so tomorrow. Any other suggestions?

*Edited to add* The .jpg files are all 120 x 180 and all well under 70kb.

took some photos and will upload them here once they hit my email inbox.


#18

Welcome to the forums.

Let’s simplify things for you first.

If your movies are in one folder (say you have several MKV files in a folder) then the thumbs must be the same as the movie name (case sensitive) but, of course, with a JPG extension.  So if the movie is named “Shaft.mkv” it should be named “Shaft.jpg”.  If you have movies in separate sub folders then you use the folder.jpg thing ( that will then display at the upper folder level).  So if you have a folder named “SHAFT” then inside that folder put a thumb called “Folder.jpg” and when you are at the folder level you’ll see that thumb instead of the folder icon.  Got it?

Now go to your hard drive when it’s connected to your PC and erase the tiny file/folder that starts with “WD”.   Hook it back up to the Live,  boot up the Live again and hopefully things will start working for you.


#19

Thanks for the speedy reply Mike. All of my movies are in one folder and the 5 files that I’m trying to match up all have identical names. There is also a folder.jpg file within the overall folder, intended to show up on the folder page. I deleted the file .wd_tv to no avail.

Also note that everytime I unplug my HDD I’ve been unplugging the WDTV so as not to have to worry about cashe issues. Originally, the jpg’s would not show up at all, until I reset the cashe and so at the very least my WDTV is recognizing them, I just cannot get them to show while in the video tab.


#20

Do you have the Media Library turned on or off?