Folders & files Not Visible with Admin login

#1

Hello the amount of issue I encounter with WD mycloud are incredible !
I was just trying to send a question to support but it says that my SerialNumber is nor correct, however I did try to cut and paste from the Dashboard setting !!??
Anyway I will park this for now !
My problem is that I didn’t use my WDMycloud actively for a While (Only My sonos is reading musing on it)
Then I’ve realised that I’ve forgotten the Admin Password so I did a 4sec Reset
No I can acces the Dashboard with my Admin credential but I didn’t find anyway to see and browse my different folders except the Standard Music, Photo and Video
But I have much more on that disk the Dashboard tell me that I have 9 GB in “other”
How can I see these folders as Admin of my WDMycloud disk ??
Thanks for any help

#2

You would use Windows File Explorer or Mac Finder to browse the folders and files on the My Cloud NOT the My Cloud Dashboard. The Dashboard is generally for configuring the My Cloud features/options.

For remote access to the My Cloud, assuming that option is enabled and functioning correctly, one can use their web browser to access the MyCloud.com web portal, or use the My Cloud Desktop program, or the My Cloud mobile apps for iOS/Android to access the files/folders.

1 Like
#3

Thank you Bennor
Windows File explorer on some machine only gives me access to Default “Music” “Photo” and “Video” but I have much more on my WDMC disk
From other machine it jump to the Dashboard directly or to a Windows Network Credential request form
All these machine are on my personal network (the WDMycloud also)
I’m totally frustrated with that WDMycloud
Hopefully I see that the guarantee run till 2018 because I dont really trust that product anymore (I’ve seen a lot of complain for similar issues)
Maybe MAC users are more Happy than Windows Users
I hope anyway that I would be able to get back all my files to copy them on a more reliable system
I will try to connect an USB drive on the WDMyCloud… it sounds the easiest way to get back my files :frowning:
For now I will never recommend to anyone to buy such unstable Randomly working device !

#4

Some more info : On the Dashboard under the Yellow bell Icon I see a Message “Network Link Down” but my network is working fine for everything but WDMyCloud
I’ve also tried to download WDAcces : it does just nothing !
More info again
I have 3 Windows 10 Machine on my network
An all machie I’m admin and I have the same Credential
Finaly on my third machine I was able to see the full content on my drive
But it clearly shows that the behaviour of the WDMycloud drive on a Network is not stable and reliable
I’ve seen this post and I will subscribe to it
Othee issues

#5

Check your IP assignments.

Check your network cable.

Try a different network port on the router.

Has your router rebooted?

What is the front panel LED showing?

What are the ethernet port LEDs doing?

Experience from reading plenty of threads of this sort is that the majority of case are due to misconfiguration of Windows network settings, conflicting IP addresses, bad cables, etc. The facrt that one of your PCs can see the drive suggests it is a Windows/network configuration problem.

It’s very rarely a fault with the MyCloud hardware of firmware.

You might want to have a look at this thread:

What?

Did you download it, or did you not download it? If you had trouble simply downloading the WD Access app, that is nothing to do with the MyCloud, as it is downloaded from the internet to your PC.

If you had trouble getting WD Access to find the MyCloud, that’s a different issue.

1 Like
#6

Thank you cpt_paranoia
For all this

Check your IP assignments.
Check your network cable.
Try a different network port on the router
Has your router rebooted?
What is the front panel LED showing?
What are the ethernet port LEDs doing?

I would say that this is not relevant because I’ve discovered yesterday that at least ONE of my three machine can see and browse the whole content of the disk. Now I will have to understand what is specific to that machine ?? She is supposed to use the exact same configuration as the other ?
About WDAcess : Ive downloaded and installed on one machine, so I can launch it but it stop immediately without showing anything : I will try to download and install again.
So I did it : now I see the WDmyCloud icon in the status bar.
On that Machine I also get a Message from WdMyCloud “Network Link Down”
If I try to start WDAccess the Windows Network Credential is popping Up
However I still have one machine that can fully access WDMycloud
I think that WDMyCloud is not mature enough to correctly handle different network cases
And this is ridiculous for something that is supposed to be used on network !

#7

Sounds to me like credentials mismatched on your various PCs. You say on ONE of them, all you see is Music, Videos and Photos. Well, those aren’t SHARES. Those are all folders within the PUBLIC share.

So, what happens when you try to specifically access one of the other shares? If you’re prompted for credentials, what happens when you provide them?

#8

They may even be the DLNA media server, rather than the file server.

#9

Thank you all

So on ONE of my three machine (Windows 10) I can see the WDMyCloud as a Network ressource and I can browe all the Folder and Read Files

On the SECOND Machine I also can See the WDMyclous as a Network ressource but Acces is refused : A Windows 10 Network credential is Popping up : I’ve try admin with no password (same as dashboard) without success

On the Third machine (My Laptop) it is the same as the second one
Now I’ve made some more investigation

It seems to be a crazy network configuration issue

PCA = WDM OK
PCB = WDM Not OK
LAPTOP = WDM Not OK

PCA can read and Write to PCB
PCB is asking credential to Access PCA
PCA is asking credential to Access LAPTOP
PCB is asking credential to Access LAPTOP
LAPTOP Can read and Write to PCB
LAPTOP is asking credential to Access PCA
LAPTOP and PCP are asking credential to ACCESS WDM

But I’m Admin of all my machines with the same user and PWD
This Drives me crazy !
I will try to find a Network specialist to help me !

#10

What is the specific error message or dialog box that pops up indicating access is refused?

Have you previously used a different My Cloud Dashboard created user name/password to access the My Cloud on those computers that currently have trouble accessing the My Cloud? If so you may be experiencing a Windows limitation where you can only use one set of user credentials to access a NAS device. The workaround is to disconnect any mapped drives and clear out any My Cloud entries in the Windows Credentials Manager on the problematic machines.

1 Like
#11

Thank You Bennor

Indeed regarding the other network issue I’ve met between my 3 machine a deeper network setting investigation seems to be essential before to go further

#12

Hello
So now I’ve fixed the first issue which was communication between diferent Machine
The fix is (on each machine)

  • Right Click on Network
  • Properties
  • Advanced Sharing settings
  • All Networks
  • Turn Off Public Folder Sharing
  • Turn Off Password Protected Sharing

So Now all the machine can communicate to each other
Unfortunately this doesn’t work for WDMyCloud
Because of course there is no such option on the WDMyCloud drive
I’ll continue to investigate
Any suggestion is still welcome

@Bennor

The workaround is to disconnect any mapped drives and clear out any My Cloud entries in the Windows Credentials Manager on the problematic machines.

The problem is not even where I try to access a “Mapped” drive but if I try to open the Network ressource “WDMycloud”
Only ONE Machine can open it !

#13

As indicated above see the Compilation of Windows 10 Methods, Steps and Solutions thread (first post in that thread) and ensure any Windows 10 computer that cannot see the My Cloud is properly configured. Pay particular attention to Windows 10 Specific Methods 1 through 5. There are a couple of settings in Windows 10 that need to be checked and possibly reconfigured.

Also disable any third party firewall or security/anti virus software as a troubleshooting step. It is possible that third party software is blocking proper communication to the My Cloud.

In general so long as your My Cloud is properly functioning, in the same IP address subnet range, and using the same Workgroup name as the computers on the local network those computers should be able to access the My Cloud. It those computers cannot, the problem is typically either on those computers or there may be a configuration problem with the local network master router.

1 Like
#14

Thank you Benor
I’ve cheched the different Fix listed,but none applies to me
1- My WDMyclous is recognized from the Network Netbios is enabled etc… etc…
2- My problem is not to see The ressource nor to try to open a Share but simply to browse the WDMyCloud network ressource as an External Drive

This is possible from one of my machines but not from the two other : on both I get a Windows Network Credential request
As you can see on my screenshot

#15

Finally I find a way
On the machine where I can browse the content of the WDMyCloud I’ve discovered that user credential are stored in Windows
Control Panel
User Account
Credential Manager
And I see specific Credential Stored for WDMyCloud
Of course the PWD was not displayed but the username gives me a clue to find it
So I was able to access from my other machines
NOW : The question is from where these credential are coming ?
Having a look on the dashboard this is indeed one of the users I’ve created when I was fighting with the configuration of that damned cumbersome device (a few month ago before to give up)
But the same dashboard did’nt show me any specifics to understand why this user in particular can access everything from a Windows Credential request and not admin for example ?
Also on the dashboard it seems that this user have nothing enabled !
Ok I’ll have to read the damned manual again (manual are usualy made to understand bad UI or bad Software) and Bad Software makers are oftently not good manual Writer !
Even if I’m moving slowly to better understanding, I really regret my purchase for this equipment
WD is probably making good hardware but very far to provide

  • understandable software
  • Good support
  • Reliable information : my issue with the serial number not recognized is one example !
#16

FYI, it was suggested previously up thread two days ago that you check the Windows Credentials Manager. :wink: This is due to a specific issue with WINDOWS operating systems that can prevent using multiple logins to an NAS like the My Cloud using different user names. Its a Windows problem not a My Cloud problem.

Generally when you access a network attached storage device (NAS) with a user name and password, in the case of the My Cloud a user name/password created through the My Cloud Dashboard, Windows will often store that information in the Windows Credentials Manager and will use that login information behind the scenes to access the NAS so that a user doesn’t have to continually enter in a user name and password every single time they access an NAS. If you enter the wrong username/password its possible Windows Credential Manager will remember that wrong login and save it.

1 Like
#17

Thank you Bennor
Yes you had a notice about it
And yes you confirm now the fact :wink:
But for the rest I’m still stuck
Still don’t know Why this specific user have full access and not Admin
Still do not catch exactly How to manage User and Share with that bloody Dashboard it is a pain !
As you can see for user Olibara nothing is enabled but it have full access trough the Network (fortunately)

#18

Are any of the other Shares, other than Public, configured for Public and not Private access through the Dashboard?

Couple of suggestions if all Shares except Public are set to Private access. One is to delete the user Olibara and their Share. Then reboot the My Cloud and try using the Dashboard to re-add that user. Or try removing the first name/last name/email entries and see if anything changes. Or try renaming the user to some other name as a troubleshooting step. Assuming of course you haven’t done any of these suggestions in the past.

As a last resort you could perform a 40 second reset (if you haven’t done so already) and reconfigure the My Cloud Dashboard and users from scratch. A reset doesn’t remove any user data Often a 40 second reset can clear strange issues with the My Cloud settings.

1 Like
#19

Quite the opposite. It looks like Olibara is configured Read/Write for EVERYTHING, except for “Iva” share.

If I had to guess, all your shares are set to Public since they’re greyed out.

1 Like
#20

Thank you Tony
Ok I understand better now
I’m really not feeling comfortable with the UI and the huge manual is not really encouraging
Anyway I agree that I need to continue this effort of understanding to feel more comfortable with that stuff
This is strange because in one hand there is a kind of rumor to say that WDMyCloud should be easy to configure
But on the other I see so many complains saying exactly the reverse ! And I am on the second side !

1 Like