Folders and thumbnails from private folder showing in all users

Hi,

I have set up two private user folders on my WDMycloud and have set them up as accessible by each individual user.  We have a lot of photos stored on the public shared folder, but when looking at the ‘photos’ section on the app there seems to be a lot of problems with security.  Folders on the private folder are showing up with thumbnails of images inside and user without access to this can see the folders and thumbnails of content within.  When selecting view photos by date, the thumbnail images that show up are on the private folder of users.

As both users are using private folders for confidential/private work is there any way to ensure these private files are not showing up?

One of the reasons I bought the WD mycloud was to allow multiple users to have access to their own private space as well as the shared area.  Currently this is not working.  Is there any way I can stop the private images/folders appearing in the app?

Thanks

Which app are you using? A DLNA client, WD My Cloud app, WD Photos, other?

Couple of suggestions for a truly private share folder:

  • Do not put any folders you want private inside the Public folder on the WD My Cloud.
  • Make sure “Public Access” is turned off for the Share.
  • Make sure “Media Serving” is turned off for the Share.
  • Make sure to set the appropriate permissions for each user on the Share. Setting a user to “Read Access” or “Full Access” will give them the ability to see the share’s contents.
  • Reboot the WD My Cloud and let it rescan. Sometimes a reboot can fix certain database issues.
  • On the Settings -> Media screen perform a rebuild of the DLNA media server and the iTunes server.

Hi,

Thanks for the reply.

  • I have 2 shared folders set up - 1 for each user and have given permission for each user to have full access to their own personal folder.
  • There are our family photos on the public folders and each user has placed their own files/photos/videos etc in their personal folder.
  • User 1 is using WDMycloud on an android phone - can see their own private folder and the public folder.  All the photos are in the shared folder.  All the private documents are in User 1 folder.
  • When using the app, User 1 can go to ‘Public’ and see the public photos, but:
  • When selecting ‘View by date’ some of the thumbnails that are on the folder are from user 1s secure folder. When user 1 opens the folder, they can see public photos in the thumbnails.  However, some thumbnails are displaying images from the private folder and when they click on these, they open up an image in from the public folder.
  • When selecting ’ view by album, only 1 folder appears (in this case the folder created in the private folder for backing up images from camera)
  • When selecting ‘View all photos’ only a specific group of photos from a folder on the public pictures opens.

User 2 is using WDMyphoto (I think) on ios. User 2 is able to see thumbnails and images from user 1s private folder.

I have tried several things to stop this happening - setting up each private folder as accessible by only the named user.

Checking user permissions to ensure they have no access to each other’s folders in both ‘user’ and ‘shares’ settings.

I have restarted the WDMycloud and devices connecting to it, but am still having these problems.  I will try to rebuild the database to see if that is any use.

Any further advice would be much appreciated!

I am becoming increasingly frustrated with this and am thinking about just removing the private information from the drive, but having secure access to personal information was one of the reasons I purchased this in the forst place!

I use both the WD My Cloud app and the WD Photos app on an android phone and don’t experience the issues you are . I can only see those photos and tumbnails from the share folders I have access to.

This may sound stupid but is it possible the photos have gotten mixed together so that photos that you think are in user 2’s folder are actually in user 1’s folder and vise versa? I went though something similar with a family member who somehow mixed togeter photos and put them in the wrong private share folders and though they were seeing photos that were supposed to be hidden because they were in someone else’s private share.

I suppose one way to check is to remove all photos from both folders then copy just a couple of different photos to each private share folder and test again and see if the pictures from the other private folder are still being seen.

HI,

All photos were separated before uploading to the WDMycloud, so nothing has been mixed up.

I downloaded WDMyphoto for user 1 and can see shared photos and photos from one folder on the private folder.

I have rebuilt the database and still seeing incorrect thumbnails on user 1 WDMycloud app.

I removed app from user1 phone and reinstalled it and can now see correct thumbnails in shared photos.

I will get user 2 to do the same if they are still seeing unwanted files.

Hoping that’s the problem solved now!

 User 1 is using WDMycloud on an android phone - can see their own private folder and the public folder.  All the photos are in the shared folder.  All the private documents are in User 1 folder.

Using which app, or which means to ‘see’ the folders?

When using the app, User 1 can go to ‘Public’ and see the public photos, but:

Which app?

Is either user 1 or user 2 the device admin?

Were the user accounts and permissions set up correctly before photos were loaded onto the device? I wonder if the thumbnails were created with old permissions. I’d hope they would update when permissions were changed, but…

Have you enabled media serving on the private folders?  DLNA media serving ignores folder permissions. If user 2 is using a DLNA  client, they would be able to see any photos in shares with media serving enabled.

Rebuilding the the DLNA media database has nothing to do with thumbnails that are created for use by the WD mobile, desktop and photos apps; there are no user controls in the Dashboard for the thumbnail process that I am aware of. The thumbnailing process can be stopped, the thumbnails deleted, and the thumbnailing process restarted. See this thread.