Folder Shares not visible via SSH

Hello, I’m trying to transfer my files from My Book Word Edition to the new My Cloud EX2 using rysnc. So I created 5 Folder Shares via the UI to match with the old NAS. I’m able to SSH login on both device using PuTTY.

So, I rsync a User1 (sample folder I created) from the MYWE to MCEX2 and according to the results it was successful, but when I checked the Folder Shares via Network Mapping - there was no User1 folder created nor listed, so I SSH login and found the User1 folder was there with all the files, however the 5 Folder shares were not visible. On the old MYWE the folders are visible and are listed when logged in via SSH.

How do I access or make the Folder Shares visible when in SSH? By the way when in SSH I’m login as “root@WDMyCloudEX2 root #”

They should all be available under the /shares folder from root.

Where are you looking for them?

After I login via ssh

root@WDMyCloudEX2 / # I type “ls”

then directory list will come up with:


that’s all nothing else :worried:

Try “cd /” and then “cd shares” after that.

When you log in you’re in the use directory. The shares folder is in the root directory.

1 Like

Got it! The Folder Shares are there. Thank you very much @DarrenHill !!!

@DarrenHill we should add some more explanation here, please let me enhance your answer.

the user “root” starts in his own folder called “/root”.
The root folder, DarrenHill is pointing to, is “/”.
Some may be confused about all the roots here :smile:

Login with username “root” kicks you to its own userfolder called “/root”.
Go backwards one stair up by “cd …” and
you are at “/” which is the top level of all folders, called “root folder” - nothing to do with the userfolder “/root”.

root is the user with all privileges. Being root is “operating at the opened heart”, be careful.

1 Like

@Joerg_A - thanks, yes reading it back it could be a little clearer… :smile:

Personally I always refer to /root as the root user’s home folder, rather than their root folder, just for this very reason (and / being the root folder, as it’s the root of the hard disk, as in its highest level folder).

The old fun and games of folder root versus root user. Completely agree with all of your comments though.

1 Like

So is it possible to login as root via SSH now? I am running an older version of the firmware and in the past the only user you could login was as sshd…though the user root did exist but no one except WD knew its password. So I am surprised to see this. Can someone please confirm that you can now actually login as the user root (I’m guessing the password now is the same as sshd’s password).

@Cybernut1 the user “sshd” on some machines / firmwares is an alias for “root”. This user “sshd” has the same privileges as root, basically it is “root”.

@Joerg_A - Yes, I’m well aware of the sshd being root’s alias thing. But that’s not what I am talking about. If you read the first post in this thread specifically…he says he logged in AS the user root…not as sshd. That’s what surprised me. And I am looking to find if you can actually do that in the current firmware (mine’s older).

I’m trying to connect my WD NAS to my windows system. I could probably do that, if I could find out the name of the share which was automatically created when I set the device up. I have searched everywhere and used all the tools I have, but nowhere can I see the existing shares. I can connect to “Public” but that’s not where my stuff is. I’ve tried the WD desktop ap, but that can’t see the device either.
I’d be very glad of any help.

Hmmm. . . you are aware that you responded to a post from 2015?

I suggest you repost a “new” thread; and restate the question. Also; please tell us which device you are trying to access (is it an EX2 using the old OS/3; an EX2 Ultra using OS/3, or EX2 Ultra using OS/5?) This may make a difference in how to resolve the issue.

In direct access to the question; you SHOULD be able to see all the shares.

How are you trying to access the machine?

In windows file explorer; type the either the DEVICE NAME you assigned in the address bar, or type the “//ipaddress” of the device. (I may have the slashes reversed; forwards gets you the files; backwards will open a web page with the device dashboard)

There is a possiblity that you may have to go into the Windows Credentials manager and fix something. Windows only allows ONE set of login credentials to be stored for a given IPaddress (or device name). If you have obsolete credentials in there, that may be the problem - - > The fix would be to DELETE the obsolete credentials. Once that is done, the next time you try to access the drive; you will be prompted for a username and password.

Thanks for your answer. Sadly, it hasn’t helped.
I’m using a new MyCloudMirror DUO with OS5
I’ve tried using the credentials, I found something to change in the Registry,
I have spent days searching for solutions and trying all things suggested without success ;-(
If the Dashboard app worked I could see the name of the share I’m in. It was created automatically during the setup process and I have no idea how to find out what the share has been named. I suspect, if I knew that I could get it to work, but without that info, no success. I’m seriously thinking that I’ve made a bad mistake - I expected a Device like this that should work with a network, otherwise it’s pretty useless as a backup cloud.
So, having had a good moan, can you help me find out what the share is where all my data resides?
I’d be very grateful for any help.
Best regards

My Cloud Mirror (Out of production for a good bit of time)
My Cloud Home Duo (currently in stores)

So if this is a mirror, you have an interesting problem.

If this is a Home Duo, that puppy is different; and doesn’t run OS/5. You need to post a message in the “My Cloud Home” section of the forum.

OK - Thanks for the input.