Folder permissions

Hi everyone, I need some help.

The WD MyCloud is driving me nuts.

  1. I was tired of experiencing such slowness so i decided to do a quick restore. Beforing doing that, i copied all my folders to a usb disk attached to the WD MyCloud.

  2. After restoring, i enabled ssh, created the shared folders (in the UI) and copied the content of the backed up folders to the new ones. 

Now comes the problem. After that some random folders (inside the same shared folder) showed a “forbidden” sign and didn’t let me access (macbook air). Rebooting the disk seemed to kill the problem (tried also a “system only” restore)

But now i have a another problem.

I’m trying to access the shared folders (private mode) with an ipad app which allows “Windows SMB” connection. Until now i had no problems. Now, it shows a list of the folders but when i try to see the content an error message appears.

“Failed to fetch directory content”.

I think there’s a permission problem, but i don’t see why! The root user has full access to private folders and the app’s settings are from the root user.

Any ideas?

fotografia PNG

1 Like

Yeah, you’ll probably need to manually set the ownership.

From the /share/(ShareName)

folder, enter the command

chown -R XXXXX.share *

… where XXXX is any of the users defined on the cloud that should have read/write access to that share.

1 Like

XXXX is the username (like “jacob”) or root?

So, it should be
chown -R jacob.share *    ?

1 Like

Ooops, just doublechecked, and I have a typo:

should be 

/shares/(share name)

not 

/share/(share name)

And yes:

chown -R jacob.share

is correct, as long as “jacob” has read/write access to that share.

It may be necessary to change the permissions, as well, but we’ll see when you’re done with that first part.

1 Like

chown: missing operand after `jacob.share’

1 Like

Shouldn’t that be

cd /shares

 

chown -R jacob sharename

Where “sharename” is the name of your share.  Also, remember that if your share is a double name with a space (ie: share name) to use “*”, so it would be share*name.

That’s the way I’ve always done it.  That will change the folder as well as all the files in that folder to owner “jacob”.

You may also want to do:

 

chmod -R 777 sharename

This will give the folder and files full access for “jacob”.

1 Like

**bleep**.   Double-typo.    Don’t forget the last *.

chown -R jacob.share *

Tinwarble:

  Shares can’t have spaces (silly WD.)

but cd /shares

(etc)

might be bad because the facl ACLs (that’s fun to say) may not applied to the share folder.  But not sure…

The default file/folder permissions are 770, not 777…   and I’m not sure how the darn Trustees would work in that case.  :)

1 Like

TonyPh12345 wrote:

Tinwarble:

  Shares can’t have spaces (silly WD.)

case.  :)

 

Yep, crossed my devices up.  The EX4 does allow spaces.

Share_naming.jpg

1 Like

Many thanks to everyone.

Tinwarble, that did the trick. :smiley:

I also have the MyBook Live and i think it’s far more stable.

MyClould is being an headache since the beginning: slow and errors.

Glad it worked.

TonyPH12345 is right though, chmod should be 770 not 777.  I got a little heavy handed with my 7’s. :stuck_out_tongue: