Folder deleted locally, but still shows up remotely

I just set up a new My Cloud EX2100 with OS 5. My storage are in RAID 1 mode. I created some users and some folders (i.e. shares). One of the folders was created by mistake so I deleted it. It’s no longer shown locally in the dashboard, nor in file explorer. However, when I log in remotely, the deleted folder shows up, and I can even upload files into it. It’s strange because I cannot see this folder anywhere in my local network, it only shows up when I access it remotely. I rebooted the device, still no change.

How can I delete this folder completely? Thanks.


Latest My Cloud OS 5 Personal & Network Attached Storage/My Cloud EX Series topics - WD Community

My Cloud OS 5 Online User Manual (

You may have to reboot the My Cloud if the indexing service hasn’t picked up the deleted folder. Or one may have to turn off Mobile & Web app access on the Share that contained the deleted folder. Then turn back on Mobile & Web app access to have the indexing service rebuild/rescan the Share. More on indexing at the following WD Support links.

My Cloud OS 5 Cloud Access Content Indexing FAQ

My Cloud OS 5: Best Practice for Cloud Access and Indexing

My Cloud OS 5: User Share Cloud Access and Indexing

Also, there is a dedicated subforum for the OS5 EX Series of devices where users more familiar with the EX2100 may be able to assist.

OS5 My Cloud EX Series

I rebooted the device twice, still no change. The folder is the share itself and it has been deleted so it shouldn’t appear remotely, yet it still does.

Just for clarification, the share I mentioned was named as “Photos & Videos”, but after I created the share on My Cloud dashboard and set it as public, I could not see it in file explorer. I assumed that the share name cannot contain spaces and special characters so I deleted it and created another share with the name “Photos_Videos” which I could see in file explorer and moved files into it. When I log in remotely, I see both shares “Photos & Videos” which is empty, and “Photos_Videos” which contains the files I move into. Even though it does not cause me trouble now, but I do not want to see a share that exists remotely but not locally.

You may have to access your My Cloud using SSH and see if the Photos & Videos share is still listed as a Share at the root level. Its possible if the Photos & Videos Share was one of the default Shares, that its still there at the root level even if the Dashboard no longer shows it. Could be the indexing is still picking it up. If the Share is still there one can remove it at the SSH/root level.

One can use a program like WinSCP ( or Putty ( to access their My Cloud using SSH. One enables SSH in the My Cloud Dashboard > Settings > Network > Network Services.

Note: Disabling Mobile & Web App access on the Share is supposed to remove it from being accessible using the OS5 mobile app and the OS5 web portal.

OS5 User Manual Cloud Access

I downloaded and installed the WinSCP. I am new to this stuff. Can you show me how to fill out the login window? What do I choose for the file protocol? Host name, port number? Thanks

You will need to write down the user name and password (if any) that is shown when you enable SSH within the My Cloud Dashboard > Settings > Network page. The following WD Knowledge Base article (found using a search of the Knowledge Base, link top of page) has more information, including directions, for programs like WinSCP and Putty.

My Cloud: Access Using SSH (Secure Shell)