Flashing Yellow on WD MyCloud

All I did was unplug my 2 TB MyCloud drive from the router for a new router to be installed, and it just started flashing yellow. Tried both the 4 second and 40 second resets, but cannot get it to go to solid blue. It just keeps flashing yellow. Please tell me there is a fix. If not, this speaks poorly of WD products. Nothing should be this fragile. Any help appreciated.

What brand/model is the new router?

The following WD Knowledgebase article may be relevant if you have AT&T Uverse or one of the router’s mentioned:


It is an ATT router (not a UVerse gateway), which is what was there before it was replaced. It was working fine then.

What are the LEDs on the MyCloud’s ethernet port showing? If they are both off, then you have the auto-negotiation problem; get a switch, or a crossover data cable.

For all their manifold faults, this is not WD’s problem; it is firmly in the court of at&t providing a router that doesn’t support MDI/MDI-X auto-negotiation.

Thanks Bennor and cpt. I checked and it turns out the router does say UVerse on the side. It is a Pace 5286AC model. I’d be curious if the switch would help this problem. If I recall correctly, last night the ethernet port of the MyCloud was lit up, so I don’t know if that means its working or not.

In any case, do you have a good switch to recommend, and what am I looking at for a cost?

Thanks again

Also, I think I just found another guy with the same issue and a switch resolved it.

Resolution link

You can get a giga bit switch for $15 to $30. Depending on how many ports
it has. Any brand should work. Just make sure it is a switch and gigabit.

1 Like

Just ordered a TP-Link 5 port gigabit switch from Amazon. Should arrive Sunday. Will post if it fixes the issue. Thanks.

1 Like

There are plenty of people who have had this problem, and fixed it with a switch. Here’s the first thread, I think:

A recent poster made the very sensible suggestion that if you can find a proper crossover ethernet cable, to save the router from having to figure out if it needs to set up an MDI or an MDI-X connection.

1 Like

cpt_paranoia, I got the gigabit switch on Saturday, plugged it in and MyCloud came back to steady blue. All the data was there too. Thanks for your advice. Cheers! -Jim