(FIXED) SN850 1TB NVME - slow write speeds (3100) on x570 using M2 Chipset slots (PCH) - confirmed as a problem on MSI, ASRock, Gigabyte and Asus motherboards

Hi all,

First time post here, so hopefully someone can help.

I have an SN850 1TB setup as my OS drive in M2_1. All onboard devices like audio and wifi are disabled in BIOS.

I’m only getting about 3100 write speeds, fluctuating very slightly but obviously far lower than expected.

I’m running a 5950x, with an MSI MEG X570 Godlike on BIOS 1.D1. Latest AMD chipset drivers. The 850 itself is on the very latest firmware, due to go to the app later this week I believe but downloadable now.

I’ve read that M2_1 being chipset could mean the lanes are being throttled perhaps and the write speed is definitely, consistently about half or so of what it should be.

Prior to this going in, I had a Samsung 980 Pro 500GB that was working just fine until about a month ago after a firmware update, where the write speeds dropped to about 1200, about 25% of expected and nothing from that side of support was worth the effort.

Additionally, I have another 850 1TB in M2_3 and that’s operating just fine, with expected writes.

Does anyone have any ideas? On the surface, it feels M2 slot and driver/software/firmware in nature and that sort of bears out with the M2_3 slot operating correctly.


1 Like


I have exact same issue with slow write speeds (3300MB/s) when SN850 runs on chipset lanes.

I have 5950x and Asrock X570 ITX/TB3 all updated with latest firmware and drivers.

So far tried the 1TB and 2TB SN850 drives and both have this exact same behaviour.

Ticket open with Asrock who confirmed the issue in their lab of slow write speeds on chipset lanes.

Asrock opened a ticket with WD who replied that this is a known issue when running this drive on chipset lanes.

I asked Asrock to explain further on the cause but they refused to explain telling me that they are under NDA from WD.

Full thread here: WD SN850 Slower than expected performance | Page 5 | TechPowerUp Forums

I have the same issue, SN850 2TB, 3200MB/s in chipset slot, 5200MB/s in CPU slot. Considering to return this drive to amazon and get a different brand.

SN850 2TB
ASUS ROG Crosshair VIII Hero WiFi
RTX 3090

Hilarious reply from WD Support…

“If the device is working fine in all slots except the M2.1 slot, then unfortunately it is most likely a firmware issue with this specific motherboard model. We cannot provide any solution as this is the motherboards manufacturers issue. We apologize for the inconvenience.”

Off to MSI I go, see what they have to say but if ASRock are aware of a problem with these drives on the chipset lanes, and are under NDA to not disclose further, the problem may be fundamental and unfixable.

We’ll see.

I’ve just stumbled upon this reddit post that says:

"Boards like the X570 Hero Crosshair VIII have the 2nd M2 slot connected to the chipset. Although this slot is supposedly X4 Gen4 Pcie it bottlenecks new, fast SSDs like the 980 Pro and sn850. In the primary M2 slot you may get 7000/5000 MB sec read/write but in the 2nd M2 you may get 6500/3200, way below the x4 Gen4 pcie spec.

Asus support confirmed in my support case that there may be significant latency induced when using the 2nd M2 due to the chipset and this causes lower speed. I was surprised to hear this."

Source: https://www.reddit.com/r/ASUS/comments/kaqnec/beware_of_asus_x570_m2_bottleneck_before_buying/

That doesn’t match my findings.

On the MSI MEG x570 Godlike, M2_1 and M2_2 are PCH, M2_3 is CPU.

But only M2_1 is throttling, so the first of the PCH slots. The others, which includes PCH and CPU, are working at full speed, M2_3 using an 850, M2_2 using a 980 Pro 1TB.

Also, before I swapped to the 850 for my OS drive on M2_1, I had a Samsung 980 Pro 500GB and prior to Samsung screwing up the turbo write and binning out write speeds, it was also working at full speed (and the Samsung firmware due end April fixes this turbo write clearout problem too).

Update, spoke to MSI support and after a few emails going over the situation, they’re going to perform some tests with my mobo and let me know what they find.

Would be good to hear what MSI have to say, here is what Asrock told me for same issue of slow write speeds with SN850 on X570 chipset lanes:

MSI came back and asked that I try with the latest BIOS, 1.D3, which made no difference. I’ve sent back a full bench of all NVMEs across PCH and CPU lanes, to prove that it’s only the SN850 on a PCH lane which is being capped on write speeds in this way.

More info when I have it.

From MSI…

We have tested the SN850 SSD on the MEG X570 GODLIKE motherboard. When it is installed on the M2_1 and M2_2 slots, the writing speed is only about 3255.75MB/s. We also tested this SSD with ASUS X570 motherboard. When we installed it on the M.2 slot from the PCH channel, and its write speed is also only 3242.07MB/s. Then use Corsair MP600 1TB SSD to test this issue again, but its speed is normal. After that, we communicated with relevant departments. As other brands of SSD do not have this problem, which may be related to the SN850 SSD itself. We suggest you contact Western Digital to check if the SN850 SSD has new firmware to update

So that’s now MSI, Asus and ASRock brands that all suffer from capped write speeds when the 850 is installed to PCH M2 slots.

I’ve gone back to Western Digital support, via my original ticket, with this response and requested that its escalated.

WD Support came back and asked for the same things I’d already previously submitted, so SMART results, Firmware revision and bench results. I’ve sent it all back in again.

Ever get the feeling you’re just going around in circles…

WD have now requested my msinfo, which I’ve supplied.

Adding in that I’m seeing the same with my WDS100T1X0E-00AFY0 1TB on an MSI MPG X570 Gaming Pro Carbon WIFI with the latest BIOS.

The WD Dashboard app shows over 800GB free, am on firmware v613000WD and the drive is healthy. I’ve tried with Gaming Mode on/off, but weirdly I can’t run any of the S.M.A.R.T. diagnostics tests, they all just say “Operation failed.”.

I’ve reinstalled with the latest WD drivers, and all my AMD chipset drivers are also up-to-date (as are my Windows Updates, too).

I’m currently running the drive in M2_1 slot, should I be using the _2 slot instead?

It really comes down to your M2 slot configuration. The M2 slots can be Chipset (PCH) or CPU, so you need to determine that first and then ideally use the CPU slot. In my case, using the CPU slot works full speed with the 850.

Funnily enough, I also cannot run the SMART test with the same "Operation Failed " error. I expect its not designed for the 850 and is incompatible in some way. Hilarious how, when they have this info, WD Support still keep asking me to use it…

WD support came back and offered a drive replacement, which obviously won’t fix the problem because the drive works at full speed on the CPU slot and we now have MSI, Asus and ASRock motherboard brands also confirming the limitation on PCH slots and success on CPU slots using their own 850s.

WD support also suggested it was a motherboard issue but provided no further information, such as if they mean my motherboard is faulty. However, again, that can’t be the case if we also have MSI, Asus and ASRock motherboards all confirmed as being affected on their own motherboards, with their own 850s.

Far too many coincidences if the above is true. Far more likely that the consistent factor, the 850 itself, is the responsible party. Which I’ve gone back with.

WD support came back again and offered a very loose and non-committal response. As follows.

Indeed since the drive works as intended in one slot, this means that this should be a firmware issue of the motherboard. We are working on bettering our products and services and this issue has been noted and if any issues are found on our side we will work on releasing a firmware update to fix it. Unfortunately I cannot assist further with this issue as we have not tested our drive with every motherboard model therefore we cannot guarantee that it will be compatible with all the models.

So to me this raises some questions…

  • Why are WD still pursuing this as being a firmware problem on the motherboards, when several brands of motherboards all report the same issue?

  • How many chipset revisions are out there that support GEN4 M2s? I can’t imagine there’s many, so why are they saying they haven’t tested ‘every’ motherboard model? Surely you’d have checked GEN4 motherboards?

I’ve requested a list of supported motherboards that have M2 PCH slot write speeds running to specification. Because now, this all feels like redirection of blame. The consistent factor here is the 850. Not my specific item but the 850 range itself, as seen by MSI and ASRock both testing 850s on x570s and seeing the exact problem.

WD Support came back with the following…

The fact that the drive works with the intended speeds in one of the slots but not the other points out that there is some sort of issue with that specific slot of the motherboard.

You can put the drive in that slot and use WD Dashboard to make sure all settings are up to par.

Furthermore, I can request the compatibility list from our engineering department if you wish, as it is not readily available

So once again, they ignore the confirmation of the problem across several motherboard brands. I have requested a specific list of supported GEN4 motherboards when using a PCH M2 slot and as you can see, apparently that list is not readily available…for some strange reason.

The more this goes around, the more its becoming clear that WD are attempting to cover up a hardware level incompatibly on the SN850.

There are issues with the 850 ssd!
°slower speeds on pch nvme slot
°requirement to reboot on first boot to recognize the drive in BIOS

And WD customer support is a bad joke - simply telling you the motherboard BIOS causes the problem, but why do my other nvme ssd’s work perfectly fine with the bios?


Never had issues with my samsung drives!

I can confirm that there is a problem with sn850 running on M2 chipset slot PCH of X570 motherboard. I have replaced sn850 with Samsung 980 pro and now I get read speeds 6300 and write 4940. With Wd sn850 I was getting 6300 and 3200. Both drives have the same capacity of 1Tb. Sn850 is now placed on M2 slot running from the CPU lane and is working with published read and write speeds. Motherboard is Gigabyte x570 aorus master. I sure hope that WD will be able to fix the problem with a firmware update because I still have one more sn850 on my third slot that is also running from the chipset and write speed is 3200.