Fixed light for 20sec then flashing - My passport essential se 1tb


My hd does not work anymore.  When I plug it, the light is on for about 20 seconds

in the meantime it emits  repeatedly a strange noise:  a uniform noise for one second and then a shorter, higher tone noise. Then the light start to flash, and there is no sound anymore.

I use linux.  When I plug the cable nothing happens. Even dmesg does not report the usb event.

On windows I tried to upgrade the firmware, but it is impossible because the software don’t find any hd.

I changed the cable too. I used the one I use with my nokia cell, but nothing changed.

Could you help me? What can I do? Is There any tricky solution that can save my data?

Should I send it to a Data Recovery company? Does the warranty process recover my data?

Please help me!

Thank you.

Looks like you have try all of the steps required to determine if drive failed. You can send it to a Data Recovery company but WD does not cover that. Warranty will cover the replacement of the unit.

It’s unlikely that a data recovery service would be of much use.  Anything they retrieved off the drive would still be encrypted.

Have you tried a power booster cable to make sure the drive is actually getting its required power?