Fix the USB Backup Failure (its a TIMEOUT Problem) OR Safepoint

See the post. RSYNC gives up on large jobs when no data is transferred in 30 seconds. Either eliminate, set to much larger number, or let the user choose.

Alternatively, bring back SAFEPOINT for WD MyCloud EX2 Ultra series.

5 Likes

Status: Acknowledged

Idea submitted for voting.

Where do I vote?

“Likes” given to your idea by other members of the WD Community are counted as supportive votes.

Since you are the creator of this Idea your own vote is not counted.

This looks to be be more of a bug of sorts that an idea and it won’t surprise me if other NASs are affected by the same issue.

1 Like

Interesting point, but it was an intentional choice by the designer to use this RSYNC feature which is working by design. Maybe WD could revisit the decision.

However, if you look at the SAFEPOINT feature of the other WD MyCloud products, one could schedule a full backup of the system to a USB drive, regardless of run time.

If others are relying on the WD MyCloud EX2 Ultra as I am for LAN based cloud storage, then, like me, they are probably keeping an off-site backup too. In other words, I have 2 USB drives such that on a weekly basis, I rotate the drives which keeps my data safe (albeit at most, one week behind.) That frequency works for my needs without subscribing to internet cloud storage.

Looking forward to the votes.

Any updates to this issue where backups from NAS to USB are failing? It’s Nov 2018 and I seem to be experiencing the same issue. If I create a back up job for all Shares, it fails. I’ve tried to create backup jobs for individual Share folders. The smaller Share folders complete successfully. The largest of my Shares keeps failing.

Any work arounds? I’m thinking of splitting up this Share folder into smaller groups of files, but really seems like it could end up being a pain for file management. Or I end up purchasing dedicated backup software, Arq Backup, that can backup NAS drives.

Aerial all you have to do is to configure from the dashboard of the mycloud device itself.
Make sure DAS drive is connected with NAS device. Check under USB setting of dashboard.
Create the job point and select the destination and select the file to create the job type. And source destination which is your external DAS drive.

Firmware has to be up to date. USB configuration has to be enabled.

Thanks gamerduke. I have the Backup jobs setup. I have 4 Shares. 2 of the shares will backup, but 2 of them will not backup. The backups for the 2 Shares that fail will start backing up, and will run for hours, but eventually ‘fail’. I can navigate to the USB drive and see that files are copied onto the USB drive, but it doesn’t complete to copy all of them. These 2 shares that fail used to be in one single Share. I split it up thinking it had too many files. No matter how many times I try to run the backup job it still Fails (I’ve tried each job at least 5-6 times).

Whats the capacity of the USB drive and file size that you are transferring. Might be drive capacity is full or check and delete all the job and recreate the job, separate job each for the share. And start the backup again. Might be there will be technical glitch with the device, reboot the device and start the job again.

aerial check each share has read and write option enable from the dashboard. User and share setting.

It’s an rsync settings problem as described above. Running the command manually without the --timeout works just fine. Easy fix once a developer looks at the symptom and suggested resolution.