FIX: How to find network shares again

Short version:

Give your WDTV a static IP

Intermediate version:

Settings -> Network Settings -> Network setup -> Manual -> IP address

There you will find something like:

Example 1: 10.0.0.23

Example 2: 192.168.2.24

Change the last digit to 254

Example 1: 10.0.0.254

Example 2: 192.168.2.254

don’t touch the other numbers.

Long version:

Your router automatically provides to all connected devices, an unique IP adress wthin a certain range (DHC Protocoll).  e.g. 10.0.0.2 - 10.0.0.100 or another example 192.168.2.2 - 192.168.2.100

The first 3 numbers have to be the same, the last one defines the range, the biggest possible number is 255. So in the both examples, your router can provide 99 unique addresses (the x.x.x.1 is always the router itself). Everytime a device connects, it gets an IP out of this range. Everytime it disconnects the IP gets available again. So the IP can change everytime you reconnect. With a static IP, the device tells the router which IP it wants to have, this has the advantage that it always gets the same IP. Why did I tell you all that? The static IP has to be outside of the DHCP range!  This means in our examples, the first available static IP would be 10.0.0.101 and in the second example 192.168.2.101.

So if you have any trouble, log in to your router settings and check which IPs define the DHCP range in order to select a static one, that works.

Please leave a note if this works for you.

regards, Dave

EDIT:

To be honest I don’t know why the “fix” helped, but for me it did. All devices in an Local area network which have the first 3 digets (e.g. 192.168.1.X) in common  can , or in case of the poroblem with the latest WDTV Firmware:  should be  able to detect themselves automatically. For all devices in your LAN you can decide seperatly if you want to give it a static IP or and dynamic one out of the DHCP Space your router offers.  Still hoping this help some of you, suffering from the problem.

rgeards, Dave

3 Likes

Thanks for the info on this fix.

One thing. I assume these changes are made in the WDTV player, and NOT your router ?

Looking in my router settings at Network, my IP range is 192.168.1.100 > 192.168.1.149

EDIT:

Went into WDTV settings and changed IP to 192.168.1.150 and no go. Still cant get network shares.

Tried changing last digit to larger number like 254 but got an error and it would not let me set it so why I used 150 instead.

Not sure if my IP changes as you say anyway becasue every time I have looked at it in the player settings, it has always read 192.168.1.127 and I just did auto IP and it gave that IP back to me.

exactly, the changes have to be made just in the WDTV.

1 Like

Not working for me … edited my last post …

EDIT:

OK I got it to work. I set 256 last time by mistake and this time tried 254 and although it did not work at first I reboot my router. I then was able to conect to network shares. I turned off player (because rebooting router even before change I could access network shares but then after turning off unit and back on, network shares were gone again) so I could check and sure enough I could access them again.

Now that this seems to be a fix, it created something I do not like. Some reason I have USERS folder and do not want.

I have a ONE folder made to pop up when going into network shares (Movies) and now I have it, along with USERS and all the subfolders that come long with it. How do I remove that.

KUDOS for the help/fix though. Glad I can now stream from my PC !

EDIT 2:

Well I guess that didnt really work. I left unti off for about 20 minutes to fully clear (gray out)  from Printers and Devices list and turned unit back on and no Network Shares … I give up. Only way to get Network going is to reboot router and thats all that happened last time when I though IP change did it.

Such a bummer …

@Dave. Workaround with fixed IP seems to have solved my (periodic) connection issues with network shares (NAS, Linux, Samba).

Just for information: my previous workaround was to wait approx. 7 seconds after i selected “Networks shares” menu option, press OK, wait approx. 7 seconds before you select the server. That worked 8 of 10 times. Maybe that will lead WD to a root cause (and hopefully fix it!).

But changing to static IP might be an interim solution. Thanks for the tip.

How are you guys getting this work ?

Did I enter the wrong numbers ?

I went into WDTV network settings and listed IP as 192.168.1.254 … isnt that correct ?

I am to assume this is for wired connection or does it matter wired or wireless ?

fstrange wrote:
But changing to static IP might be an interim solution.

Actually, using static IPs on your own LAN should be best practice for devices that are connected regularly. You assign the IP once and are done with it. For devices that are connected every now and then or if someone visits you with his smartphone you can still run a DHCP server that assigns higher numbers (like .200+) so you won’t get confused about who is who.

I’m using DHCP for my WDTVs since I’m constantly testing different firmware versions and keying in static IPs with the remote is a PITA compared to how it’s done in XBMC. Now that I’ve finally told my router to assign the same IP to a certain WDTV, my network troubles are gone.

So can anyone tell me if I am doing this right ? I assume I am but I may be missing something. Seems that this is an actual fix for those who try but I still can not see network shares after doing so.

Do I need to do anything in my router settings ?

Works like a charm!  thank you so much… love the support

Sadly my experience is the same as yours.  I’ve had my WDTV set up with a static IP address since before the firmware upgrade and still have the network shares issue.  I’ve tried all of the advice in this and the main firmware thread and so far none of it works permanently.  The solutions that work last only for a few hours, then it goes back to not seeing them after a power cycle.  I’ve given up on this firmware, rolled back, and blocked the upgrade server in my DNS so it’ll stop prompting me to upgrade every time I turn it on.

While I can not get this Static IP fix to work, I finally found my solution.

This may or may not work for anyone else but here it is.

I changed WORKGROUP name on PC to WORKGROUP-US (can add anything I guess after adding the ‘dash’ (-)

For Windows 7 Users

Click Start then Right-Click on My Computer and choose Properties

Click Change Settings at the Right where it lists Computer Name and Full Computer Name and Workgroup.

When you get the popup, click the button that says Change

When you see the next dialog box, under WORKGROUP is a name that should read WORKGROUP.

Just add a dash (-) and anything else like PC or something.

After making the change the PC will want to reboot so do it. I made NO changes to the settings in the WDTV unit nor my router settings.

My PC rebooted and I went over to my WDTV player, turned it on and waited for it to boot up. Got the stupid New Firmware notice but ignored it and went straight to _ Video _, _ Network Shares _ and what do you know, my PC was listed and I clicked it and my folders showed up ! I was able to stream as though nothing happened.

I checked the Internet stuff and all that stuff was fine. No changes. I checked Network Settings and everything was the same as it has been.

One thing I did notice was my HP Color LaserJet 3000 was showing offline (hooked up via RG45) when it was fine before. So I checked it’s IP in my router settings and saw that it had changed. So I simply changed it to that IP in the Printer Properties/Ports and all is good.

So not sure WHY making that change did anything and why I didn’t have to make the name change match in the player, but whatever works to get my network streaming back …

This doesn’t work for me … this media player is headed for the garbage and WD is not getting any more of my hard earned cash. [Deleted]