Fix corrupted system

Hello !

My WDMC is broken.
First I started by breaking the SSH access by setting PermitRootLogin to no in sshd_config, and I managed to resolve this by reinstalling the latest firmware.
Now I succeeded in corrupting the system by launching apt-get update, then apt-get upgrade, which resulted in unsolvable dependency problems (if you want to know why I did this: I wanted to mount a truecrypt device to copy directly from disk to disk because over the network it is 6MB/s fast, and I have already almost 2TO of data to copy and I didn’t want to be waiting for 3,85 days, BUT  truecrypt couldn’t be launched, I don’t know why, so I wanted to install tc-play instead, but it was not found in the archive, so I run apt-get update, still unfoundable, then upgrade and ooooooooh sh*t, apache2 won’t start anymore)

Of course, as I always do the bad things before the good ones, I asked for a reboot before re-reinstalling the firmware.

So basically, now the system won’t start. Red LED.

It means I cannot access the web interface.

As playing with root already voided the waranty, I opened the whole thing and disconnected the 2TB storage of the OS module.

Now my question is:

how can I “flash” this module’s memory to reinstall the latest firmware and override all my mess :slight_smile: ?

PS: I received it today, I am really quick at breaking things.  If I can’t fix this, I will probably buy another one with my summer job’s pay.

Hi pawamoy, see if the following threads help?

1 Like

Thank you, it seems to be the solution I"m searching for.
I was afraid that the system may be on the little motherboard, but it makes sense that it is on the disk instead.
I will try this afternoon to connect the disk to my computer with a dock and use dd to reinstall the rootfs.img on it.
I will let you know if it worked !

I finally managed to fix my WD MyCloud !!

Here are the steps I got through:

  • first I opened up the box, got the Hard Drive out and plugged it on my laptop (SATA to USB)

  • then I tried to restore the rootfs.img file from the latest firmware onto the two RAID partitions, but it didn’t work

  • so I tried to restore the entire disk image with those findable on these pages:

  • BUT IT FAILED AGAIN (I’m afraid compression/upload and download/decompression might have corrupted the image)

  • so I bought another WDMC, upgraded it to the latest firmware, plugged another disk on it, then backup all partitions on this disk except the 4th (the extended 1.9TB one) through SSH, with that command: dd if=/dev/sda1 of=/shares/YOURDISK/partition1 (repeat for /dev/sda2, 3, 5, 6, 7 and 8)

  • at this time I was able to restore the seven images one by one, using Disks utility on Linux (dd would also have worked I guess), AND IT WORKED

  • I just had to do a Quick Restore because the web interface said 0Ko free space (Quick Restore is always good after debrick)

So, to summarize, I

  • downloaded the entire disk image (link above)

  • wrote it on the WDMC disk

  • used clean WDMC partitions (all but the big one) to restore those on the WDMC disk

  • (did a Quick Restore)

If anyone needs them, I can upload them on something like Mega or Uptobox. The problem is that it is about 5Go, so it would take some time. I can compress them using 7zip but again, I fear data corruption by doing so.

Anyway, many thanks to the community :slight_smile: !!