FIX #2 - Network Shares

I already made a post about a fix I tried in another thread FIX: How to find network shares again

However, I thought maybe I should bring more attention to it than sitting at the end of a thread, falling down the line.

The fix in the other thread consisted of simply adding a Static IP to your WDTV unit. It worked for some, but unfortunately it didnt work everyone, including me. So after reading many posts around the net I found a fix that worked for me and may work for others. I found it on this very forum titled Re: Network Shares Drop

Basically, all you’re doing is adding on to your Workgroup name from WORKGROUP to WORKGROUP-PC

You can add anything but you do need to add the ‘dash’ (-) and something else. Give it a try and see if that works for you to get connected to your Network Shares again.

*I did NOT however have to change the name in my WDTV unit unlike the poster said in the last link. My WDTV settings still say WORKGROUP

 

I do not know how it is working, but it is and that’s all I care about !

One thing I did notice was my HP Color LaserJet 3000 was showing offline (hooked up via RG45) when it was fine before. So I checked it’s IP in my router settings and saw that it had changed. So I simply changed it to that IP in the Printer Properties/Ports and all is good. You may have to do this if you have networked printers or other devices.

1 Like

thanks for sharing.

Kudos to you.

If possible, I’d like those who tried it to write down if it worked or not.

This may also be a look into a solution to why it ‘broke’ and they can fix it in the next update (if they are doing one)

I am curious as to your software enviroment as I may want to try your suggestion.

What version of Win7 and are you also running windows live essentials 2012 or similar?

If I could run live essentials with this fix, that would be great…

Thanx,

 Kid

I am running Win 7 Ultimate 64

I am not running any other software. I simply stream from my PC to the WDTV Live Plus via network cable with my router (EA3500) being the ‘middle man’

I have still not run into any issues using this ‘fix’. Fact my kids are streaming a movie as I type this.

My SMP connects just fine without any dash in the workgroup’s name.

So you saying you just added a couple more letters without a dash and it worked the same ?

I did not try NOT adding the dash but if that works just the same then good. At least we know.

I wonder if changing the name completely works as well ?

While this all may work well enough, I do hope WD creates a fix so there is no need to alter the WORKGROUP name in the first place.

No, what I’m saying is that WORKGROUP works for me as well as any other random name. And I’m suspecting that your approach which the dash simply worked because you switched to a different workgroup.

If I follow what you are saying, is that you made no change, because you didnt have to. That isnt what this thread is about.

If you had no need to change the name or had no network issues, then I dont get why you even posted ?

I posted this to help with those who lost network shares and by adding on to the name WORKGROUP, it gets them back.

Everyone starts off with the name WORKGROUP in Workgroup when they install Windows or buy a PC

I simply said to add on to that to get network shares back after faulty WD firmware.

I’m posting here because I had network problems that I solved without your solution, simply because Fix #2 isn’t one. Adding a dash to the workgroup is not necessary. It rather worked for you because you changed the workgroup on several devices which probably made your router re-recognize them. My router was confused by all the WDTVs popping up on my network and once I deleted all network info and set it to assign the same IP to each device on every connect, it worked.

You failed to read my ‘fix’ correctly.

I ONLY changed WORKGROUP to WORKGROUP-PC  on my computer I share from. I did NOT change ANYTHING ELSE on any other device.

Also. If this fix was not for you, then why did you post ? If you didnt need to do anything then why bother saying you didnt need to do my fix ? If another fix worked, then good for you. Just because my fix wasnt used doesnt mean it didnt work for me or for anyone else.

This fix was for those (like me) who tried static IP and it didnt work. If that one worked for you then good. No need to come in here and say this one didnt work if you didnt even need to or even try it. It’s not like this was an opinion poll …

WDTV619 wrote:
I ONLY changed WORKGROUP to WORKGROUP-PC  on my computer I share from. I did NOT change ANYTHING ELSE on any other device.

Which makes this even more unlikely to be the reason of fixing the problem. I’d be interested to see if anyone here chimes in claiming it also worked for them.

I’m with Techflaws on this one. If the name of the workgroup is “WORKGROUP” changing the workgroup on the WD to “WORKGROUP-PC” should actually prevent the WD from accessing the workgroup named “WORKGROUP” it’s interesting that this works for you

Once again … NOT PAYING ATTENTION !!!

I changed to WORKGROUP-PC on MY COMPUTER ONLY !!!

How hard is it to read you guys ?

I also never claimed WHY it worked but that it just did.

One day my network shares were no longer available. I tried everything from resetting WD to giving the WD a static IP and made changes in my router. Nothing worked. I read another thread on here about changing WORKGROUP name on the computer that the shares are on and it worked.

Again. I made NO changes to router or WD when this change was made. I had set those devices back to what they originally were before changing WORKGROUP.

@WDTV619, why are you so upset about people posting input?

we appreciate you’re trying to help others, but you should understand

that we want to know if this is an actual solution, or just a fluke

what I said above still holds true

Workgroup must match on both devices for workgroup authentication to work

if you only change the workgroup on 1 device, it should become inaccessible by other devices not in the same workgroup

your fix is the exact opposite, and should break workgroup authentication on properly working devices

I get upset when my words are misunderstood and replies end up confusing others who may want to know what I did.

Many people do not read full threads and go straight to the last post and if they read what you guys thought you read, then it can create problems.

As far as my solution and how it should not work, again, I do not know how or why, but it just does.

I have been using this ‘fix’ for nearly a week now and have yet to have any issues getting to my network shares on my PC.

All I can say is try it. No harm in that, is there ? If it works. Great. If I doesn’t, then change it back. I did the same when looking at others’ so called solutions/fixes.

So far this thread is filled with ‘this should not and can not work’ and yet here I am saying it does because I am using the ‘fix’ !

PC Workgroup = WORKGROUP-PC

WDTV Live Plus Workgroup = WORKGROUP

Don’t take offense but I’m with Techflaws on this…I’ll bet you could have changed the workgroup name to anything (except WORKGROUP) and it would have worked.  The dash had nothing magical about it.  The act of changing the name “flushed” and re-initialized something that made things be recognized again.  I’ll bet if you change it back to WORKGROUP on your PC it’ll still work.

I can understand the dash issue. Fact I probably should have not said it needed a dash.

I also think I will try and put it back to just WORKGROUP (been wanting to actually try that) and see if things stay the same (network shares available)

My so-called anger about the replies was because I was sort of being told this can not work and should not work, when I was sitting here experiencing it work ! I didn’t know how or why, I just know it was working and I was able to stream my stuff again after loosing network shares. I was also a little upset when people weren’t reading my posts correctly and that may have confused users. I stated many times that I only change the name on my PC and it was being relayed that I changed the name on all sorts of devices.

I just figured I would share this ‘fix’, be it temporary or whatever so users could stream on their network once again until WD can figure out how to put a fix.

It just didn’t make sense unless of course being in the same workgroup wasn’t necessary anymore. So I started up the LIVE without being connected to the network and set it’s workgroup to WORKGROUP while all other devices on my network stayed on STRAYLIGHT. And what can I say, despite being in the different workgroups the LIVE could connect to my NAS shares immediately.

You set what to WORKGROUP ?  Your WDTV unit or you made that name change on your PC ?