First time DvDFab user.. no audio sound

… after first dvd rip/convert - Mkv format…

hi community… 

i’ve decided to rip all my dvd disc to my nas using DvDFab… i just done my first rip and tested the Mkv on my WDTVLive and whilst the picture quality is good… there’s no sound coming through my speaker… I’ve never rip convert a DVD before and perhap set the audio setting wrongly before processing… i’d select the 5.1 dts audio box in DVDFAB… or should i have select AC-3/2 5.1 or AC3/2…??

here are the mediainfo of the dvd i’ve rip/convert:

Format                           : MatroskaFormat_Version                   : Version 2FileSize/String                  : 1.37 GiBDuration/String                  : 1h 22mnOverallBitRate/String            : 2 361 KbpsMovie                            : SHOOT_EM_UP.Title1.DVDRipEncoded_Date                     : UTC 2011-08-03 14:02:57Encoded_Application              : DVDFabEncoded_Library/String           : libebml v0.7.8 + libmatroska v0.8.1

VideoID/String                        : 1Format                           : AVCFormat/Info                      : Advanced Video CodecFormat_Profile                   : Main@L3.0Format_Settings_CABAC/String     : YesFormat_Settings_RefFrames/String : 2 framesCodecID                          : V_MPEG4/ISO/AVCDuration/String                  : 1h 22mnWidth/String                     : 720 pixelsHeight/String                    : 312 pixelsDisplayAspectRatio/String        : 2.35:1FrameRate/String                 : 25.000 fpsColorSpace                       : YUVChromaSubsampling                : 4:2:0BitDepth/String                  : 8 bitsScanType/String                  : ProgressiveEncoded_Library/String           : x264 coreColor primaries                  : BT.601-6 525, BT.1358 525, BT.1700 NTSC, SMPTE 170MTransfer characteristics         : BT.709-5, BT.1361Matrix coefficients              : BT.601-6 525, BT.1358 525, BT.1700 NTSC, SMPTE 170M

AudioID/String                        : 2Format                           : AACFormat/Info                      : Advanced Audio CodecFormat_Profile                   : LCCodecID                          : A_AACDuration/String                  : 1h 22mnChannel(s)/String                : 6 channelsChannelPositions                 : Front: L C R, Side: L R, LFESamplingRate/String              : 48.0 KHzCompression_Mode/String          : Lossy

My connection are as follow… HDMI pass through —> WDTVLive to Sony STR AV reciever… AV reciever to TV via HDMI… 

please advise what i done wrong… thanks


check this :

* on screen of your  TV set  in WD HD  “audio options”  pls change/shift  to/from :  “stereo”  and check



You did NOT select DTS, or DVD Fab messed up, because your audio was saved as multi-channel AAC.

The WD’s don’t support multi-channel AAC.  

You should just leave the audio AS-IS, without changing it.


audio sound plays when  stereo is selected in video/audio setting…

pretty sure i DID select DTS…

i will try rip another dvd following your advice and not change audio AS-IS… will post the result later

hmm… confused now lol

stuck in another dvd to rip… gladiator

i can see the generic at top of pic2 is h264.acc        —        should that be change and if so to what…?

wd1.png wd2.png


The problem you are having is because you selected the AAC profile, which transforms the selected DTS audio into the AAC format (not fully supported by the WD TV Live Plus).

I rip all my Blue-Rays and DVDs using the MKV.h.264.audiocopy profile in DVDFAB, and select 2 pass for better visual. This preserves whatever audio format I select (DTS-HD, TrueHD, DD 5.1, etc.) usually in AC3 format, and produces an MKV file between 4 and 8 GB per movie (the better the sound, the bigger the file).

It gives me excelent video and audio quality despite the compression ratio. DTS-HD is passed-through as DTS by the TV Live Plus (no DTS-HD licence on the box I believe), but TrueHD is supported.

If you need to put more than 1 audio track in your MKV, then you could use the MKV.Remux profile. The resulting file will be bigger than with the h.264 format though (20-40GB depending on the movie).

Best regards,

1 Like


Thanks for the detail explanation dude… appeciated it.


Where do you select the 2 pass option?  I noticed my video was a little choppy with the default settings.

***Never mind - found it under Encoding Method

also what’s the recommended frame resolution?  Does it pull it from the DVD source and recommend?  I noticed the default for bugs life seems to be 720 and not something higher… is that because it’s not blu-ray?